
 

1 
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IMPORTANT 

 

These instructions assume you will be using the ORD WorkSpace located on CADD Services’ website. 

 

CONFIG FILE 

As of 5/25/2022, the zip file published by CADD Services does not have the config file for the “None” role.  

Having this file is a necessity for creating line styles.  Until CADD Services zip includes this file, in the 

interim, you can easily add the config file yourself to the workspace. 

 

The reason for having the “None” role is when creating a new line style (this applies to creating new cells 

as well) if you open an existing cell or line style library file you will only be able to use the cells or styles 

existing or embedded in the file (the line style or cell is already drawn in the file).  Choosing “None” allows 

you to import from any library to use in creating a new one. 

 

Do this by following these steps: 

1. Create a blank text file using a simple text editor such as Notepad or UltraEdit.  Name the file 

None.cfg and place one line in it which states, “DoNothing=0” and place one extra blank line after it, 

see below. 

 
2. Save this config file into this location: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\WorkSpaces\DOT-US North Carolina\Roles 

3. This will allow the “None” role to be available. 

 

TOOL NAVIGATION 

Navigating to specific tools may require you to go to a specific Workflow, Tab, Tool Group, and Tool or 

Tool Dropdown.  These are identified this way: 

Workflow > Tab > Tool Group > Tool/Tool Dropdown 
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IMPORTING A CUSTOM LINE STYLE FROM ANOTHER SOURCE 
Following these steps will allow you to import a line style into your library from another source such as a 

unit or discipline.  This example will show copying the HPB line style from the Roadway WorkSpace into 

the EAU WorkSpace. 

 

The “NCDOT_Roadway” workspace is located under NCDOT Training\Development in PW. 

\Documents\Administration\Bentley\Configuration_10_10\Organization-Civil\Disciplines\ 

1. Export the “NCDOT_Roadway” workspace to your Disciplines folder on your C: drive 

The redacted portion will have your specific email in the parentheses. 

 
 

2. Open Microstation Connect edition 

3. Set the WorkSpace to DOT-US North Carolina and the WorkSet to Admin-XX (where “XX” is whatever 

letters designate your discipline i.e., RD=Roadway).  Every discipline has an Admin WorkSet.  The Admin 

WorkSet allows you to create levels while loading your WorkSpace, the regular WorkSets will not. 

4. Open the DGNLIB file cls_heu.dgnlib located here: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Environmental_Analysis\Standards\Dgnlib\Line Styles 
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5. As the file is opening, you may have a window pop that asks you to confirm whether you want to open 

the file with no WorkSet or use the last one used.  Be sure to select “Open the file with No WorkSet”. 

 
You can check to confirm there is no WorkSet by mousing over the WorkSet icon in the lower right of the 

Microstation window and it should indicate “There is no active WorkSet” 

 
6. Open the Line Style Editor.  Go to the Attributes tool group, click the drop-down for line styles and 

select “Manage…” at the bottom. 
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7. Go to the Attribute tool group, the line style drop-down, then click “Manage…” which will open the Line 

Style Editor, then go to File>Manage… 

 
8. Select your destination library first.  This will be your unit’s new ORD resource file (eau_cls.rsc) located 

here: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Environmental_Analysis\Standards\Dgnlib\Line Styles\RSC Backup\ 

9. At the Manage Line Style Definitions window go to File → Open Source File… then select resource file 

where you want to import the new line style from.  In this case, to import the HPB line style FROM 

Roadway’s resource library you will select the rdy_cls.rsc file from here: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Roadway\Standards\Dgnlib\Line Styles\RSC Backup 
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10. Select the line style(s) you want to import (in this case RD_HPB).  Use the [Shift] key to select a 

continuous range or the [Ctrl] key to highlight multiple files not in the same range. 

 
 

11. Rename the new style with your unit’s initials.  In this case it would be named EA_HPB. 

12. Exit the file 

13. In the WorkSets.inp file change the NCDOT WorkSet to L2 and the unit WorkSet to your unit (listed in 

the paragraph above the setting). 
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CONVERSION OF V8i LINE STYLES TO NEW ORD LINE STYLES 
This first step will convert old V8i line styles so that the scale is corrected for the new annotations scale.  If 

you ever need a specific level from a Workspace you load the Workspace with that level.  However, when 

creating a *.dgnlib, like the “cls_rdy.dgnlib”, where line styles will actually be drawn in the design file, or 

a Workspace file that does not depend on loading any workspace. 

 

1. FILE CREATION 

A. Open Microstation Connect edition 

B. Set the WorkSpace to DOT-US North Carolina and the WorkSet to Admin-XX (where “XX” is the 

letters designating your discipline e.g., RD=Roadway).  Every discipline has an Admin WorkSet.  The 

Admin WorkSet allows you to create levels while loading your WorkSpace, the regular WorkSets will 

not. 

C. Create a new blank CADD file.  Use a standard 2D seed file, give it the normal “dgn” file extension, 

and save the file in your unit’s folder, the highlighted portion below: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-Civil\Disciplines\ 

NCDOT_Environmental_Analysis\Standards\Dgnlib\Line Styles 

D. Go to OpenRoads Modeling > Drawing > Primary > Key-in tool which looks like a cluster of 

three keyboard keys 

 
E. Type in “file disassociateworkset” and hit [Enter]. 

 
F. Go to File → Close or you can completely exit Microstation, but DO NOT do a save settings on 

this file before closing/exiting, or it will go back to the active WorkSpace and WorkSet used when 

initially opening the file 

G. Reopen Microstation (DO NOT open the file yet) and first choose “None” for the Role, then choose 

“No WorkSpace”.  The WorkSet should automatically set to “No WorkSet”, select your file again and 

open it. 

H. Close the file and reopen it, making sure the “No WorkSet” & “None” Role are selected again.  

Reopening the file this way ensures any previous WorkSets or Roles are cleared out of the 

Microstation cache. 

I. You can check to confirm there is no WorkSet by mousing over the WorkSet icon in the lower right 

of the Microstation window and it should indicate “There is no active WorkSet” 
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2. RESET THE SCALE 

NOTE: This is only used to import and revise the scale on an older V8i resource line style library into an ORD 

resource file 

A. Go to the Attributes tool group, click the drop-down for line styles and select “Manage…” at the 

bottom. 
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B. The select File → Import → Microstation Resource File (RSC)… 

 
C. Then path to C:\NCDOT_V8_WORKSPACE\Ncdot_Stds\English\symb and select the rdy_cls.rsc file, 

or whichever file you need to modify for your unit. 

 
D. Select the line styles you want to modify the scale to 1.00000:12.00000 and click on [Import].  This 

will import the selected custom line styles into the *.dgn file at the scale chosen. 
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E. It may appear that nothing happened.  To check they were imported, go to the Attribute tool 

group, click the drop-down for the line styles.  You should see only the Bentley default line styles 

(because the file was disassociated) and your imported line style(s), in the red box in the middle 

image below.  Notice the two styles that were selected to be imported RD_AUE, RD_BW, and the 

custom one RD_Oak is already shown in this example because it was previously created.  The rest are 

default styles for Microstation. 
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Something else to consider is if you desire to revise the names of all the old levels.  This method is 

recommended as it makes it easier to determine if you are choosing the new line style that’s been 

redesigned/rescaled for ORD vs. the old one, because it will have a new name.  However, the Line Style 

Editor does not allow you rename styles.  The renaming must be done through the Manage Line Style 

Definitions. 

F. Go to the Attribute tool group, the line style drop-down, then click Manage… which will open the 

Line Style Editor, then go to File → Manage… 

 
G. At the Manage Line Style Definitions window go to File → Manage… and it will have you select 

your Destination library first, from there you go to File → Open Source File… then select your new 

resource file. 
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H. Source (old “rsc” file in V8i) is on the left and Destination (new “rsc” file) is on the right. 

OLD = path to C:\NCDOT_V8_WORKSPACE\Ncdot_Stds\English\symb and select your unit’s resource 

file (i.e., Roadway=Rdyls.rsc) 

NEW = path to your unit’s (highlighted folder below) new resource file (or the one being made for 

this exercise, Roadway=rdy_cls.rsc) 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Roadway\Standards\Dgnlib\Line Styles 

 
I. When you rename the custom line style, then you can import it into the dgn library.  The one 

renamed is the destination. 

J. Once you are done with renaming/re-scaling/importing your edited line styles you can exit the file 

and rename it with a “dgnlib” extension. 

K. Save the new/revised library here:  

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Roadway\Standards\Dgnlib\Line Styles  

L. Line styles need to be edited through the “rsc” file.  The “dgnlib” is the product of the line style 

“rsc” file that makes the line styles portable.  Portable in this context means when a line style from a 

“dgnlib” is placed by a user in a “dgn” file, it is saved as a part of that file.  If you only used a style 

from an “rsc” file, you would need to send the workspace along with the file to anyone. 
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CREATING A CUSTOM LINE STYLE FROM SCRATCH 
1. Open an existing custom line style resource file (*.rsc) or create a new one, like the existing Roadway 

one named “rdy_cls.rsc”.  Open this resource file by going to the element attributes tool group and use 

the drop-down in the line styles to select “Manage…”.  This will open the Line Style Editor window, then 

choose “New…”. 
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For this example we are creating an “rsc” file named “oak_rsc.rsc” 

 
 

2. The file annotation scale is in the “OpenRoads Modeling” Workflow on the “Drawing Production 

Ribbon” in the “Drawing Scales” section and should be set to “Full Size 1 = 1”. 

 
 

Annotation Scale Ready 

For storing text as part of the custom line style, set the active text height and width (text size) to this full 

size 1:1 base scale.  If the text size is 7.5 at 1”=50’, then the base scale text size should be set to 0.0125 

(7.5/600). 

Legacy Project Scale Consideration 

For storing text as part of the custom line style, set the active text height and width (text size) to the 1:12 

ratio (1”=1’). If the text size is 7.5 at 1:50, then the base scale text size should be set to 0.1500 (7.5/50). DO 

NOT DO THIS FOR THE CONNECT WORKSPACE. 
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For this cell we are using font style 11 “GEOMETRICFUTURA” but any font can be used.

 
 

3. Draw the line style graphically in the dgnlib file.  This is helpful to visualize what you will use as your 

pattern.  It is also necessary to draw it if the symbol or text being utilized as part of the pattern is not 

already part of the library as a point component of the line style.  Draw this new line style graphically at a 

scale that looks good on a 1”=50’ plan sheet then scale it down 1:600.  This is called your base scale and is 

the real 1:1 scale you will draw so that applying annotation scale to the style will scale it correctly for your 

drawing. 

 

A line style is made up of two different elements; stroke pattern (lines & gaps) and sometimes a symbol or 

point cell.  These point cells are only shown in the rsc file.  Once a point is in the rsc file it cannot be 

edited, it can only be created or deleted, but only deleted using V8i, this may be a bug in the Connect 

edition.  In the example below, the red line the “A” is centered on is only used for centering the text and 

will not be part of the line style.  The point symbol cell or text component of the custom line style can be 

placed on any level. However, it is recommended that the Default level with color, weight, and line code of 

zero be used. 

 
 

4. Place Point Symbol Cell (text or drawing symbol) 

A. For the text point symbol cell only, drop the complex status of the text. This is to ensure the text 

retains its shape if the font or dgnlib is not available.  Microstation will eventually only utilize 

Windows fonts and the custom or proprietary fonts to Bentley will no longer be available. 
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These point symbols could be text or a graphic design or shape and are a special kind of point cell only 

seen within the resource file library. 

 

B. Place a fence around the text or you can use the selection tool to select just the text. 

 
 

C. Define Cell Origin.  In this case we snapped to the center of the red line. 

 
 

5. In the Line Style Editor, select Edit → Create → Point. 
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6. In the Components list sort the list by clicking on the “Type” column.  Scroll through and locate the list 

of “Point” symbol then in the “Description” column it should show “new point component” then select the 

point you just created. In the field below the Component list rename this point cell with a “P_” prefix to 

indicate it is a point component.  Hit the Enter key to make the change. 

 
 

                                            
 

 
 

NOTE: It is good practice to save your work after each step. 

  



 

18 

 

7. Select Create and name the new point symbol cell. 

 
 

8. Since the point cell is created, remove the fence or de-select the text. The cell origin command can also 

be de-activated by depressing the Define Cell Origin button. 

 

9. In the Line Style Editor, select Edit → Create → Stroke Pattern.  This will create a “Stroke” Type in the 

Components list. 
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10. Scroll through the Component list and select the new stroke pattern component. Rename this stroke 

pattern with a “S_” prefix.  Hit the Enter key to make the change. 
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In this step we are defining the stroke pattern distance (or line) between the point symbol cells. 

 

11. Define the stroke pattern Gap (open) and Dash (solid) lengths.  Click [Add] and change the Length 

“Fixed” to 0.10. Change the Stroke Type from “Gap” to “Dash”. 
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In this step we are defining the stroke pattern distance (or an open gap) to place the point symbol cell in. 

This distance should be just slightly longer than the width of the point symbol cell.  For example, if the 

character “A” is 0.05 (text width), then two times that is 0.10, resulting in a gap distance of 0.10.  For 

patterns that have more than one letter in it, half a letter width extra on each side is a good distance i.e., a 

4-letter pattern would need a gap of 0.25: 0.05x4 + 0.025x2. 

 

12. Click [Add] and select the second part of the stroke pattern by clicking on it. 

 
 

13. Change the Length (Fixed) to 0.100000. Stroke Type should be set to “Gap”. 
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14. Optional: In the Stroke Pattern Attributes, set the Shift (Distance) to 0.50.  This is taking half the 

distance of the solid dash line (1.00) and shifting the first point symbol cell (gap) location at the half 0.05 

mark, instead of the full 0.1 mark. 

 
 

15. To create a custom style you choose the component elements you want to make up that pattern.  

Select the Point you made from the Components list then click [Base Stroke Pattern] button. 
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16. Select the Base Stroke Pattern “S_Oak”. 

 
 

A sample of the pattern will be displayed. 
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17. Click on the Gap portion of the stroke pattern and then [Select…] to choose the point symbol cell 

“Oak” you made in step 6. 

NOTE: Sometimes the line will not display in the preview (the ling black bar in the middle of the Line Style 

Editor window), this is just a graphics issue and does not affect the creation of the line style. 
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18. Recommended: For point symbol cell text only, change the point symbol Weight to “Symbol”. This is 

done because when we drop the text complex status into a shape, having a weight higher than zero 

causes jagged edges. The point symbol cells can always use the color and weight they were originally 

created on (Symbol) or the color and weight assigned with the level (Element). 

 
 

Now you have a stroke pattern and a symbol cell you can use to create a Compound. 

 

19. In the Line Style Editor, select Edit → Create → Compound. 
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20. Scroll to the bottom (or top) of the Component list and select the new compound component. 

Rename this stroke pattern with a “C_” prefix.  Hit the Enter key to make the change. 
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21.  Click on Insert and select the stroke pattern “S_Oak”. 

 
 

22. Click on Insert and select the point symbol “P_Oak” then File → Save. 

 
Depending on what scale you drew your stroke and point symbol, the pattern may or may not show in the 

preview pane, 
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23. Next you want to create the actual line style name.  In the Line Style Editor, select Edit → Create → 

Name. 

 
 

24. Key in the name of the custom line style and hit the Enter key to make the change.  The double arrows 

“>>” by the Type indicates you are about to link the name of your custom line style with the Compound 

you created. 
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If this is not the case, then while highlighting the custom line style name and the compound select Edit → 

Link.  Lastly save the resource file, File → Save. 

 
 

25. To test the new custom line style, simply Import it from the resource file to the active dgnlib file. 

A. Go to File → Import → MicroStation Resource File (RSC). 
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B. At the next window path to and select the RSC file you want to import from.  This is typically: 

C:\NCDOT_CONNECT_WORKSPACE\Configuration_10_10\Organization-

Civil\Disciplines\NCDOT_Roadway\Standards\Dgnlib\Line Styles\RSC Backup 

 

C. Select the new line style(s) you want to import. 

 
 

D. Select your draw line tool then change the style to the custom style you created. 
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E. Test the annotation scale function by changing the annotation scale. 
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25. There is a “Physical” setting in the Line style Editor that can be checked on if you do not want the 

annotation scale to take effect.  This is done for true real world dimension line styles, such as some 

existing and proposed pipes, curb and gutter driveway turnouts. 

 
 

26. Saving the “.dgnlib” 

Rename the file to have a ”.dgnlib” extension.  Otherwise known as “when a design file is not a design 

file”.  This allows the revised or new dgnlib to be loaded into the WorkSpace once it is updated on a user’s 

computer.  As you can see, this “.dgnlib” is simply a regular design file saved with a “.dgnlib” extension.  

Coincidentally, this is the same way used to create a “.cel” file for cell library files.  It is also important to 

verify the correct 2D or 3D design seed file is used to create the new file. 

 

27. Remember that you can always shift a line style for clarity and readability using the “Modify Line Style 

Attributes” tool located Drawing → Home → Modify → Change Element Attributes tool. 
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RETROFITTING EXISTING CUSTOM LINE STYLES 
1. draw the custom line style in the active dgnlib.  

Legacy Project Scale Consideration 

Since the original custom line styles were created with Project Scale in mind, use the line style scale of 1 

for their placement. 

 
 

Annotation Scale Ready 

Use a line style scale of 0.0833 (1/12) for their placement. 
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2. Use the Drop Line Style command to drop the custom line style to leave the individual elements. 

 
 

 
 

Repeat the steps above for creating custom line styles from scratch starting from step 2D (define cell 

origin). 
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UPDATING LINES STYLES ALREADY BEING USED IN AN EXISTING FILE 
If an existing line style is used and a revision is made to the line style, the user will need to update their 

design file. 

1. Open the file 

2. Open the Level Manager 

3. Find the level in question, right-click on it and select “Update Levels”. 

 
This will sync whatever is in the WorkSpace with what’s in the design file. 

 

 


