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About this Practice Workbook... 

• The Module 09 – Resurfacing Grades.Zip file will be provided for download. 

• Exact the zip file to the root C:\ 

• All files are then automatically extracted here:   C:\NCDOT Training\Roadway\Module 09 – 
Resurfacing Grades 

• With these subfolders: 
 
 
 
 

 
The Module 09 – Resurfacing Grades PDF will also be located here. 
 

• This PDF file includes bookmarks providing an overview of the document. Click on the 
bookmark to quickly jump to any section in the file. You may have to turn on the bookmark 
function in your PDF viewer, such as Adobe Reader. 

 

• The dataset used throughout this module uses English units and US Survey Feet. 
 

• Each module is self-contained. You can jump to any module and begin the exercises. 
 

• The NCDOT_WorkSets.inp on your desktop should be set the following variables: 
o NCDOT_USE_LOCAL_WORKSETS = L2 
o NCDOT_UNIT_TRAINING_WORKSETS = Roadway 

• This module uses the DOT-US North Carolina WorkSpace, Training-RD_R-2635C WorkSet and 
NCDOT_Roadway Role. It is very important that you select the correct WorkSpace, WorkSet 
and Role.  

 

• For more information on setting up workspaces, click here.  
 

• The tool tips and help were copied from the Bentley Online Help. See this link for the complete 
list of tools and common usage. 
OpenRoads Designer CE Help (bentley.com) 
 

• NCLUG/NCDOT Bentley ORD Open X presentations from each NCDOT Department: 
NCLUG - 2022 TECH Talks 
 

• This workbook was written with the release of OpenRoads Designer 2023 
OpenRoads Designer  Readme (bentley.com) 

https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fconnect.ncdot.gov%2Fprojects%2FRoadway%2FORD%2FNCDOT%2520ORD%2520Flashcard%2520v2023%2520V1.pdf&data=05%7C02%7Carwillets%40ncdot.gov%7C45bb1ff572f54d9f8dd008dcd67fc60e%7C7a7681dcb9d0449a85c3ecc26cd7ed19%7C0%7C0%7C638621091467261192%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0%7C%7C%7C&sdata=SAyRTASF60V%2FIM9OOdL%2FQqsgfxlKtV9Yq4SWlVOatD0%3D&reserved=0
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v12/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
https://www.nclug.com/page-18079
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Readme-v14/en/GUID-43563D21-2E4C-4133-AB04-26E6A4F630EB.html
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Overview 
The Resurfacing Grades module provides practical guidance and introduces essential tools to help you 
develop resurfacing grades effectively. While these tools are valuable, successful roadway design 
ultimately relies on your engineering judgment and experience. 
 
In this module, you will use two key tools: the Overlay Vertical Adjustment Tool to establish a Vertical 
Control Envelope, and the Best-Fit Profile Tool to create an initial profile that will require refinement. 
You'll also learn how to leverage ORD reporting features and other methods to streamline your 
workflow. 
 
By integrating these tools and strategies, you'll be better equipped to apply sound engineering 
judgment and refine your resurfacing grades to meet specifications. 
 

Key Concepts, Tools, and Terminology 

 
Overlay Vertical Adjustment (OVA) Tool 
A tool within OpenRoads Designer is used to create and adjust the vertical alignment for resurfacing 
projects. It evaluates both the template and existing surfaces to calculate the necessary PGL elevation, 
minimizing the overlay above or the milling below the surface. 

 

 

 

 

 

Best-Fit Profile Tool 
The Best-Fit Profile tool enables users to create a complex profile that aligns with a selected existing 
profile, such as generating a new profile that matches an existing ground profile  

 

 

 

 

 

 
It is important to clarify that the Best-Fit Profile tool located under (Site > Grading > Profiles > Best-
Fit Profile) is distinct from the similarly named Define Profile by Best Fit tool found under (Geometry 
> Vertical). The Define Profile by Best Fit (Geometry > Vertical) tool offers limited utility and is not 
recommended for this purpose. 

 
 

BEST-FIT 
PROFILE 

OVERLAY VERTICAL 
ADJUSTMENT 
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Resurfacing 
The process of adding a new layer of asphalt or concrete over an existing road surface to improve its 
condition and extend its lifespan. 

Profile Grade Line (PGL) 
The line representing the elevation of the road's centerline. 

Cross Slope 
The cross slope refers to the slope of the road surface perpendicular to the direction of travel. In the 
context of roadway design, it is also known as superelevation. 
Resurfacing Grade Control Envelope 
The Resurfacing Grade Control Envelope is a designated range that ensures the proposed resurfacing 
grade maintains structural integrity and aligns with existing road conditions. It serves as a guideline 
for design decisions, ensuring consistency with project standards and minimizing disruption to the 
underlying pavement. 
 

Exercise 1 - Tools & Techniques for Resurfacing Grade Development 
 

Exercise 1 focuses on the practical application of tools for developing resurfacing grades. You will use 
the Overlay Vertical Adjustment tool to create a Vertical Control Envelope and the Best-Fit Profile 
tool to generate an initial profile, which will require further refinement. This exercise primarily 
concentrates on an Undivided Facility, emphasizing hands-on techniques for accurately setting grades 
with these tools. While many concepts and techniques are applicable to both divided and undivided 
facilities, there are key differences that must be understood. While this exercise addresses an 
undivided facility, a subsequent exercise will focus exclusively on divided facilities, highlighting the 
critical distinctions and how to manage them effectively. 
 
1. Launch OpenRoads Designer 2023  
             Double-click on the OpenRoads Designer 2023 icon on your desktop to launch 
             OpenRoads Designer. 
 
2. Set the Workspace and Workset 
             Select DOT-US North Carolina from the Workspace menu. 
             Select Training-RD_R-2635C from the Workset menu. 
             Select NCDOT_Roadway from the Role menu. 
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3. Open the r2635c_rdy_alg.dgn file and zoom in closely to the Y16 Alignment 
A. Click the Browse Button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and 
open the r2635c_rdy_alg.dgn file. 
 

B. Zoom in near the Y16 Alignment as shown below. The Y16 Alignment will be used throughout 
this exercise. 
 
Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in.  

 
4. Set the existing ground profile for the Y16 alignment as the active profile. 

A. Select the Open Profile Model button (Geometry > Vertical > Open 
Profile Model) and select the Y16 Alignment when prompted to Locate 
Plan Element. 
 

B. Next, select a view to open when prompted to do so. This will open the Y16 Profile View as 
shown below. 

 
 
 
 
 
 
 
 
 
 
 

Note: All existing ground profiles throughout module 9 are based on the R-2635C existing 
ground terrain model. 

Y16 
  Alignment 

Y16 
  EXISTING 
PROFILE 



 

Module 9 – Resurfacing Grades 
 

 
 

Page | 8  
 
 

C. In the Y16 Profile View, left-click on the Y16 Existing Profile and pause briefly to display the 
toolbar as shown below. Next, activate the Y16 Existing Profile by selecting the Set Active 
Profile button, as illustrated. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Set up a Corridor along the Y16 Alignment  

A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open 
the r2635c_rdy_Y16_cmd.dgn file. 
 

B. Zoom in near the Y16 Alignment as shown below.  
 

 
Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

 
C. Click on the Create Template button (Corridors > Create > Template > Create Template) 

to load the Create Template dialog. 

Y16 
  EXISTING 
PROFILE 

Y16 
  Alignment 

SET ACTIVE 
PROFILE 
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D. Open the R-2635C (Training)_RDY.itl file located under the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder.  
 

E. Notice the UF - 1+1 Lanes - LDSS Template as shown below.  
 

 
 
 
 

 
 
 
 
 
 
 
 

Note: No specific template is required for this exercise. However, it is recommended to choose 
a template that closely aligns with the intended design, particularly in relation to the 
pavement and PGL (Proposed Grade Line). Understanding the differences between a divided 
and undivided facility is crucial in this context. Once you have established a working grade, 
there is no need to maintain the same template throughout the duration of the project. 

 
F. Close the Create Template Dialog. This will set the R-2635C Template Library active while 

working on the Y16 Corridor. 
 

G. Set the following Parameters using the Create Corridor Dialog and click through the prompts 
that follow. 
 

• Feature Definition = Final 

• Name = Y16 
 
 
 

Note: NCDOT recommends using the "Final" design stage feature definition when utilizing a 
corridor to develop a grade. 
 

H. Next, click the New Corridor button (Corridors> Create > New Corridor) and select 
the Y16 Alignment when prompted to Locate Corridor Baseline and Right-Click to 
use the Active Y16 Profile. 

UF - 1+1 Lanes - 
LDSS TEMPLATE 
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I. This will open the Create Template Drops Dialog. Set the following Parameters within the 
Create Template Drops Dialog. 
 

• Start = Lock to Start 

• End = Lock to End 

• Drop Interval = 5 

• Template = UF - 1+1 Lanes - LDSS  
 

Note: NCDOT recommends using a 5’ drop interval when utilizing a corridor to develop a grade 
because it will provide very accurate data.   

 
J. Left-Click to Place the UF - 1+1 Lanes - LDSS Template as shown below. 

 
 

 
6. Explore and become familiar with the Overlay Vertical Adjustment Tool 
 

Note: Bentley's implementation and explanation of the Overlay Vertical Adjustment tool has 
introduced unnecessary complexity, as the Backbone Thickness and Minimum Overlay 
Thickness parameters are effectively interchangeable in determining the final surface 
elevation. NCDOT recommends setting the Backbone Thickness to 0.0’ and adjusting only the 
Minimum Overlay Thickness, rather than configuring both. We will provide examples to clarify 
this. 
 
 

A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder 
and open the r2635c_rdy_alg.dgn file.  
 

B. Click on the Overlay Vertical Adjustment button (Corridors > Miscellaneous > 
Overlay Vertical Adjustment) to load the Overlay Vertical Adjustment dialog. 
 
 
 
 
 
 

Y16 
  Corridor 
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C. Please review the options and parameters within the Overlay Vertical Adjustment dialog box 
provided below. This information is provided for reference purposes only. Those interested in 
fully utilizing this tool are encouraged to take the time to explore and experiment with its 
features. However, for the purposes of Module 9 - Resurfacing Grades, we will focus solely on 
the elements relevant to this module. 

 

• Backbone Thickness - This parameter defines the vertical distance from the Profile Grade 
Line (PGL) to the bottom of the Backbone components. It's redundant and can be 
managed through the Minimum Overlay Thickness parameter. To avoid confusion, I 
recommend setting it to 0 instead (see examples on the following pages for clarity). 

 

• Minimum Mode 
o Minimum Overlay - When specified, it evaluates the 

existing surface to find the control point closest to the 
bottom of the backbone, using that elevation to 
calculate the centerline elevation. 

o Minimum Milling - When specified, the existing surface 
is evaluated to find the control point farthest from the 
backbone, and the vertical adjustment is made to align 
the backbone with that point. 
 

• Maximum Milling Toggle - When enabled, it limits the depth of milling 
to prevent removing too much pavement, ensuring the process follows design 
specifications. 
 

• Maximum Vertical Difference - Generally, this value should remain at 0. If greater than 
0.0, the program compares the Adjusted Vertical elevation between stations to ensure the 
difference does not exceed this value. 

 

• Minimum Overlay Thickness - Is the minimum allowable thickness of overlay material that 
can be applied to the existing surface during vertical adjustment. 

 

• Solution Option – Always use the Examine All Cross Section Points option. 
 

• Existing Ground Range – The portion of the existing surface that will be considered for 
the vertical adjustment. This typically represents existing asphalt. There are a few options 
to define how this information is provided. 
 

Note: Please refer to the examples on the following pages for more clarity and to provide the 
necessary context. 
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D. The following examples demonstrate two parameter variations for the Overlay Vertical 
Adjustment tool using the Minimum Overlay method. It is important to note that the 
Minimum Overlay Thickness and Backbone Thickness parameters are interchangeable. 
Therefore, NCDOT recommends setting the Backbone Thickness to 0.0’ and adjusting only the 
Minimum Overlay Thickness, rather than configuring both parameters. These examples are 
provided for clarity and guidance in applying this approach. 

 
 

Example 1 – Minimum Overlay Method 
 

 1.5” Minimum Overlay Thickness with Backbone Thickness Value of 0.0’ 
 

 
 

 
 
 
 
 
 
 
 
 
 
 

Note: In the image above, the control point marks where the bottom of the 1.5-inch Minium 
Overlay Thickness meets the existing asphalt, with the backbone thickness at 0.0’ in this 
example. To determine the PGL (Profile Grade Line), we add the 1.5-inch overlay thickness to 
the control point's elevation and project the Proposed ORD Cross Slope (superelevation) 
toward the centerline of the roadway. The superelevation (variable) is applied based on 
project-specific settings, not template defaults. 

 
 
 
 
 
 
 
 
 

PGL 

CONTROL 
POINT  

1.5” 

PROPOSED ORD 
CROSS SLOPE 

(SUPERELEVATION) 

0.0’ 

BACKBONE 
THICKNESS 

MIN 
OVERLAY 
THICKNES

S 
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Example 2 – Minimum Overlay Method 
 

0.0’ Minimum Overlay Thickness with Backbone Thickness Value of 1.5” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: In the image above, the Control Point marks where the bottom of the 1.5-inch Backbone 
thickness meets the existing asphalt, with the Minimum Overlay Thickness at 0.0’ in this 
example. To determine the PGL (Profile Grade Line), we add the 1.5-inch Minimum Backbone 
thickness to the Control Point's elevation and project the Proposed ORD Cross Slope 
(superelevation) toward the centerline of the roadway. The superelevation (variable) is applied 
based on project-specific settings, not template defaults. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

PGL 

CONTROL 
POINT  

1.5” 

PROPOSED ORD 
CROSS SLOPE 

(SUPERELEVATION) 

0.0’ 

MIN 
OVERLAY 

THICKNESS 

BACKBONE 
THICKNESS 
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E. The following examples demonstrate two (2) parameter variations for the Overlay Vertical 
Adjustment tool using the Minimum Milling method. Please note that this method will not be 
utilized in Module 9 and is provided solely for informational purposes. For those interested in 
fully exploring this tool, it is encouraged to take the time to review and experiment with its 
features. 

 
 

Example 1 - Minimum Milling Method 
 

Backbone Thickness Value of 0.0’ with the Use Maximum Milling option disabled 
 

 
 

Note: In the image above, the Control Point marks the lowest point along the existing asphalt 
where it meets the bottom of the backbone. To determine the PGL (Profile Grade Line), we 
project the Proposed ORD Cross Slope (superelevation) from the Control Point toward the 
centerline of the roadway. The superelevation (variable) is applied based on project-specific 
settings, not template defaults. 
 
 
 
 
 
 
 
 
 
 
 
 

 

PGL CONTROL 
POINT  

0.0’ 

PROPOSED ORD 
CROSS SLOPE 

(SUPERELEVATION) 

BACKBONE 
THICKNESS 
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Example 2 - Minimum Milling Method 
 

Backbone Thickness Value of 0.0’ with the Use Maximum Milling option 
Enabled and a Maximum Milling Thickness of 0.083’ (1-inch) 

 

 
 
Note: In the image above, the Control Point is marked at the lowest point along the existing 
asphalt where it meets the bottom of the backbone, which has a thickness of 0.0, and is 
determined by the Maximum Milling Thickness of 0.083’ (1 inch). Without this specified limit, 
the Control Point would align with the small red circle, exceeding the allowable milling 
thickness at that location. Therefore, the Control Point is adjusted to the Maximum Milling 
Thickness to ensure compliance with specified constraints. To determine the PGL (Profile 
Grade Line), we project the Proposed ORD Cross Slope (superelevation) from the Control Point 
toward the centerline of the roadway 
 
 
 

F. You may find it helpful to spend additional time exploring the various options within the 
Overlay Vertical Adjustment tool, as it tends to be more complex than necessary for its 
intended purpose. Familiarizing yourself with its features will help you navigate its 
functionality more efficiently. 

 
G. Please exit the Overlay Vertical Adjustment tool. 
 
 
 

 

0.0’ 

PROPOSED ORD 
CROSS SLOPE 

(SUPERELEVATION) 

PGL 

0.083’ 

CONTROL 
POINT  

MAX 
MILLING BACKBONE 

THICKNESS 
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7. Create a Resurfacing Grade Control Envelope for the Y16 Corridor  
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and 
open the r2635c_rdy_alg.dgn file.  

 
B. Zoom in near the Y16 Alignment/Corridor as shown below.  

 
Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

 
C. Select the Open Profile Model button (Geometry > Vertical > Open Profile 

Model) and select the Y16 Alignment when prompted to Locate Plan 
Element. 

 
D. Next, select a view to open when prompted. This action will open the Y16 Profile View, as 

illustrated below. At this point, you should have two (2) views open: the Plan View and the 
Y16 Profile View. 
 
 

 
 
 
 
 
 

 
 
 

Note: The Profile View needs to be open in order to use the Overlay Vertical Adjustment tool. 
 

E. While keeping the Y16 Profile View open, click on the Overlay Vertical Adjustment 
button (Corridors > Miscellaneous > Overlay Vertical Adjustment) and select the 
Y16 Corridor from the plan view when prompted to do so. 

Y16 
 Alignment/Corridor 

Y16 
  EXISTING 
PROFILE 
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F. This will open the Overlay Vertical Adjustment tool. Set the following Parameters within the 
Overlay Vertical Adjustment dialog. 
 

• Vertical Name = Y16_Control  

• Start = 10+00.00  

• Stop = 23+99.78 

• Backbone Thickness = 0.0000 

• Minimum Mode = Minimum Overlay 

• Minimum Overlay Thickness = 0.1250 

• Left Template Range Point = ~ETO 

• Right Template Range Point = +ETO 

• Existing Ground Range = Match Existing Linear 
Geometry 

• Solution Option = Examine All Cross Section Points 

• Maximum Vertical Distance = 0.0000 
 

G. After confirming the Existing Ground Range parameter and accepting the Match Existing 
Linear Geometry value, you will be prompted to locate the Left and Right Linear Geometry. At 
this stage, select the corresponding Left and Right Existing Edge of Pavement elements, as 
displayed in the illustration below. 
 
 
 
 
 

 
 
 
 
 
 
 
 

H. Then, continue left-clicking through the remaining prompts until you have completed the 
process.  
 
Note: Upon completion of this process, a green progress bar will briefly appear in the bottom 
right corner of your screen, indicating that the corridor has been processed. 
 

LEFT EXISTING 
EDGE OF 

PAVEMENT 

RIGHT EXISTING 
EDGE OF 

PAVEMENT 
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I. Now, examine the Y16 Profile View and notice the newly created white linear Y16_Control 
vertical alignment, located near the existing ground alignment, as illustrated below. This will 
serve as the Bottom of your Control Envelope. 

 
J. Next, we will establish the top of the Control Envelope by following the same process used to 

develop the Y16_CONTROL alignment, using the same Parameters as before, except with the 
following two (2) changes. 

 
 
 
 

• Vertical Name = Top_Envelope 

• Minimum Overlay Thickness = 0.2500 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

Y16 
  EXISTING 
PROFILE 

Y16_CONTROL 
(Bottom of Envelope) 
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K. Zoom in on the Profile View, you'll now see the newly created Top_Envelope vertical 
alignment, positioned 0.125' (1.5 inches) above the Y16_Control alignment. This completes 
the Resurfacing Grade Control Envelope, which was developed based on the design criteria 
and tailored to the specific needs of the individual project. The purpose of the Resurfacing 
Grade Control Envelope is to establish vertical boundaries for the Proposed Resurfacing 
Grade (Y16), which will be developed later in this module. The designer should aim to stay as 
close to the bottom of the envelope as possible without dropping below it to prevent 
undercutting the existing pavement. Additionally, the designer should avoid exceeding the top 
of the envelope to minimize wedging. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
8. Review the Y16 Corridor utilizing the Y16 _Control Vertical Alignment  

A. Keeping the Y16 Profile View open, set the Y16_Control (Bottom) vertical alignment active by 
selecting the Set Active Profile button as shown below. 

Y16_CONTROL 

TOP_ENVELOPE 

Y16_CONTROL 
(Bottom Profile) 

TOP_ENVELOPE 

SET ACTIVE 
PROFILE 
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B. After setting the Y16_Control vertical alignment active, Click the Browse button (File> 
Open > Browse) and path to the C:\NCDOT Training\Roadway\Training-RD_R-2635C\ 
Module 9\Roadway\Design folder and open the r2635c_rdy_Y16_cmd.dgn file to view the 
Y16 Corridor, now utilizing the Y16_Control vertical alignment. 

 
C. Next, click on the Open Cross Section View button by navigating to (Corridors > 

Review > Dynamic Sections > Open Cross Section View). When prompted, select the 
Y16 Corridor from the plan view and choose a view to open. 

 
D. Now, scroll through the cross sections and observe the 1.5 inches of Surface Course and the 

Grade Point as you review the sections. You should see that the cross sections are adjusted to 
be as close as possible to the existing pavement without undercutting it. 

 
Note: Although the Y16 alignment may appear optimal in the cross-section view, it is not 
feasible in practice because it does not meet NCDOT Standards. It will be used as an initial 
reference, representing the bottom of the control grade envelope, and will guide the 
development of a grade that adheres to NCDOT Standards. 

 
 

E. Then, Key-in station 14+00 using the Station Key-In dialog as shown below and zoom in closely 
to the cross section.  
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F. In the illustration below, note that the Overlay Vertical Adjustment tool establishes the Grade 
Point by maintaining a minimum overlay thickness of 1.5 inches. It identifies the lowest point 
(Control) that meets this thickness and projects the Superelevation Cross Slope from this 
point to define the Grade Point, ensuring that the profile closely follows the existing 
pavement. 

 
 
 
 
 
 
 

Note: It is important to recognize that the Overlay Vertical Adjustment tool incorporates 
various parameters in addition to the ones used in this particular excercise. Ultimately, the 
goal is to develop a proposed PGL elevation that aligns with the pavement design criteria. 
Multiple combinations of these parameters can yield the same proposed PGL elevation. 

 
9. Use the Y16 Vertical Control Envelope to develop a Best Fit Vertical Profile  

 
Note: A Best-Fit profile is typically a starting point and will require adjustments to align with 
your design intent and specific needs, applying engineering judgment. The purpose of this 
module is to demonstrate tools and methods that will assist you throughout the process. If you 
choose not to use the Best-Fit Vertical Profile option, you may skip this step and proceed to 
Step 10 to manually develop your profile. 

 
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and 
open the r2635c_rdy_alg.dgn file. 

 
 
 
 
 
 

 
 

 

Y16 
 Alignment/Corridor 

PGL 
(GRADE POINT) 

CONTROL 
POINT  

1.5” 

SUPERELEVATION 
(CROSS SLOPE) 
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B. Zoom in near the Y16 Alignment as shown below.  
Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

 
C. Select the Open Profile Model button (Geometry > Vertical > Open Profile 

Model) and select the Y16 Alignment when prompted to Locate Plan 
Element. 

 
D. Next, select a view to open when prompted. This action will open the Y16 Profile View, as 

illustrated below. At this point, you should have two (2) views open: the Plan View and the 
Y16 Profile View. 

 
 

 
 
 
 
 
 
 
 
 

 
 

E. Now, Select the Best-Fit-Profile button (Site > Grading > Profiles > Best-Fit-Profile) 
and set the following Parameters within the Best-Fit-Profile dialog. 

 
 

• Minimum K-Value = 96.0000 

• Minimum Tangent Length = 0.0000 
 
 
 
 
 

Note: This tool was not specifically designed for this application; because of this, only two 
parameters are relevant in this context, while the others are disregarded. Additionally, since 
there is only a single K-value parameter instead of separate values for sag and crest curves, 
you should select the worst-case scenario of the two based on your design criteria. 

Y16 
  EXISTING 
PROFILE 

Y16_CONTROL 
(Bottom Profile) 

TOP_ENVELOPE 



 

Module 9 – Resurfacing Grades 
 

 
 

Page | 23  
 
 

F. Then, select the Y16_Control (Bottom of Envelope) vertical profile when prompted to locate 
the element, and then Left-Click through the subsequent Heads-Up Prompts that follow. 

 
G. This will activate the Best-Fit command, swiftly displaying and updating several profile options 

and variations in orange (see below), creating an animation-like effect as OpenRoads Designer 
develops a Best-fit option based on the Y16_Control profile. Ultimately, a selection will be 
made, resulting in the generation of a Best-Fit profile.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
H. Once the Best-Fit Profile command is complete, close the Best-Fit window. If you zoom in 

closely on the Y16_Profile view, you should see the newly created Best-Fit profile, which 
closely follows the Y16_Control profile. This is the profile generated by the Best-Fit Profile 
tool. 
 
 
 
 
 
 
 
 
 
 
 
 
 

TOP_ENVELOPE 

Y16_CONTROL 
 (BOTTOM OF 

ENVELOPE) 

BEST-FIT 
PROFILE 

Y16 EXISTING 
PROFILE 
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I. Now, select the Set Feature Definition button (Geometry > General Tools > Standards > Set 
Feature Definition) and configure the Parameters in the Set Feature Definition dialog box as 
outlined below. Then, click on your Best-Fit profile to update it with the appropriate NCDOT 
Standards and rename the profile to Y16. 
 

 
 

• Feature Type = Alignment 

• Feature Definition = ALG_Centerline 
Minor Roadway 

• Name = Y16 
 
 
 
 
 
 
 
 
 
 

J. Select the Y16 profile and note that the Vertical Curves display only the K Values, rather than 
both the Curve Lengths and K Values. This occurs due to the functionality of the Best-Fit 
Profile tool. 

 
 
 

K VALUE 

K VALUE 
K VALUE 



 

Module 9 – Resurfacing Grades 
 

 
 

Page | 25  
 
 

K. To address this issue and convert your profile into a more manageable format, select the 
Table Editor button (Geometry > Common Tools > Table Editor), select your profile (Y16) 
when prompted to Locate Alignment. This will open the Y16 Profile within the Table 
Editor. Once the Y16 Profile is opened as shown below, click the Apply button within the 
Table Editor. This will reformat the profile to function as a standard VPI based OpenRoads 
Designer profile. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

L. With the Table Editor still open, you may notice some clear discrepancies in the Stationing, 
Slopes, and Elevation Readouts. Additionally, certain portions of the profile do not fall within 
the Resurfacing Grade Control Envelope established in Step 7. This is because we aim to align 
as closely as possible to the Y16_Control profile (Bottom of Envelope). While the Best-Fit 
Profile tool provides a good initial approximation, it's not a perfect solution—just a starting 
point. 
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M. As you proceed to refine the Y16 Profile that was developed using the Best-Fit Profile tool. 
Consider the following tips to guide you through the refinement process. 
 
Note: The intent of the Resurfacing Grades Module is to offer general guidance and introduce 
tools and methods to assist you. It is not intended to teach roadway design, as that requires 
not only the use of tools but also the application of engineering judgment, which comes with 
years of experience. When designing your resurfacing grade, it’s essential to use your 
engineering judgment alongside the tools presented in this module. This distinction is crucial 
to understand. 

 
Refinement Tips for the Y16 Profile: 
 

• Refine the stationing by rounding appropriately and adjust the grade and elevation values 
to two decimal places. 
 

• Adjust the Y16 Profile to remain as close to the Resurfacing Grade Control Envelope as 
possible. It is crucial to understand that if the profile falls below the envelope, it may 
encroach upon the existing pavement. Conversely, positioning the profile above the 
envelope will result in excessive elevation, potentially leading to excessive wedging. While 
a slightly higher profile may be acceptable, it is generally better to be lower unless it 
results in undercutting the pavement. This is an example of when engineering judgment 
and a clear understanding of the project's intent are essential. 

 

• Open the Plan, Profile, and Cross-Section views of the Y16 Corridor simultaneously for a 
comprehensive review. Right-click in the Plan view, select View Control, and choose the 3 
Views Plan/Profile/XS setting. The Cross-Section View is crucial for spotting details that 
the Profile View may miss, helping you assess variations. Take notes on your observations 
and adjust the profile as needed. 
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• Adjust the Vertical Exaggeration Factor while fine-tuning your grade to 
remain close to the bottom of the Resurfacing Grade Control Envelope, 
ensuring that you stay within its limits. Achieving a close alignment with 
an Exaggeration Factor of 100X indicates a precise adjustment. You can 
find the Exaggeration Tool in the Profile View under the View Attributes 
Dropdown in the Top Left Corner of the Profile View. Once you have 
established a tight grade at 100X, switch back to 1X or 5X to see the true 
quality of your grade. This feature is particularly beneficial, as it allows for 
on-the-fly changes, unlike Geopak, enhancing convenience and ease of 
use. 

 
 
 
 
 
 
 

• Use the Profile Insert Curve tool (Geometry > Vertical > Modify > Profile 
Insert Curve) to add additional Vertical Curves if necessary. 
 

• Use the Delete Vertex tool (Drawing > Modify > Delete Vertex) to delete any 
Vertical Curves or VPI’s if necessary.  

 

• Refer to the Project Design Criteria and/or NCDOT Standards to define and comply with 
the Minimum and Maximum Grade and K-values. 

 

• If the existing cross slope does not align with the proposed superelevation, it may lead to 
excessive wedging on one side of the road. Depending on the specific circumstances and 
guided by sound engineering judgment as well as an understanding of the project's intent, 
you may consider adjusting the proposed superelevation to better match the existing 
conditions. 

 

• Implement standard design practices at both the beginning and end of the resurfacing 
limits to ensure a smooth and compliant transition between the new and existing 
pavement, in accordance with NCDOT Guidelines. 

 

• For additional assistance with vertical geometry, please refer to Module 4 - Vertical 
Alignments. 

 
 

VIEW 
ATTRIBUTES  
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Exercise 2 - Resurface Grade Tie-in 
 
Exercise 2 provides a concise example illustrating how to tie in your grade to the existing pavement. In 
this example, we will demonstrate how to transition from a proposed grade to an existing grade using 
a vertical curve to ensure a smooth connection. It is important to recognize that multiple methods 
may be available for this process. Depending on the specific circumstances, you may encounter 
limitations that affect your options. In many cases, achieving the desired outcome may require 
flexibility and compromise. As previously noted, the objective of this module is not to teach you how 
to engineer or design a resurfacing grade. Rather, the goal of Module 9 is to familiarize you with the 
tools within OpenRoads Designer that can support your design process. Ultimately, all design 
decisions should be based on sound engineering judgment and experience. 
 
1. Launch OpenRoads Designer 2023  
             Double-click on the OpenRoads Designer 2023 icon on your desktop to launch 
             OpenRoads Designer. 
 
2. Set the Workspace and Workset 
             Select DOT-US North Carolina from the Workspace menu. 
             Select Training-RD_R-2635C from the Workset menu. 
             Select NCDOT_Roadway from the Role menu. 

 
 
 
 
 
 

3. Open the r2635c_rdy_alg_tie-in.dgn file and zoom in closely to the Y16 Alignment 
A. Click the Browse button (File> Open > Browse) and path to the Module 

9\Roadway\Alignment folder and open the r2635c_rdy_alg_tie-in.dgn file. 
B. Zoom in near the Y16 Alignment as shown below. The Y16 Alignment will be used 

throughout this exercise. 
 
 
 
 
 
 
 
  

Y16 
  Alignment 
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4. Open the Y16 Profile  
A. Select the Open Profile Model button (Geometry > Vertical > Open Profile 

Model) and select the Y16 Alignment when prompted to Locate Plan 
Element. 
 

B. Next, select a view to open when prompted to do so. This will open the Y16 Profile View as 
shown below. Notice the proposed Y16 Profile does not tie properly to existing.   

 

 
 
5. Transition from the proposed Y16 grade to the existing grade using a vertical curve  

A. Zoom in closely to the beginning of the proposed grade as shown below. 

 
 
 
 

Y16 
PROFILE 

Y16 
PROFILE 
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B. Using the Feature Definition Toggle Bar set the Active Feature Definition to ALG Component 
Tangent (Alignment > Roadway > Component > ALG Component Tangent). 
 

 

 
 
 
 
 
 

C. Now, using the Profile Line Between Points (Geometry > Vertical > Lines > Profile 
Line Between Points) tool, draw a line in snapping to existing from Sta 10+00 to 
approximetely Sta 10+60 as shown below. This will establish a grade that matches 
existing at the Tie-In location. 

 
 
 
 
 
 

D. Next, click on the vertical line that was drawn in the previous step and use the Arrow 
Manipulator to extend the line out to where it intersects (approx 11+85) the proposed grade 
as shown below. This step is not necessary but can be helpful to understand the proposed 
geometry while making decisions regarding vertical curve placement. 
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E. Using the Feature Definition Toggle Bar set the Active Feature Definition to ALG Component 
Curve (Alignment > Roadway > Component > ALG Component Curve) 

 
 
 
 
 
 
 
 
 

F. Then, using the Parabola Between Elements (Geometry > Vertical > Curves > Profile 
Curve Between Elements > Parabola Between Elements) tool, click on the two (2) 
Vertical Tangent Lines, key-in 150’ Curve Length and place the Proposed Vertical 
Curve as shown below. 

 
G. Again, there a multiple ways to tie profiles back to exisitng conditions. For additional 

assistance with Vertical Geometry, please refer to Module 4 - Vertical Alignments. 
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Exercise 3 – Divided Facilities 
 
Exercise 3 is focused exclusively on Divided Facilities. While many tools, methods, and workflows 
from Exercise 1, which established a resurfacing grade for Undivided Facilities, remain applicable, 
there are notable differences. This exercise will highlight these distinctions and provide 
comprehensive guidance on making the necessary adjustments to develop a resurfacing grade for a 
Divided Facility. It’s important to note that the Overlay Vertical Adjustment tool has specific 
functional limitations when working with Divided Roadways, and much of the focus will be on 
addressing these limitations. Despite these challenges, the tool remains highly effective when used 
properly. 
 
1. Launch OpenRoads Designer 2023  
             Double-click on the OpenRoads Designer 2023 icon on your desktop to launch 
             OpenRoads Designer. 
 
2. Set the Workspace and Workset 
             Select DOT-US North Carolina from the Workspace menu. 
             Select Training-RD_R-2635C) from the Workset menu. 
             Select NCDOT_Roadway from the Role menu. 

 
 

 
 
 
3. Examine how a divided facility template with a median ditch impacts the operation of the 

Overlay Vertical Adjustment tool 
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and open 
the r2635c_rdy_alg_div_ditch.dgn file. 
 

B. Zoom in near the Y16 Alignment and Corridor as shown below.  
 

 
 
 
 
 

Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

Y16 
  Alignment/Corridor 
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C. Select the Open Profile Model button (Geometry > Vertical > Open 
Profile Model) and select the Y16 Alignment when prompted to Locate 
Plan Element. 

D. Next, select a view to open when prompted to do so. This will open the Y16 Profile View as 
shown below. 

 
 

 
 
 
 

 
 
 
 

Note: The Y16 Corridor is currently using the existing Y16 profile as shown above. 
 

E. While keeping the Y16 Profile View open, click on the Overlay Vertical Adjustment 
button (Corridors > Miscellaneous > Overlay Vertical Adjustment) and select the 
Y16 Corridor from the plan view when prompted to do so. 

 
F. This will launch the Overlay Vertical Adjustment tool. Set the following Parameters within the 

Overlay Vertical Adjustment dialog. Please note the inability to exclude the template median, 
which is a key issue that will be addressed during this exercise.  

 

• Vertical Name = Y16_DIV_DITCH_EXAMPLE 

• Start = 10+00.00  

• Stop = 23+99.78 

• Backbone Thickness = 0.0000 

• Minimum Mode = Minimum Overlay 

• Minimum Overlay Thickness = 0.2500 

• Left Template Range Point = ~ETO 

• Right Template Range Point = +ETO 

• Existing Ground Range = Match Existing Linear 
Geometry 

• Solution Option = Examine All Cross Section Points 

• Maximum Vertical Distance = 0.0000 
 
 

EXISTING 
Y16 
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G. After confirming the Existing Ground Range parameter and accepting the Match Existing 
Linear Geometry value, you will be prompted to locate the Left and Right Linear Geometry. At 
this stage, select the corresponding Left and Right Existing Edge of Pavement elements, as 
displayed in the illustration below. 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

H. Then, continue left-clicking through the remaining prompts until you have completed the 
process.  
 
Note: Upon completion of this process, a green progress bar will briefly appear in the bottom 
right corner of your screen, indicating that the corridor has been processed. 

 
I. Now, examine the Y16 Profile View and notice the newly created  Y16_DIV_DITCH_EXAMPLE 

vertical alignment, located above the existing ground alignment, as illustrated below.  
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J. Keeping the Y16 Profile View open, set the Y16_DIV_DITCH_EXAMPLE vertical profile active 
by selecting the Set Active Profile button as shown below. 

 
 
 
 
 
 
 
 
 
 

K. Now, Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open 
the r2635c_rdy_cmd_div_ditch.dgn file. 

 
Note: Upon opening the CMD file, a green progress bar will briefly appear in the bottom right 
corner of your screen, indicating that the corridor has been processed after setting the newly 
created Y16_DIV_DITCH_EXAMPLE profile as active in the ALG file. 
 

L. Next, click on the Open Cross Section View button by navigating to (Corridors > Review 
> Dynamic Sections > Open Cross Section View). When prompted, select the Y16 
Corridor from the plan view and choose a view to open. 

 
M. Now, scroll through the cross-sections and observe that the Overlay Vertical Adjustment tool 

did not apply the expected adjustments. Instead of minimizing the overlay pavement as 
intended, the cross-sections appear significantly elevated overall. This outcome was 
anticipated and intentional, designed to bring awareness to the discrepancy for further review. 

 
N. Let’s take a closer look. Key-in station 10+00.00 using the Station Key-In dialog as shown 

below and zoom in closely to the cross section.  
 

 
 
 
 
 
 

 
 

SET ACTIVE 
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O. Notice that, because the median was not excluded from processing, the Overlay Vertical 
Adjustment tool follows its default logic. It evaluates the existing surface to identify the 
Control Point closest to the bottom of the backbone, then adds an additional 3” based on the 
provided input to calculate the PGL. However, the tool incorrectly includes the grass median in 
its calculations, when it should only consider the proposed pavement. As previously 
mentioned, this is a flaw in the application that we will address. 

 
 
 
 
 
 
 
 
 
 
 
 
 
4. Adjust the divided facility median ditch template to ensure compatibility with the Overlay 

Vertical Adjustment tool, enabling it to function as intended. 
A. Next, click on the Create Template button by navigating to (Corridors > Create > 

Template > Create Template). This should load R-2635C (Training)_RDY.itl as shown 
below. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3” 

PGL 
(GRADE POINT) 

3.0” 
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B. If the R-2635C (Training)_RDY.itl does not load, or if your just unsure, select (File > Open) 
from the top left corner of the Create Template dialog box and browse to C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open the            
R-2635C (Training)_RDY.itl to load it manually. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

C. Now, double click on the DF-2+2 Lanes Median Ditch template to activate it as shown below. 
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D. Zoom in closely to the median ditch area, then right-click and select (Add New Component > 
Unconstrained) as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

E. Then, set the Feature Definition to TC_Draft-DNC as shown below. 
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F. Now, draw a line from the ~ETI_DRAW point to the CL_PGL point, as illustrated below. 
 
 
 
 
 
 
 
 
 
 
 

G. Then, draw a line from the CL_PGL point to the +ETI_DRAW point, as illustrated below. 
 
 
 
 
 
 
 
 
 
 
 

H. In addition to providing the previous steps, I have also included a template called DF - 2+2 
Lanes Median Ditch_MOD in the R-2635C (Training)_RDY.itl that has already made these 
changes. 
 
Note: Once the grade has been established, the TC_Draft-DNC lines previously added to the 
template should be removed.  

 
5. Apply the modified DF-2+2 Lanes Median Ditch Template and see how it impacts the Overlay 

Vertical Adjustment tool. 
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open the 
r2635c_rdy_cmd_div_ditch.dgn file. 
 
 
 

 

CL_PGL ~ETI_DRAW 

CL_PGL +ETI_DRAW 
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B. Zoom in near the Y16 Alignment and Corridor as shown below.  
 

 
 
 
 
 

Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

 
C. Next, click on the Synchronize Template button by navigating to (Corridors > Miscellaneous 

> Synchronize Template plate). This will update the Y16 Corridor template to incorporate 
the changes made in Step 13. 
 

D. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and open 
the r2635c_rdy_alg_div_ditch.dgn file.  
 

E. Zoom in near the Y16 Alignment and Corridor as shown below.  
 

 
 
 
 
 

Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 
 

F. Select the Open Profile Model button (Geometry > Vertical > Open 
Profile Model) and select the Y16 Alignment when prompted to Locate 
Plan Element. 

 
G. Next, select a view to open when prompted to do so. This will open the Y16 Profile View as 

shown below. The Y16_DIV_DITCH_EXAMPLE profile is still set to active. 
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H. While keeping the Y16 Profile View open, click on the Overlay Vertical Adjustment button 
(Corridors > Miscellaneous > Overlay Vertical Adjustment) and select the Y16 Corridor from 
the plan view when prompted to do so. 

 
I. This will launch the Overlay Vertical Adjustment tool. Set the following Parameters within the 

Overlay Vertical Adjustment dialog. Please note the inability to exclude the template median, 
which is a key issue that will be addressed during this exercise.  

 

• Vertical Name = Y16_DIV_DITCH_EXAMPLE2 

• Start = 10+00.00  

• Stop = 23+99.78 

• Backbone Thickness = 0.0000 

• Minimum Mode = Minimum Overlay 

• Minimum Overlay Thickness = 0.2500 

• Left Template Range Point = ~ETO 

• Right Template Range Point = +ETO 

• Existing Ground Range = Match Existing Linear 
Geometry 

• Solution Option = Examine All Cross Section Points 

• Maximum Vertical Distance = 0.0000 
 

J. After confirming the Existing Ground Range parameter and accepting the Match Existing 
Linear Geometry value, you will be prompted to locate the Left and Right Linear Geometry. At 
this stage, select the corresponding Left and Right Existing Edge of Pavement elements, as 
displayed in the illustration below. 
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K. Then, continue left-clicking through the remaining prompts until you have completed the 
process.  
 
Note: Upon completion of this process, a green progress bar will briefly appear in the bottom 
right corner of your screen, indicating that the corridor has been processed. 

 
L. Now, examine the Y16 Profile View and notice the newly created  Y16_DIV_DITCH_EXAMPLE2 

vertical alignment, located in between the Y16_DIV_DITCH_EXAMPLE profile and the Y16 
existing ground profile, as illustrated below.  

 
 
 
 
 
 
 
 
 

M. Keeping the Y16 Profile View open, set the Y16_DIV_DITCH_EXAMPLE2 vertical profile active 
by selecting the Set Active Profile button as shown below. 

 
 
 
 
 
 
 
 
 
 

N. Now, Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open 
the r2635c_rdy_cmd_div_ditch.dgn file. 

 
Note: Upon opening the CMD file, a green progress bar will briefly appear in the 
bottom right corner of your screen, indicating that the corridor has been processed 
after setting the newly created Y16_DIV_DITCH_EXAMPLE profile as active in the ALG 
file. 
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O. Next, click on the Open Cross Section View button by navigating to (Corridors > Review > 
Dynamic Sections > Open Cross Section View). When prompted, select the Y16 Corridor from 
the plan view and choose a view to open. 

 
P. Now, scroll through the cross-sections and observe that the Overlay Vertical Adjustment tool 

now works as expected. It minimized the overlay pavement as intended. Exactly how it worked 
with the undivided facility in Exercise 1. 

 
Q. Let’s take a closer look. Key-in station 10+00.00 using the Station Key-In dialog as shown 

below and zoom in closely to the cross section.  
 

 
 
 

 
 

 
R. It is important to note that, due to the added elements connecting the PGL to the Inside EOT 

points, the Overlay Vertical Adjustment tool now operates as intended. The median ditch is 
ignored, and these elements are treated as if they represent the top of pavement. The system 
then evaluates these elements against the existing surface to identify the Control Point closest 
to the bottom of the backbone, subsequently adding 3" based on the provided input to 
calculate the PGL. While this is not a perfect solution, it is a highly effective one. 
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6. Examine how a divided facility template with a raised median impacts the operation of the 
Overlay Vertical Adjustment tool 
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and open 
the r2635c_rdy_alg_divided.dgn file. 
 

B. Zoom in near the Y16 Alignment and Corridor as shown below.  
 

 
 
 
 
 

Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 

 
C. Select the Open Profile Model button (Geometry > Vertical > Open 

Profile Model) and select the Y16 Alignment when prompted to Locate 
Plan Element. 

 
D. Next, select a view to open when prompted to do so. This will open the Y16 Profile View as 

shown below. 
 
 

 
 
 
 

 
 
 
 

Note: The Y16 Corridor is currently using the existing Y16 profile as shown above. 
 

E. While keeping the Y16 Profile View open, click on the Overlay Vertical Adjustment 
button (Corridors > Miscellaneous > Overlay Vertical Adjustment) and select the 
Y16 Corridor from the plan view when prompted to do so. 
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F. This will launch the Overlay Vertical Adjustment tool. Set the following Parameters within the 
Overlay Vertical Adjustment dialog. Please note the inability to exclude the template median, 
which is a key issue that will be addressed during this exercise.  

 

• Vertical Name = Y16_RAISED_MEDIAN_EXAMPLE 

• Start = 10+00.00  

• Stop = 23+99.78 

• Backbone Thickness = 0.0000 

• Minimum Mode = Minimum Overlay 

• Minimum Overlay Thickness = 0.2500 

• Left Template Range Point = ~ETO 

• Right Template Range Point = +ETO 

• Existing Ground Range = Match Existing Linear 
Geometry 

• Solution Option = Examine All Cross Section Points 

• Maximum Vertical Distance = 0.0000 
 

G. After confirming the Existing Ground Range parameter and accepting the Match Existing 
Linear Geometry value, you will be prompted to locate the Left and Right Linear Geometry. At 
this stage, select the corresponding Left and Right Existing Edge of Pavement elements, as 
displayed in the illustration below. 
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H. Then, continue left-clicking through the remaining prompts until you have completed the 
process.  
 
Note: Upon completion of this process, a green progress bar will briefly appear in the bottom 
right corner of your screen, indicating that the corridor has been processed. 

 
I. Now, examine the Y16 Profile View and notice the Y16_RAISED_MEDIAN_EXAMPLE vertical 

alignment, located above the existing ground alignment, as illustrated below.  
 
 
 
 
 
 
 
 
 
 
 

J. Keeping the Y16 Profile View open, set the Y16_RAISED_MEDIAN_EXAMPLE vertical profile 
active by selecting the Set Active Profile button as shown below. 

 
 
 
 
 
 
 
 
 
 

K. Now, Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 
Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Design folder and open the 
r2635c_rdy_cmd_divIded_facility.dgn file. 

 
Note: Upon opening the CMD file, a green progress bar will briefly appear in the 
bottom right corner of your screen, indicating that the corridor has been processed 
after setting the newly created Y16_RAISED_MEDIAN_EXAMPLE profile as active in the 
ALG file. 
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L. Next, click on the Open Cross Section View button by navigating to (Corridors > Review > 
Dynamic Sections > Open Cross Section View). When prompted, select the Y16 Corridor from 
the plan view and choose a view to open. 

 
M. Now, scroll through the cross-sections and observe that the Overlay Vertical Adjustment tool 

works as expected. It minimized the overlay pavement as intended. Exactly how it worked with 
the undivided facility in Exercise 1. 

 
N. Let’s take a closer look. Key-in station 10+00.00 using the Station Key-In dialog as shown 

below and zoom in closely to the cross section.  
 

 
 
 
 
 
 

O. It is important to note that, due to the functionality of the Overlay Vertical Adjustment tool, 
the raised median is essentially disregarded in this process. This occurs because the median 
does not influence the Proposed Ground Line (PGL) in this scenario. Additionally, the raised 
median is positioned above the proposed pavement, in contrast to the Median Ditch, which 
lies below the proposed pavement. As a result, the Overlay Vertical Adjustment tool functions 
as intended, ignoring the Raised Median. This allows the system to assess the Proposed 
Pavement against the Existing Surface, identify the Control Point closest to the bottom of the 
backbone, and then apply a 3” adjustment based on the provided input to calculate the PGL. 
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Exercise 4 – Profile Reporting & Proposed Resurfacing Model Review 
 
Exercise 4 focuses on methods to check the Resurfacing Profile against the Resurfacing Grade 
Control Envelope that was developed in Exercise 1. 
 

1. Generate a report of the Y16 Profile. 
 
A. Click the Browse button (File> Open > Browse) and path to the C:\NCDOT 

Training\Roadway\Training-RD_R-2635C\Module 9\Roadway\Alignment folder and 
open the r2635c_rdy_alg.dgn file. 
 

B. Zoom in near the Y16 Alignment/Corridor as shown below.  

 
Note: All reference files that are required for the Resurfacing Grades module have already 
been attached to the files you will be working in. 
 

C. Next, select the Open Profile Model button (Geometry > Vertical > Open 
Profile Model) and select the Y16 Alignment when prompted to Locate 
Plan Element. Then select a view to open when prompted to do so. This will 
open the Y16 Profile View. 
 

D. In the Y16 Profile View, left-click on the Y16 Profile and pause briefly to display the toolbar as 
shown below. Next, activate the Y16 Profile by selecting the Set Active Profile button, as 
illustrated and then close out of the profile view. 

 
 

Y16 
 Alignment/Corridor 
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E. Next, select the Horizontal Geometry Report button (Home > 
Model Analysis and Reporting > Reports > Horizontal Geometry 
Report) and configure the Parameters in the Horizontal 
Geometry Report dialog box as outlined below. 

 
 

• Start Station = Lock To Start 

• End Station = Lock To End 

• Interval = 50.0000 

• Include Event Points = None 

• Included Profiles = Active Profile 
 
 
 

 
Note: The Interval is used to determine a stationing interval for reporting purposes. This 
should be set based on the need.  

 
F. Then, select the Y16 Alignment when prompted to Locate First Element and then Right-Click 

& Reset to Complete.  
G. Please proceed by clicking through the remaining prompts, which have been pre-populated 

based on the parameters specified in the Horizontal Geometry Report dialog. This action will 
open the Bentley Civil Report Browser, defaulting to the Horizontal Alignment Review 
Report, as illustrated below. 
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H. Next, please select the VerticalAlignmentIntervalStationElevationGrade.xsl from the list on 
the left side of the Bentley Civil Report Browser, as shown below. You will see that the report 
presents the Stations with intervals that correspond to the parameters defined in the 
Horizontal Geometry Report dialog, along with their respective Elevations. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

I. Finally, Save the report as a Microsoft Excel (.xlsx) file and call it Y16_Vertical. 
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2. Generate a report on the Top Alignment of the Y16 Resurfacing Vertical Control Envelope, as 
developed in Exercise 1. 
 
A. Please follow the same procedures that were used to generate the Y16 Profile Report. 

 
3. Generate a report on the Bottom Alignment of the Y16 Resurfacing Vertical Control Envelope, as 

developed in Exercise 1. 
 
A. Please follow the same procedures that were used to generate the Y16 Profile Report. 

 
4. Compare the three profiles using the Excel reports generated in the previous steps. Assess 

whether the Y16 profile remains within the envelope boundaries by examining the elevations. 
 
A. Copy the Stationing and Elevations from all three profile reports into a new excel document. 

 
B. Utilize a formula to evaluate the Y16 Elevations for each station against the Top and Bottom 

Profiles of the Envelope. 
 

C. If the Y16 Profile falls outside the Envelope Elevation at a specific station, access the cross-
sections to identify the cause. Subsequently, document the reason in the spreadsheet. 

 


