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Today’s Training Agenda

• We’ll go over the file conversion process to be used for Traffic Control
Plans

• We’ll go through and show the Levels created for Traffic Control Plans

• We’ll discuss the Attributes tool box and Level Filters created for Traffic
Control Plans

• We’ll go over the Work Zone Traffic Control Unit’s Menu bar

• We’ll introduce some new Line Styles

• We’ll show you how to save files to other versions / formats (Handout
only)

• Wrap it up with the basic file naming / creation process to be used for
Traffic Control Plans



V7 to V8…Converting your Files

Double Click on the file you wish to Convert within the Microsoft Explorer Window.

The dialog below will immediately appear.

Select Microstation Version 8 within the drop down menu as shown below then hit OK.



The next dialog (shown below) will inquire as to your intentions, Upgrade to V8 or open
read-only and keep the V7 format.

To convert your file to version V8 select upgrade and hit the OK button.

That’s all there is to it!

Repeat the process for the rest of your active project files.



TCP Leveling Guide
Before V8

This leveling guide should be used when preparing traffic control plans.  You can vary from the
listed attributes if necessary.  However, be aware that the pen tables that control certain plotting
actions rely on levels 49 and 50 containing the correct objects.

If you use the Traffic Control Section Barmenu to select text, cells, etc., they will be
placed using the correct Leveling Guide attributes.

Level Feature Color Line Line Font Text Text Text Text Text Text
Description Weight Style Size Size Size Size Size Size

Metric Metric Metric English English English
1:1000 1:500 1:250 1"=100' 1"=50' 1"=20'

30 TCP Lines /
Items

2 3 Varies

31 General Text 3 0 71 4.0 2.0 1.0 14.0 7.0 2.8
31 Match Lines 3 0 71 5.0 2.5 1.25 16.0 8.0 3.2
31 Street Names /

Title Block
3 0 71 7.2 3.6 1.8 20.0 10.0 4.0

31 Stations / Labels 3 0 71 9.2 4.6 2.3 30.0 15.0 6.0

32 Proposed
Striping

0 / 4 3/6/10 Varies

49 Black Area Fill
Shapes

0 0 0

50 Existing Striping 7 3/6/10 Varies
50 Gray Area Fill

Shapes
9 0 0

62 Junk Level
(NO PLOT)



NCDOT’s New Leveling Scheme within V8

Bunches and Bunches of Levels – Just for YOU!

Traffic Control alone has an approximate total of  400 levels to date.

If you were to consider all Units I’m sure you’ll be into the thousands.

How in the world are you going to remember this stuff and maintain a respectable
production rate?

The Answer….FILTERS (to be covered later)

First let’s get familiar with the New Level Display dialog.



New Level Display dialog

Out with the OLD

In with the NEW



General Questions – Levels

Question 1: What do the different colors for a level in the Level Display
mean?
Answer: Definitions of the different color is outlined below.
Black = the Level is ON.
No color = the level is currently turned OFF.
Gray highlight = the level is ON in some of the views and OFF in the other views.

Question 2: What happens to my V8 files levels when I save it to V7 if
there are more than 63 levels?
Answer: The elements that are on levels beyond level 63 will be placed on levels that will
wrap around starting with level 1. For example, if you have elements on level 64, the
elements will be placed on level 1 when the file is saved to V7.



Attributes Toolbox

Invoke by selecting tools from the top menu then attributes

Filters Developed for
Traffic Control Unit

Traffic Control
Levels……



New Junk Level

To retain elements within your design file (ex. alternate designs) that would not display
or plot you used to move them to Level 62 which was our Junk Level as we called it.

In Microstation V8 the ByLevel methodology used for level naming requires us to define
the line style, weight and color for each level created. This in turn will change the
symbology of all those items moved to a particular level. This is not good when trying to
recall what was moved to a “Junk Level” for later recall such as we had done with the
Junk Level 62 in version 7.

To overcome this tendency we had to come up with another approach to retain design
elements for later recall.

The New Method:

You should now change the classification of these elements to “Construction” rather than
the normal “Primary” classification. Construction elements will not plot per our plot
settings.

To recall elements whose classification has been changed, simply follow these steps:

1. Turn on the display for construction elements by either hitting keys ‘Cntl+B’ together
or selecting “View Attributes” from the WZTCU Barmenu under the
Utilities/MDLapps catagory for the display attributes dialog box to appear.
(See Figure 1 Sheet 2)

2. Once the dialog box opens check the box next to Constructions.

3. Select the items you wish to recall and move them back to the appropriate design
level.



Important things to remember:

When you either move or create an element to a construction element class be mindful
that all subsequent elements placed in the design file may be placed within that element
classification unless you specifically toggle the active class back to primary. Try to get
into habit of changing the class of elements to construction then switching the active class
back to primary before placing other elements in your design file. If you have the
construction element display turned off within your design file you will hopefully be
aware something’s gone amiss when trying to place future elements. It may also be
helpful if you display the active element class toggle button as shown on Figure 2 below
which could also, serve as a visual aid.

Figure 1

Figure 2



Other ways of moving elements to other levels.



WZTCU – Barmenu

Linestyle Dialog Functions

NOTE: If the Linestyle was selected utilizing the Barmenu this dialog comes up
automatically for those linestyles you usually desire to change the scale factor on. If you
use the ByLevel selection method new to V8 you will have to invoke this dialog on your
own; change the scale factor then remember to change it back to 1 once through with the
linestyle placement else all subsequent selections will use the improper scale.

Use this when you desire to
change the Linestyle scale

factor.



New Line Styles

DRUMS   Line Style

Diagonals   (White)

Diagonals   (Yellow)

Double Diagonals



Changing the Gap Scale with the New Line Styles

Select Gap Scale as shown

Select the element then key in the distance desired with the
Accudraw Dialog Box shown below.



- Cell Library -

Overview

This selection does not load the individual cell libraries.  It merely loads the generic cell
library dialog box to where you can select the desired library from the file dropdown list.
This dropdown list is obtained from a MicroStation variable MS_CELLLIST. This
variable points to the directory(s) that contain the appropriate cell libraries and cell
library index files (*.cdx). They are located on our server in a central location.

One nice thing about defining a cell listing is when a cell name is known and entered as
the active cell (AC=term) for example, MicroStation will scan each cell library index file
in alphabetical order until the cell is located.  It will continue to scan the index files until
all have been checked.  If the cell name is in another file, the last one found will be used.
This process eliminates the need for you to remember which cell library the actual cell
resides in.



- Cell Selectors -

Overview

This Section of the Barmenu utilizes a utility, which brings up a dialog box graphically
showing the contents of the related cell libraries.  Each selection has been setup to go to
the appropriate cell library and bring up a user-sizeable dialog box. Each button within
these dialog boxes is associated with a cell from the cell library as selected from the
Barmenu.  Most of the buttons have been setup to display both the cell graphic as well as
the cell name.  Some, as with Guide Signs, just display the description (e.g. JCT) .



Each button can also contain a MicroStation key-in which is activated when the button is
pressed.  This key-in field can contain up to 511 characters.

If for some reason you wish to elaborate and customize the buttons with specific keyins
and or create your own cell selector files you may do so by utilizing the pulldown menus
on the cell selector dialog box.

Once defined and or customized you must save your file with a unique name in a location
on your machine that WILL NOT BE REPLACED when we perform a workspace or
software update.

To invoke your files simply select any of the listed cell libraries on the Barmenu
dropdown; once into a dialog box simply select file open and select your own unique file.

The following gives you a synopsis of the pulldown menu items:

File Pulldown Menu

The File pulldown menu is used to load and save cell selector files.  Cell selector files
contain each button's configuration information including the size and number of buttons
to be displayed.

File > New - Assigns a filename to the current configuration.  Save  must be used to write
the configuration to this new name.

File > Open - Load the previously saved cell selector  configuration file.

File > Save - Rewrites the current configuration to the current cell selector file.

File > Save As - Write the current configuration to the cell selector file specified.

File > Load Cell Library - Automatically defines the configuration based on the selected
cell library and the current default button settings.  Each cell in the selected library is
assigned to a button with the command and color for each button specified through the
Edit>Set Defaults menu selection.  The load command appends to the current
configuration, if the user desires to overwrite the current configuration the Edit>Clear
Configuration option should be selected prior to loading the cells.

File > Load Remote Cell Library - Lets you select a library on a web page for example.

File > Exit - Closes the Cell Selector dialog box.



Edit Pulldown Menu

The Edit pulldown menu is used to insert, delete, and configure individual buttons.  To
modify a button the user must first ensure that the button has focus (highlighted box is
around the button).  Optionally, the user may double click the mouse on the button to
edit.

Edit Cut...Copy...Paste > Allows you to grab previously defined buttons from one file and
copy or paste into another.

Edit > Button  - Opens the Configure Cell Selector Button dialog box shown below.  As
the focus changes between items this dialog will update itself so that it always represents
the button which has focus.

Edit > Insert  - Inserts a new button after the button which has focus.  The user must set
the button configuration using the dialog box shown below.  The default settings for the
inserted cell are defined via the Edit>Defaults menu selection.

Edit > Delete - Deletes the button which has focus.

Edit > Clear Configuration - Clear the configuration of all buttons.  This command is
generally used prior to loading cells from a cell library.

Edit > Button Size - Allows the user to set the size of buttons and the gap between them.

Edit > Defaults - Sets the button defaults, which are used when inserting new button
configurations.  These defaults should be set prior to loading cells from cell libraries.
The default key-in is made up of the prefix of the cell name and a suffix.  If the toggle for
cell name is set, the cell name is inserted into the key-in string after the string stored in
the prefix.  The suffix is appended to the string after the cell name (if the toggle is set).
For example if the prefix is "AC=", the toggle is set (and the cell is LIGHT), and the
prefix is ";aa=45;cm=2,3,25.0,25.0".  The complete key-in would be:

"AC=LIGHT;aa=45;cm=2,3,25.0,25.0".



- Text Sizes -

Overview

Sets the active text parameters to the symbology for plan view labeling as defined in the
Traffic Control's CADD Standards Manual.

This dropdown allows you to select the standard text size, font, weight, color and level
for most of the scales used for our plans.

The four (4) main categories defined are as follows:

Set General Text Size > Used for most of the proposed text or callouts on your
drawings.

MatchLines > Self explanatory.

Street Names/Title Blk> Self explanatory.

Stations/Labels > Used for the Cardinal Station Labels along each alignment plus
other various labels such as for sectional views, etc.



- Arrows -

Plan Sheet North Arrow

This selection merely makes our standard north arrow cell active for placement into your
design file.

NOTE: You will have to set the active scale to suit your own drawings needs.

Set True Scale

Use this feature to adjust the Line Terminators and Cells to a proper size when dealing
with prior or existing design files that were using the “Old English” working unit that has
been converted to Microstation V8.

Line Terminators

Sets the active Line Terminator to the desired type and proper size relative to the drawing
scale you are utilizing.

There are currently four (4) types to choose from according to you needs or preference.



Saving Design Files to other Versions / Formats

V8 to V7

To save your version 8 or V8 files to version 7 or V7 simply choose File…Save
As…from the top menu within Microstation and select the proper version or format from
the drop down menu shown above.

NOTE: Be sure to rename your file and select the destination folder or directory before
hitting the OK button.



Creating PDF Files within Microstation

1. Using the Print or Cntl+P function within Microstation

NOTE: The plot driver is already established for the pdf output. All you need do is
choose whether you want Monochrome, Grayscale or Full Color results.

Once you have
defined  or placed
a fence around the
elements you wish
to export or plot
Select – File…
then Print from
the Top menu in
Microstation or hit
the Cntl+P keys
simultaneously to
invoke the print
dialog box shown
to the left.

Next hit the
Printer Icon or
Select
File….Print from
the top menu then
choose the Name
and the location
you wish the file to
be created in on
our system.



2. Using InterPlot Organizer

Choose a file
previously saved
within the InterPlot
Organizer or create a
plot using IPLOT
making sure you save
the iparm, (ifile). Next
drag and drop the ifile
into the InterPlot
Organizer Window as
shown on the Left.

Next select the file you
desire within the
Organizer window and
Select File…Export
PDF…from the top
menu.



Make other selections
as desired then Hit the
Create PDF button.

Name and Save the file
to the desired location
on our system.



The New Design File Generator Program

This program is an extremely helpful tool to create Traffic Control design files utilizing
the current NCDOT file naming convention. Setup a shortcut Icon on your desktop as
you will want this program often.



File Naming Convention

1. TCP Design File Naming Structure.  When creating design files, name each file
according to the convention TIPNumber_Unit_FileType_Desc.dgn:

• TIPNumber – use the full tip number without any other symbols like “-“.
• Unit – This will always be TC for Traffic Control.
• File Type – There are four basic types used in Traffic Control as shown below.
• Desc – This is optional and can be any “short” description you want to use.  Some

units are using this for a date.  A good use would be for revisions (e.g. _Rev#1).  As
we move into using file referencing, this can be used to indicate the Phase of the plan.
(e.g. B9999BB_TC_Tcp1_PH1.dgn or B9999BB_TC_Tcp23_PH3.dgn)

a. B9999BB_TC_BPmp.dgn - This is the base pavement marking file. Roadway files
will be referenced to the these base files. If the Roadway files have a true “Display
On Reference” relationship then the Roadway files will be archived with the
other files, otherwise they will be deleted.

b. B9999BB_TC_pmp#.dgn - This is the pavement marking plan. The “#” denotes file
number beginning with the number 1 and going to the last file. The PMP base map
will be referenced to these files.

c. B9999BB_TC_BTcp.dgn – This is the base traffic control plan file. Roadway files
will be referenced to these base files. If the Roadway files have a true “Display On
Reference” relationship then the Roadway files will be archived with the other
files, otherwise they will be deleted.

d. B9999BB_TC_tcp#.dgn – This are the actual traffic control plan design files.  These
files will consist of the plan sheets for your design. The TCP Base map will be
referenced  to these files. The “tcp” denotes the traffic control plan.  The “#” denotes
file number beginning with the number 1 and going to the last file.

NOTE:  To facilitate file referencing and plotting, you should have only one design
sheet per file (Mandatory).  However, this is not critical for Title, Phasing, and General
Notes sheets.



Reasons for One File per Sheet

• Better organization of plans.
• Allows the plans to be coordinately correct.
• Allows others following behind you to quickly ascertain and retrieve data

from your project file.
• Also, allows others the ability to purge your project files leaving only the

essential final drawings.
• If one file gets corrupt to where you have to restore same, the entire

project isn’t shut down.
• Allows two or more people the ability to work on a set of plans without

the duplication of files.
• Easier for retrieval purposes many years down the road.
• Allows someone who is not familiar with your project, the ability to go in

and create a plot on specific sheets in very little time.
• Leads us into the use of reference files, which again eliminates

duplication of files and provides for a more efficient method of file
manipulation.

• Finally, it is now mandatory.


