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About the Contract Bill of Materials 
 
The Contract Bill of Materials, or CBOM, is the function that controls what materials are 
available to be used on an individual contract. It defines how much of each Material is 
needed based on the amount paid on each line item and its Conversion Factor.  
 
The CBOM contains a list of the Pay Items assigned to each contract during its 
creation. These Pay Items may or may not require Materials.  For example, Pay Items 
such as "Mobilization" or "Construction Surveying" do not require Materials.  This type of 
item is indicated by a check in the Labor Only checkbox. 
 
Most other Pay Items on a Contract will require Materials and the CBOM is where these 
Materials are listed. 
 
The Contract's Pay Items are drawn from the Master Pay Item list. Standard Pay Items 
can have Materials and Conversion Factors assigned to them on the Master Bill of 
Materials. These Materials can then be assigned to the corresponding Contract Pay 
Items on the Contract Bill of Materials when the Contract is Authorized. 
 
If a Contract Pay Item is created from a Generic Master Pay Item, or one that requires a 
Supplemental Description, the Materials cannot be defaulted.   
 
A Generic Pay Item appears in the Contract's "Itemized Proposal for Contract No. 
C123456" with a description similar to "Generic Utility Item - 12" DI Restrained Joint, 
Water Pipe, PC 350". The Sec # is SP. This is your indication that you need to consult 
the Contract's Project Special Provisions to determine the Materials required for that line 
item. 
 
A Pay Item which requires a Supplemental Description appears in the Contract's 
"Itemized Proposal for Contract No. C123456" with a description similar to "12" Gate 
Valve & Valve Box, ***** WP (200#)". The Sec # may or may not be SP. If the section 
number is given, consult the appropriate NCDOT Standard Specifications for the 
Materials to be used. If the Sec # is SP, consult the Contract's Project Special 
Provisions to determine the Materials required for that line item. 
 
Contract Pay Items that are created from these kinds of Master Pay Items will have the 
check box in the column Check for Materials checked.  
 
The Contract BOM may also list Work Items that have been added by the user to Lump 
Sum pay items such as Roadway Construction to track materials and work. Again, 
these Work Items are based on the Master Pay Item list and may or may not have 
Materials already assigned to them on the Master Bill of Materials. The Work Items 
listed on the CBOM will also display a check in the Check for Materials box if they are 
created from Generic Master Pay Item, or one that requires a Supplemental Description 
and a check in the Labor Only box if they do not require any materials. 
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Note 1: Pay Items which are not Labor Only and do not have 
Materials defaulted when the CBOM is built are identified on the 
CBOM window by having the box in the Check for Materials column 
checked. These Pay Items should be reviewed and Materials added 
as necessary in order to facilitate receipt of the Materials on the 
Project and Project Certification.  

Note 2: Contracts that were Authorized prior to September 25, 2006 
do not have Pay Items without Materials marked as Check for 
Materials. Only Generic Pay Items or those with Supplemental 
Descriptions are marked. 

 
The Contract Bill of Materials can be updated during Contract Activation, and 
throughout the life of the Contract. Work Items can only be added after Contract 
Activation so Materials on them must be reviewed after the contract is activated.  
 



Page 5 

The Contract BOM Window 
To work with the Contract Bill of Materials window, go to Functions > Contract 
Maintenance > Review Contract BOM. Enter the Contract Number whose Bill of 
Materials you wish to review. 

Note: For information on ways to enter your contract number, see the 
User Guide "Getting Started" in the User Guides section of the HiCAMS 
home page. 

Below is an example of the Review Contract BOM window for contract C203557.  

 
The lower portion of the window shows the material information for the Line Item row 
highlighted in the upper grid. 

Note: The default Sort Order is Line Item number first, then the Contract 
Adjustment by Number. Work Items are sorted Numerically by Line Item. 
The default Sort Order can be changed by clicking on the Sort icon or by 
selecting Edit > Sort. See the User Guide "Getting Started" for more 
details on working with the Sort function. 
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Updating the Contract BOM (Bill of Materials) 
The primary reason for updating the Contract Bill of Materials is to provide an accurate 
and complete listing of the materials that are incorporated into the Project. Documenting 
the Material Received, Accepted, and Paid quantities is critical to Project Certification. If 
the Materials are not listed, or the conversion factor is set incorrectly, the quantity totals 
will be incomplete or inaccurate. 
 
The initial Verification of the Contract BOM occurs during the Contract Activation 
process. Often, required materials cannot be identified until the project is underway, so 
the contract Bill of Materials can also be updated throughout the project's construction. 
 
To thoroughly verify the Contract BOM, the following tasks should be completed for 
each Line Item. 
1. Confirm that the Material Listing is complete. 

The Materials on each line item should be reviewed. Those which are not present 
should be added, and those which are not needed should be deleted. To 
determine what materials should be on those Line Items that have the Check for 
Materials box checked, consult either the Standard Specifications or the 
Contract's Project Special Provisions.  
 
It is possible that a line item that has the Check for Materials checkbox checked 
does not need materials. See the Appendix for more information on this. 

2. Confirm that the Conversion Factors are appropriate. 
The Conversion Factor works in conjunction with the quantity Paid to Date to 
determine how much of each Material is required to perform that paid amount of 
work. When the Material Unit of Measure and the Line Item Unit of Measure are 
the same, the Conversion Factor will usually be 1. When the Material Unit of 
Measure and the Line Item Unit of Measure are different, the Conversion Factor 
may be defaulted from the Master Bill of Materials or it may need to be calculated 
using information specific to the Project and found on the Contract Plans. 

 
The Contract BOM Report is useful for conducting this review, whether a hard copy is 
printed or it is viewed online. The Report shows the Materials and Conversion Factors 
assigned to each line item. Corrections can be made and are reflected immediately 
when the report is regenerated. 
 
The Contract BOM also provides data for the quantities displayed in the Audit Materials 
function that will contribute to the quality of the Project's Certification. 
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Adding a New Material to a Contract BOM Line Item 
The verification of the Line Items indicates that there are no materials assigned to line 
item 141 (1'-**"X*****"CONC PARAPET [(1'-2" X 2'-10"). The Bill of Material in the 
Structure plans indicates that Class AA Concrete and Epoxy Coated Reinforcing Steel 
are used to construct this line item.  
Step 1:  Go to Functions > Contract Maintenance > Review Contract BOM. Enter 

the Contract Number whose Bill of Materials you wish to review. The Review 
Contract BOM window opens. Our example uses C201181. 

Step 2:  Select Line Item 141 on the CBOM listing, and click on the Insert button  
or use the Insert key on the keyboard. The Material Selection window opens. 
To narrow your material search, set the Material Type to Concrete Class AA 
and click the Retrieve button. 

 
Here is how the Material Selection window will appear after the Retrieve. 
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After clicking OK, the Material will be inserted on the General Tab of the CBOM for Line 
Item 141. The window looks like this: 

 
Notice that the Conversion Factor is set to 0.00 and the Quantity is blank. 
 

Possible Error: 
If you Save now, you will receive the following error message: 

 
Click OK and enter the correct conversion factor. 

 
Step 3:  Enter the Conversion Factor.  

Possible Error: 
If you enter a one for the conversion factor, and the Line Item UOM is not 
the same as the Material UOM, you will receive the following warning: 
 

 
You can still save the record, but the improper conversion factor will cause 
discrepancy problems with your Materials. 
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To calculate the Conversion Factor for the Class AA concrete, find the plan quantity on 
the Bill of Material in the Structure plans. In this example, the quantity of Class AA 
concrete required for the plan quantity of 192.83 LF of Parapet wall is 24.1 CY. The 
conversion factor asks the question "How much of this material do I need for each one 
of the pay item units?" In this case, how many cubic yards of concrete are used in each 
linear foot of Parapet Wall? The conversion factor is equal to 24.1 CY divided by 192.83 
LF = 0.125 CY/LF. 
 
Step 4:  Enter 0.125 for the conversion factor. The Material quantity required 

calculates to 24.104 CY. This is within the margin of error for this calculation. 
 

 
Step 5:  Save the record. A green checkmark should appear at the end of the row. 
Step 6:  Next, add the Epoxy Coated Reinforcing Steel to the same Line Item. Click 

the Insert button to open the Material Selection Window. Set the Material 
Type Group filter to Steel and type *epoxy* in the Material filter. This will 
search for all materials that contain the word epoxy in their description. 

 
Here is how the Material Selection window will appear after the Retrieve. 
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Step 7:  Select the third row "Reinforcing Steel, Epoxy Coated" and click OK. 
 
To calculate the Conversion Factor for the Epoxy Coated Reinforcing Steel, find the 
plan quantity on the Bill of Material in the Structure plans. In this example, the quantity 
of Epoxy Coated Reinforcing Steel required for the plan quantity of 192.83 LF of 
Parapet wall is 3400 LBS. The conversion factor asks the question "How much of this 
material do I need for each one of the pay item units?" In this case, how many pounds 
of reinforcing steel are used in each linear foot of Parapet Wall? The conversion factor 
is equal to 3400 LB divided by 192.83 LF = 17.632 LB/LF. 
 
Step 8:  Enter the conversion factor (17.632). The Material quantity required 

calculates to 3399.979 LB. This is within the margin of error for this 
calculation. 

 

 
 

Note: This screenshot shows the Contract BOM window before the Labor 
Only indicator was added. 

Step 9:  If you are entering two or more Materials that can be used in place of each 
other, a Substitution Group can be established. To do this, enter the same 
alpha or numeric character in each row.  

Step 10:  Save the record. A green checkmark should appear at the end of the row. 
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Note: Until the record is Saved, Materials can be deleted by using the 

Delete  button. This method does not create a History record. 

Note: The Conversion Factor can be changed throughout the life of the 
project by clicking in the Conversion Factor field and typing in the new 
number. All Tickets previously created will have the Conversion Factor in 
effect at that time they were created. The new Conversion Factor will be in 
effect for any newly Inserted Tickets. 

More information on Conversion Factors can be found in the User Guide "Working with 
Conversion Factors". 
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Copying Materials from a Contract BOM Line Item to another Contract 
BOM Line Item on the Same Contract 
Sometimes there are similar Line Items on a Contract which do not have Materials 
assigned to them. In this case, Materials can be copied from one line item to another 
line item. In the case of contract C201181, Line Item 142 is 1'-**"X*****"CONC 
PARAPET [(1'-2" X 3'-6 3/4")] and it has the same materials as Line Item 141.  
 
There are two methods for copying materials from Line Item 141 to Line Item 142. 

Note: The following screenshots show the Contract BOM window before 
the Labor Only indicator was added. 

 
Method 1: 
Step 1:  Go to Functions > Contract Maintenance > Review Contract BOM. Enter 

the Contract Number whose Bill of Materials you wish to review. The Review 
Contract BOM window opens.  

Step 2:  Select the Line Item that contains the Materials you wish to copy. In this case, 
select Line Item 141, then Right-Click. A popup menu is displayed. 

Step 3:  Select Copy from the popup menu. 
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Step 4:  Select the Line Item to which the Materials will be copied. In this case, select 
Line Item 142 and Right-Click. The popup menu opens again. This time, 
select Paste from the menu. 

 
Here is an example of how the window looks after the Materials are pasted onto the 
second Line Item.  
 

Possible Error: 
The Materials and their associated Conversion Factors are copied. If 
different quantities of Materials are required for the second line item, the 
Conversion Factor must be changed. 

 

The Structure plans Bill of Materials for this Line Item list 30.2 CY of Class AA Concrete 
and 4144 LB of Epoxy Coated Reinforcing Steel as being required. The conversion 
factor for the Concrete is equal to 30.2 CY divided by 192.83 LF or 0.157 CY/LF. The 
conversion factor for the Reinforcing Steel is equal to 4144 LB divided by 192.83 LF or 
21.490 LB/LF. 
 
Step 5:  Enter the Conversion Factors and Save the record. 
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Possible Error: 
If Materials already exist on the Line Item to which you are copying 
Materials, you will receive this message: 

 

 
Clicking Yes will continue with your Paste operation and replace or delete the existing 
Materials. Remember that Deletes are prohibited if the Material is already in use in the 
system.  
 
Clicking No will cancel your Paste operation and allow the existing Materials to remain 
in place. 
 
Method 2: 
Step 1:  Go to Functions > Contract Maintenance > Review Contract BOM. Enter 

the Contract Number whose Bill of Materials you wish to review. The Review 
Contract BOM window opens.  

Step 2:  Select the Line Item to which the Materials need to be copied. In this case, 
select Line Item 142. Click Insert. The Material Selection window opens. 

Step 3:  Change the Filter selection from Material Type to Contract. The Contract Line 
Item filter appears.  

Step 4:  Set the Line Item filter to Line Item 141. This is the Line Item that contains the 
Materials we wish to copy. 
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Possible Error: 
If the Line Item you want to use does not have any Materials currently 
assigned to it, it will not appear in the Line Item filter. 
 

Step 5:  Click the Retrieve button. The Materials that are assigned to Line Item 141 
appear in the drop down. 

Step 6:  Right Click and pick Select All from the Popup menu. 
 

 
 
Step 7:  Click OK.  
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Here is an example of how the window looks after the Materials are inserted onto the 
second Line Item.  
 

 
 
Notice that in this case, only the Materials are copied, not the Conversion Factors. 
 
Step 8:  Enter the correct Conversion Factors and Save. 
 



Page 17 

Removing Materials from a Contract BOM Line Item 
There are several reasons that Materials may need to be deleted from your Contract 
BOM.  
1. Materials are created on the Contract BOM Line Items during the Authorization 

process by defaulting the corresponding Materials from the Master BOM Pay Items. 
The Master BOM attempts to be complete for any Line Item used so Materials not 
appropriate to your location may be defaulted to your Contract even if they are not 
going to be used on your Contract.  The removal of these Materials is part of the 
Verification process for the Contract Bill of Materials. 

2. Substitutable Materials that are not used should be removed. For instance, the 
Materials defaulted to the Pay Item "MASONRY DRAINAGE STRUCTURES" are: 

 
Brick, Clay 
Brick, Concrete 
Concrete, Class B 
Masonry Drainage Structures, Steps for 
Precast Concrete Units 
Reinforcing Steel, Plain, For Miscellaneous Use 
Block, Concrete 

 
If your contractor has already told you that only Precast Concrete Units will be used, 
the Materials for the Brick and Block can be deleted. 

3. The Pay Item was eliminated from the Contract work so no Materials were used. 
4. The Material was added to the wrong Line Item. 
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To remove a Material from the Contract BOM, follow these steps: 
Step 1:  Go to Functions > Contract Maintenance > Review Contract BOM. Enter 

the Contract Number whose Bill of Materials you wish to review. The Review 
Contract BOM window opens. 

Step 2:  Select the Line item that has Materials that need to be deleted. In our 
example, that is Line Item 25. 

Here is how the window looks after the line item is selected: 
 

 
Notice the number 1 in the Substitution Group column. This is an indication that this 
group of Materials can be used in place of each other. In our example, we know that the 
contractor will not be using the Brick and Block so they must be deleted. 

Step 3:  Select the Material that you want to delete and click on the Delete button  
in the Toolbar. The Material is removed from the display. 

Step 4:  Save the record. If the Material is not in use on the contract, it will be deleted 
and a History record will be created. 

Step 5:  Continue selecting and deleting the unneeded materials from your list. 
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Note: To select several consecutive line items at once, press and hold 
down your Shift key and click the first line item, click the last line item, then 
release the Shift key. To select several non-consecutive line items at 
once, press and hold down your Ctrl key, click on each line item, then 
release the Ctrl key. 

 
Possible Error: 
If the material you are trying to delete is in use, you will receive an error 
message similar to this when you Save: 

 
When you click Close, the Material will appear back in the display with a 
green check mark. 
 
Possible Error: 
If you delete all but one of a set of Materials that are part of a Substitution 
Group, you will receive the following message: 
 

 
In most cases, you want to Click Yes. You should click No if the remaining 
Materials can be substituted for each other. The Materials will be restored 
to the list, and you can modify the substitution group values before saving. 
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Minimum Sampling Guide Versioning and the 
CBOM 
 
In HiCAMS Version 6.1, the Minimum Sampling Guide (MSG) was redesigned to 
incorporate Version Control. This means that when MSG Material Types are changed, 
the changed version will affect future contracts and not be retroactive to all current 
contracts as it has been in the past. An example would be if the MSG sample frequency 
requirements are changed from being 1 sample per 5,000 tons to being 1 sample per 
2,000 tons. The new frequency would be applied to all new contracts but would 
generally remain at the old rate for existing contracts.  
 
A look at the MSG tab of this Contract shows that there are three different versions of 
this Material Type on this contract, Versions 3.00, 3.01, and 3.02. Each version has an 
Effective Date and an Expired On Contract date displayed. The Material Type in effect 
on the date of a Material Receipt, Ticket, Sample, etc. is the one that will control the 
Acceptance of the material quantity.  
 

 
When the Material Selection window opens, the version of the Material's Material Type 
displayed is the one that was in effect on the Contract's Letting Date. However, if 
revisions have been made to the Material Type since the Letting Date and they have 
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been applied to the contract, those updated versions also need to be assigned to the 
contract.  
 

 
Note: Do not be alarmed if the MSG status is Expired. This status refers 
to the current status of the Material Type. It is still available for your 
contract because it was Current on your Contract's Letting Date. 

When you select this material, you may get the following pop-up message: 
 

 
This message indicates that all the revised Material Type versions in use on your 
contract will be assigned automatically to this line item when OK is clicked.  
 
 
Here is how the MSG tab of will appear after clicking OK, assigning a Conversion 
Factor, and Saving the record: 
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Printing the Contract BOM 
It is sometimes helpful to have a hard copy of the Contract BOM to review or distribute 
to the field Inspectors. There are two ways to generate the report. 
 
Printing the Contract BOM report from the Standard Reports window 
Step 6:  Go to Inquiries > Standard Reports. The Select A Report window opens. 
Step 7:  Find "Contract BOM Report" in the list, and select it. The Report filters will 

display. Enter the Contract number for which you require the Report and Tab 
out of the field. 

Possible Error:  
If you enter your Contract Number and hit the Enter key instead of the Tab 
key, you will not have the chance to set the other filters before the report is 
generated. 

 
Here is an example of the Select A Report window after the Contract Number has been 
entered and the Criticality filter has been set to Critical. 
 

 
 
The Line Item filter allows only for a consecutive listing of Line Items. To select non-
consecutive Line Items, generate this report from the Review Contract BOM window. 
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The dropdown filters refer to the same fields on the Minimum Sampling Guide and can 
be used to narrow the output of the Report. 
 
Step 8:  After the filters have been set, click the Generate button. The Contract Bill of 

Materials Report preview opens.  
Here is an example of the CBOM report preview window. 
 

 
 
Notice that the report begins with Line Item 6. This indicates that Line Item 6 is the first 
Line Item to have Critical Materials assigned to it. Remember that the Criticality filter 
can be set to All if the entire list of Materials for the contract is desired. 
 
Step 9:  To print a hard copy of the Report, click on the Printer button. The standard 

Print dialogue box opens. Continue Printing as usual. 
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Printing the Contract BOM report from the Review Contract BOM 
window 
Step 1:  Go to Functions > Contract Maintenance > Review Contract BOM. Enter 

the Contract Number whose Bill of Materials you wish to review. The Review 
Contract BOM window opens. 

Step 2:  In the Toolbar, go to File > Print or click on the Printer button  or use the 
keyboard shortcut CTRL-P. The CBOM Print Selection window opens. The 
selection window is simply a relisting of the Contract BOM window with the 
capacity for selecting more than one row at a time. An example of the window 
with Line Items 1-10 selected is shown below. 

 

 
Note: To select several consecutive line items at once, press and hold 
down your Shift key and click the first line item, click the last line item, then 
release the Shift key.  To select several non-consecutive line items at 
once, press and hold down your Ctrl key, click on each line item, then 
release the Ctrl key. 

 
Step 3:  After the Line Items for the Report have been selected, click on the Print 

button at the bottom of the window. The Contract Bill of Materials Report 
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preview opens. An example of the window for Contract Line Items 1 through 
10 is below. 

 

 
Notice that although Line Items 1 through 10 were selected, Line Items 1 (Mobilization), 
2 (Construction Surveying), and 4 (Supplemental Clearing and Grubbing) do not appear 
on the report. This is because there are currently no Materials associated with those 
Line Items. These Line Items also have either the Check for Materials box checked or 
they have the Labor Only indicator checked. In addition, this report displays all Criticality 
Codes. If you want to view only Critical Materials, generate the report from the Standard 
Reports window. 
 
Step 4:  To print a hard copy of the Report, click on the Printer button again. The 

standard Print dialogue box opens. Continue Printing as usual. 
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Remember 
1. Materials must be listed on the Contract BOM before they are available for selection 

in the Material Receipts, Tickets, Material Prepayments, Field Inspection Reports, 
and Sample windows. 

2. Care should be taken when entering the Conversion Factor. Unless the Units of 
Measure for the Line Item and the Material are the same, the Conversion Factor is 
probably not 1.000. For additional information on conversion factors, see the 
HiCAMS User Guide "Working with Conversion Factors" 

3. For specific help with calculating conversion factors for your project, please contact 
your M&T Area Engineer, the Materials and Test Unit (Francine Moody or Randy 
Pace Phone 919-733-7091), or the Construction Unit (919-707-2400). 
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Appendix: Window Definitions 
The Contract BOM Window 
To work with the Contract Bill of Materials window, go to Functions > Contract 
Maintenance > Review Contract BOM. Enter the Contract Number whose Bill of 
Materials you wish to review. 

Note: For information on ways to enter your contract number, see the 
User Guide "Getting Started" in the User Guides section of the HiCAMS 
home page. 

Below is an example of the Review Contract BOM window for contract C201277. A 
Work Item added to Line Item 1 is highlighted and shows the Materials assigned to the 
Work Item, the same as Materials are assigned to a Pay Item. You can also see an 
example of a line item with the Check for Materials checkbox checked and a Labor Only 
Work Item. 
 

 
 

Note: The default Sort Order is Line Item number first, then the Contract 
Adjustment by Number. Work Items are sorted Numerically by Line Item. 
The default Sort Order can be changed by clicking on the Sort icon or by 
selecting Edit > Sort. See the User Guide "Getting Started" for more 
details on working with the Sort function. 
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Column Definitions for the Review Contract BOM Window 
Line Item: The Line Number for the Pay Item in the Contract's Itemized Proposal. 
 
Contract Adj: If the Line Item was added by a Contract Adjustment, the type of 
adjustment with its number will appear in this column. Line items are added by 
Supplemental Agreement (SA), Force Account (FA), Leftover Materials (LOM), 
Eliminated Contract Items (ECI), Claims (C), and manually by the Construction Unit 
(OTH). Generally, only Line Items added by SA or OTH will have materials associated 
with them. 
 
Work Item: The Work Item number. Work Items are used on Lump Sum pay items to 
track materials and work. For more information about Work Items, see the User Guides 
"Review Work Items" and "Review Work Accomplished". 
 
Description: The Pay Item description. This is the same description that is found in the 
Standard Specifications.  
 
Quantity: The Contract Quantity for the Line Item. 
 
Unit of Measure: This is the Unit of Measure or UOM associated with the Line Item. It 
may or may not be the same as the Unit of Measure for the Materials used on the Line 
Item. 
 
Check For Materials: This box is checked if the Labor Only indicator is unchecked, and 
one of these three cases exists: 
1. No materials exist for the line item on the Master Bill of Materials OR 
2. The Pay Item was created from a Generic Master Pay Item OR 
3. The Pay Item required a Supplemental Description. Some Line Items requiring a 

Supplemental Description have materials but not conversion factors assigned to 
them. These pay items will still be checked to indicate that they need to be reviewed. 

Note: These Pay Items should be reviewed and Materials added as 
necessary in order to facilitate receipt of the Materials on the Project. 
Some of these Line Items are Labor Only but because they are created 
from Generic Line Items, that check box cannot be checked, nor can the 
Check for Materials box be unchecked. 
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Information about the Review Contract BOM Tabs 
General Tab Column Definitions:  
 

 
 

Row: A number assigned by HiCAMS. Used to identify the rows that cannot be 
saved. 
 
Material: The various substances assigned to this Contract Line Item to be 
incorporated into the Project during its construction. 
 
Master Conv Unknown: If this check box is checked, it indicates that the Master 
Bill of Materials cannot set the Conversion Factor for this Material. It must be 
entered by the user based on Contract Specific information. 
 
Conversion Factor: Displays the current Conversion factor. The conversion 
factor defines how many Material Units are required for each Line Item Unit. In 
this example above, where the Material UOM matches the Line Item UOM, the 
conversion factor is set to 1.000 because each payment of one ton requires one 
ton of Material. When the Material UOM does not match the Line Item UOM, the 
Conversion Factor is generally not set to 1.000. For more information on 
conversion factors, see the User Guide "Working with Conversion Factors". 
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Substitution Group: Identifies Materials that can be used in place of each other. 
When several materials can be used for the same purpose on a Line Item, a 
Substitution Group is created. In this example, either Asphalt Concrete Surface 
Course Type S9.5B or RS9.5B can be used for this line item. Substitution Groups 
are denoted by entering the same number or letter into the Substitution Group 
column for the Materials. In this case, the ones could be replaced with upper or 
lower case letters, or other numbers. The Substitution Group will enter into 
Project Certification calculations at a future date. 
 
Quantity: The quantity column displays the calculated quantity of Material 
needed if the Bid Quantity amount of work is done. In this case, 700 tons 
payment on the Line Item would require 700 tons of the Material. 
 
Unit of Measure: This is the Unit of Measure associated with the Material. It may 
or may not be the same as the Line Item Unit of Measure. 
 
 

MSG Tab Column Definitions: 
 

 
Material: The various substances assigned to this Contract Line Item to be 
incorporated into the Project during its construction. 
 
Material Type: The MSG Material classification that contains the Acceptance 
and Testing Requirements for this Material. 
 
Version: The MSG Version of the Material Type in use on this contract. 
Contracts may have different Material MSG version numbers depending on when 
they were let, the unit of measure in use, and special provisions which define a 
testing requirement just for that contract. 
 
Effective Date: The start date for when this Material Type and Material 
combination can be used on the contract. For the original contact materials that 
are defaulted by the Master Bill of Materials during Authorization, the Effective 
Date is the same as the Letting Date. When changes are made to an MSG 
Material Type, they may be applied to existing contracts or just to newly let 
contracts. If the change has been applied to your contract, the new MSG version 
will show on the MSG tab. The original Material Type's Expired on Contract date 
will be one day less than the Effective Date of the updated MSG Material Type. 
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Expired on Contract: The last date that the Material Type and Material 
combination can be used on Contract Records. In most cases, the Expired on 
Contract date will be 12/31/2075. If a Material's MSG Type has been modified 
and replaced on the Contract, the Expired on Contract date will reflect the last 
date that those MSG requirements will be applied to the Material quantities. 
 
Criticality: The Minimum Sampling Guide Project Certification Criticality code. 
The MSG Project Certification Criticality Codes are Critical, Non-Critical and 
Minor. 
 
How Received: The Contract Tracking function that updates the Received 
Quantity for Project Certification. Possible functions include Material Receipt, 
Ticket, or Not Received. 

Note: The How Received code may change from version to version 
of the MSG for the same Material Type. It is possible for the 
material listed to be received by Material Receipt when the project 
begins and be changed to Not Received at sometime during the life 
of the project. 

It is also possible to view the complete MSG information for a Material Type by Right-
Clicking on the Tab. Select MSG from the popup menu and the Minimum Sampling 
Guide information for that version will display. 
 

 
History Tab Column Definitions: 
 

 
Note: In this example, the Right Click menu has been used to turn 
Word Wrap on so that the entire Material Description is displayed. 
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Material: The various substances assigned to this Contract Line Item to be 
incorporated into the Project during its construction. 
 
Action: Displays what has happened to each Material. The possible actions are 
Create, Modify, or Delete. 

Note: All Materials defaulted from the Master Bill of Materials will 
have a Create Record with an Action Date set to the date and time 
the Contract was Authorized, and Who set to the name of the 
person who Authorized it.  

Action Date: When the Action took place. The Default sort order for the tab is by 
Material, then Action Date (most recent first). 
 
Conversion Factor: Displays the conversion factor for the Material when the 
Action occurred. 
 
Substitution Group: Displays the Substitution Group for the Material when the 
Action occurred. 
 
Who: Displays the name of the person who performed the Action. 
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The Material Selection Window 
The Material Selection window was redesigned for Version 6.1. An example of that 
window is shown below. 
 

 
 
Information about the Material Selection Window filters 

 
Material Type or Contract Filter: The default setting for this filter is to the 
Material Type. This is the same as in previous HiCAMS versions. 
 

The following filters are available when Material Type is selected: 
 
Material Type Group: A new, higher level category called Material Type Group 
has been added to the window. These groups can be used to apply an initial 
filtering to the Material Type List. 
 
Material Type: The Material Type filter provides a listing of all the MSG Material 
Types.  
 
Material: This field functions as a Find tool. If you want to identify all the 
Materials that start with the word "steel", you would type steel into the Material 
field and click on Retrieve. If you want to identify all the Materials which contain 
the word "steel", you would type *steel* into the Material field and click on 
Retrieve.  
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Metric/English: The Material unit of measure system is defaulted from the 
Contract.  
 
Unit of Measure: A listing of the possible material Units of Measure. 
 
From Date/To Date: Defaults to the Contract's Letting Date. 
 

The following additional filter is available when Contract is selected. 
 
Line Item: A listing of all the Line Items that currently have Materials assigned to 
them. This filter is useful if you have the same Line Item repeated on the contract 
several times and none of them have any materials defaulted by the Master 
BOM. For instance, "Supports for Overhead DMS Structures at STA *******", has 
no Materials associated with it on the Master BOM. Once you have added the 
Materials to the Line Item, you are able to copy the same materials to the 
remaining ones. 

 


