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I. Introduction

General Workflow

The following general workflow has been developed, as detailed in the remainder of this
document.

A. Complete initial layout of channels using OpenRoads tools.  All ditches should be
developed using corridor modeling methods.  Establish initial corridor models for
ditches that incorporate civil “rule” dependencies to terrains, geometry, and/or
roadway corridors as desired.  Some preliminary hydraulic capacity/stability assessment
should be performed beforehand to identify approximate ditch dimensions and
minimum and maximum ditch slope constraints for the ditch profile.

B. Using the initial ditch layout, including the dimensions and profiles for the ditch reach
segments, use FlowMaster, FHWA Toolbox, a spreadsheet, or some other means to
perform a hydraulic analysis to check capacity and velocity and determine the required
ditch cross-section and lining needed for each reach.  If the OpenRoads Drainage and
Utility channel layout tools are used for hydraulic analysis of ditches, refer to separate
documentation for those tools.  However, such channel links in the Drainage and Utility
model should never be used for 3D modeling or plan production.

C. Make adjustments of the OpenRoads ditch design based on the hydraulic assessment.
Using the proposed cross-section data and lining types for each reach, add parametric
constraints and adjust point controls and template drop selections for the ditch corridor
model to update the design.  If needed, the profile can also be adjusted.  Repeat Steps B
and C if needed until ditch corridor model is finalized.

D. After the ditch corridor models are finalized, complete tasks to prepare the Redline
Drainage Plans.  This includes identifying and preparing the ditch cross section details as
well as showing the proposed ditches on the roadway profiles and cross sections,
including any needed modifications to the roadway corridor models.

E. After approval of the Redline Drainage Plans, coordinate with the Roadway Design Unit
staff to incorporate the needed roadway corridor model modifications as described in
detail in this document for various kinds of ditches.
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Ditch Terminology

The procedures in this document, and the standard ditch templates in the NCDOT
WorkSpace are intended to adhere to the terminology used in the NCDOT document “Ditch
Drafting Guidelines”.

Below is screen shot of the ditch template library, showing how the ditch templates are
organized:

1. Head and Tail Ditches.  These are ditches that
are not associated with the roadway, and have
independent alignments.

2. Lateral Ditches.  These are ditches that are
located in true “fill” sections of a roadway.
They are located on the outside of the roadway
corridor, along the fill slope stake line.  As
shown in the screen shot on the next page
from the Ditch Drafting Guidelines, there are
generally two categories of lateral ditches:

a) Unclassified Excavation (UCE).  These
ditches have a continuous slope from
the roadway shoulder point to the
bottom of the ditch.  The ditch
excavation is considered part of the
roadway earthwork quantity, and the
roadway is technically considered in a
“cut” in such locations.  A slope stake
line where the fill slope intersects the ground is not shown on the plans.

b) Drainage Ditch Excavation (DDE).  These ditches have berm between the fill slope
stake line and the top of the ditch foreslope.  Or, there is no berm but the
roadway fill slope is different than the ditch foreslope.  The ditch excavation is
quantified separately from the roadway excavation.

3. Outside Channel Change.  These are ditches that relocate or reconstruct existing
channels under or adjacent to the roadway.

4. Special Cut Ditches.  These are ditches that are located in true “cut” sections of a
roadway.  They are located in roadway medians and in the shoulder areas.  These
templates are intended to be used to create Special Cut Ditches that modify the
standard cut ditches produced by the roadway corridor models.
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Corridor Modeling Terminology

“Template”.  This refers to the typical section that is applied to the horizontal and vertical
alignment geometry of a roadway or ditch to create the initial corridor model.  Default
templates are stored in a template library file (ITL) located outside the DGN.

“Point Constraints”.  This refers to properties of a template specifying how each point in the
template is related to, or constrained, to other points.  For example, the outside edge of a
lane is 12’ right of the baseline at a 2% slope.

“Parametric Constraints”.  This is a type of corridor edit.  Parametric constraints override
the template point constraints in order to change template dimensions such as lane width,
slopes, pavement depth, etc.

“Point Controls”.  This is a type of corridor edit.  Point controls override the location of a
point on a template.  Points can be
controlled by other geometry, other
corridor features, specified elevation and
grade, etc.

“Secondary alignments”.  This is a type of
corridor edit.  By default, templates are
applied perpendicular to the horizontal
alignment selected for the corridor.
However, additional alignments can be
added as secondary alignments to force
the template drop lines to be placed The effect of a secondary alignment
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perpendicular to these secondary alignments to account for lane tapers, slope stake lines,
and other features that are not perpendicular to the roadway baseline.

“End Condition Exceptions” or ECE.  This is a type of corridor edit.  End conditions are the
part of the template beyond the shoulder hinge point – the side slope that seeks existing
ground or another feature.  An ECE overrides the end conditions specified in the template
and replaces them with something else.  A specific type of ECE is “backbone only” which
turns off the end condition entirely within a specified station range on the left or right side
of the road.

“Remove Rule”.  This is an edit to any ORD civil geometry that is dependent on another
feature.  For example, a new horizontal alignment may be created from a slope stake line
using an Offset tool with the offset set to zero.  The alignment would then be dynamically
dependent on the slope stake line.  This dependence can be removed using the Remove
Rule tool.  This is often necessary in modeling workflows to avoid circular dependency
errors.

Naming Convention

Ditches should be named using the following convention: alignment name, baseline station
of ditch starting point (to the nearest foot), and notation of left or right side of road.  For
example:

L_118+23, LT

Video Links

Throughout this manual, links are provided to videos on the NCDOT YouTube channel that
demonstrate the described workflows.  The links are indicated by highlighted text shown as
(Video) that contain URL links that will direct you to specific locations in videos that
correspond to the particular step in the workflow being described in the manual.  If viewing
the document from a website, you may wish to right-click on the link and choose “open in a
new window” to maintain access to this document while simultaneously viewing video
segments.
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II. Head and Tail Ditches

Head and tail ditches have independent alignments – they are not part of, or dependent
upon, a roadway corridor model.  Head and tail ditches typically flow towards or away from
a drainage system element such as an inlet, headwall, end section, or open-ended pipe.
However, the following procedures can be used for any ditch with an independent
alignment outside the grading limits of a roadway corridor.  Ditches should be created in a
new DGN file created from a 2D seed.

B. As detailed below, the general workflow includes the following steps:

1. Create horizontal alignment.

2. Create vertical alignment and make it the Active Profile for the horizontal alignment.

3. Create a corridor model by applying one of the standard NCDOT ditch templates for
head/tail ditches.

4. Make adjustments as needed to the ditch corridor model by adjusting the horizontal
and/or vertical alignments.  Further adjustments by adding or modifying template
drops, or adding parametric constraints are discussed in Chapter IV.

C. Create ditch horizontal alignment.  (Video)

1. Make sure the workflow is set to OpenRoads
Modeling.

2. Go to Geometry > Standards > Feature
Definition Toolbar and dock it above the view
window if not already there.  Set the active
feature definition to Linear > HYD_Modeling >
HYD_Ditch_Baseline, and toggle on Use Active
Feature Definition.

3. Go to Geometry > Horizontal
and select Complex by PI.

https://youtu.be/udwqMcn-_g0?t=34
daube
Highlight
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4. In the tool settings dialog or heads up prompt,
provide a name for the alignment such as L_17+04,
LT.

5. Set the value for radius to 0.0 and set the Ahead
and Back Transitions to None.

6. <D> (“accept” or left mouse click for standard right-
hand mouse setup) in the design file to place PI
points along the proposed ditch centerline to layout
an alignment as shown in the example below.

7. After alignment is created, you can revise it by selecting the alignment and clicking
and dragging any of the PI points.  Go to Common Tools > Table Editor and use this
tool to add a radius to any PI points that create sharp bends in the alignment that
may cause crossing templates in the corridor model (if you’re not sure, you can hold
off and do this later as needed).  However, it is usually desirable to avoid curves in
order to simplify construction layout.

L_17+04, LT
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D. Create ditch invert vertical alignment.  (Video)

1. Select a feature from the referenced existing
terrain and from the fly-out menu select Set As
Active Terrain Model.

2. Use the Element Selection tool to select the ditch
horizontal alignment, and from fly-out menu, select
Open Profile Model.  Select an unused view
window and <D> in the window to create a profile
model.

3. Click on the View Attributes in the upper left corner
of the profile model view window.  Under the Civil
tab you can change the profile exaggeration if
desired.

4. Go to Geometry > Vertical > Complex Geometry and
select Profile Complex by PI.

5. Provide a Name such as L_17+04, LT.

6. Check the box for Curve Length, enter a
value of 0.0, and leave the other boxes in
the dialog unchecked.  Profiles for ditches
should not use vertical curves.

7. Set invert elevations at upstream and
downstream end of the ditch, as well as
any intermediate points by placing data
points in the profile window to create a
series of PI points as shown on the next
page.  However, read Steps 8 through 11
below before placing your vertical PI points.

L_17+04, LT

https://youtu.be/udwqMcn-_g0?t=204
daube
Highlight
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8. Remember that when placing the PI points, you can
use Civil Accudraw to specify a slope, a particular
station and/or elevation, or a vertical offset.  If you
don’t have this toolbar docked, go to Geometry >
Civil Toggles > Civil Accudraw and open the toolbar
and dock it.  Note that stations in a profile view
always refer to the station of the element being
profiled, not some other baseline reference such as a
roadway baseline.  The element being profiled is
shown in the upper left corner of the profile model window.

9. When done, <R> (“reset” or right mouse click for standard right-hand mouse setup)
to complete the process.

10. After alignment is created, you can revise it by selecting the alignment and clicking
and dragging any of the PI points.  Remember you can use the Undo tool at any
time.  You can also edit the profile using the text manipulators for station and
elevation of the PI points, as well as the slope of the lines.  You can also use the
Microstation Add Vertex and Delete Vertex tools to add PI points.

11. In some situations, you may want to snap to existing ground at the start or end of a
profile to tie into the existing surface.  Or you may want to snap the vertical PI points
to the vertical gray lines in order to make the vertical PI points coincide with the
horizontal PI points (which is recommended).  However, remember that when you
use a snap,  you are creating a civil rule.

Set to Slope Mode

Set to Station-Offset Mode
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Do you want to prevent your ditch profile from automatically updating if the terrain
model is revised?  Do you want to be able to revise the vertical PI points after they
have been snapped to the horizontal PI locations?  If so, then you do not want to
create these civil rules.  If you ever want to snap to an element without creating a
civil rule dependency, toggle off the Persist Snaps and Rule toggle on the Feature
Definition Toolbar.  It is recommended that you do this when creating ditch profiles.

12. When the profile is done, select it and from the flyout menu select Set As Active
Profile.  The alignment will now appear in the 3D model view if you have it open.
Note: any time after the ditch corridor has been created, you can come back to this
profile model window and revise the profile and the corridor will automatically
reprocess.  This is also true of any changes to the horizontal alignment.  However, if
changes are made to the horizontal alignment, you should check the profile as well
to make any needed revisions.

E. Create a corridor model for the ditch.  (Video)

1. Go to Corridors > Create > Template and select Create Template.  When the dialog
opens, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and select NCDOT-
Hydraulics-Ditches.ITL, and then click Open.  Then close the Create Template dialog.

2. Go to the Corridors tab and select New Corridor.

3. In the dialog box, for the Feature
Definition go to Corridors and select HYD
w/Contours from the drop-down list.

4. At the prompt Locate Corridor Baseline,
select the previously created horizontal
alignment.

5. At the prompt Locate Profile, select the
profile previously created that represents the ditch centerline profile.  Or, you can
<R> to select the active profile.

6. At the prompt Corridor Name, provide unique name such as L_17+04, LT and <D> to
accept.  A temporary shape will appear representing the newly-created corridor
model (see example on the next page).  Move your mouse a little to get the next
prompt to select a template drop.

L_17+04, LT

https://youtu.be/udwqMcn-_g0?t=433
daube
Highlight
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7. If you accidentally exit from the process at this point, simply select that shape and
from the flyout menu select Corridor Creation Tools > Create Template Drop.

8. In the dialog box, in the Template field, go to Typical Sections > Drainage Ditches >
Head/Tail Ditches and select the template Trap_Riprap_CL-B.  Or, if using the heads
up prompt, press ALT + Down Arrow to select the template.  Click OK.

9. Check the boxes for Lock to Start and Lock to End in the tool settings dialog (or press
the ALT key if using the heads up prompts) to apply the template to the entire ditch
alignment.  Alternatively, you can specify specific start and end locations for the
template by keying in station values, or by selecting graphically in the file with your
mouse.
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10. Check the box for Drop Interval and enter a reasonable value.  Generally, for ditches
this value should be in the range of 1 to 5 feet, depending on the level of precision
desired.  Since ditches tend to use small and simple corridor models, it is
recommended to use 1’ most of the time.  In this example, 5’ is used to make the
template drops easier to see.  Enter 5.0 in the dialog (or enter directly by using the
heads up prompt).  You can change this value later.

11. <D> in the design file to accept all dialog settings.  After confirming the Drop
Interval, the corridor model will be created and displayed in the view window.

12. Go to Home > Primary > Attach Tools > References and turn off display of the
referenced 3D model.

13. Note the graphics that are displayed:

 Lines for Top of cut slope/limit of grading (green).

 Line for ditch center (light blue dashed line) and bottom width of ditch (red).

 Lines for limits of the riprap lining (red).

 Graphics for the corridor handles (yellow) and template drops (dashed light
blue).  To edit a ditch corridor, you select these graphics and choose reviewing
and editing tools from the flyout menu.  If desired, you can turn off display of
these graphics which are on the level Draft_Corridor_Graphics_Final.

 Note: the corridor graphics have an Element Class set to Construction, so they
will not plot.

14. Turn on display of the referenced 3D model and go to Home > Primary > Level
Display, select the 3D model reference, and turn off display for all levels except
P_HYD_Contour_Major and P_HYD_Contour_Major.
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Notice that the displayed contours reflect the 4:1 slope of the riprap lining and the 2:1
slope of the ditch slopes beyond the riprap.  As discussed in Section IV of this document,
these slopes (as well as other ditch dimensions  and channel lining) can be revised as
desired after the corridor model has been created.

F. Using Dynamic Sections to Review the Corridor Model  (Video)

1. Go to Corridors > Review > Dynamic Sections > Open Cross Section View.  At the
prompt Locate Corridor or Alignment, select the manipulator handle for the corridor
in the plan view window.  Or you can select one of the corridor handles and select
this tool from the flyout menu.

2. Select an unused view window and <D> in the window to display a cross-section
view of the corridor.  Note that the riprap lining and fabric layers are displayed, as
well as the existing ground and nearby roadway corridor model.  Anything that is
referenced to the 3D model will be visible here such as proposed drainage and
existing or proposed utilities.

https://youtu.be/udwqMcn-_g0?t=654
daube
Highlight
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If the road corridor or existing terrain is not shown, make sure the cross section window is
active and then go to Level Display and check that the level display for these reference files
is turned on.

You can use the left and right arrow navigation buttons to step through the corridor cross-
sections.  However, this can be very tedious.  There are better ways to navigate the cross
section viewer:

1. Click on the station drop-down list and directly enter a station value.  However, be
sure your mouse cursor stays in the key-in field when you press ENTER or it will
often not work.

2. <R> and press in the cross section
view window to display the tool
menu.  About 2/3 the way down the
list select Locate Station Via
Datapoint.  You will then be
prompted to pick a plan or profile view
window (note that you can use either) and then <D> to identify the station visually,
snap to identify the station from a graphic element, or key-in a specific station.

3. Once a cross section view has been established for a corridor, select one of the
corridor handles, and a “slider” handle will appear.  Drag this slider up and down the
corridor to quickly review cross sections.  See image below.
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G. Using the 3D Model to Review the Corridor Model   (Video)

1. Select and open the view window for the 3D model.  If one has not been set up yet,
then <R> and press in a view window and go to View Control > 2 Views Plan/3D to
have OpenRoads create a 3D model view.

2. Select Fit View and zoom to the area of interest.  Use Rotate View with Method set
to Dynamic to provide a 3D perspective view.  Be sure to move the cross-hair so that
it snaps to an element near your area of interest before rotating.

3. Go to Home > Primary > Level Display and verify that the levels
P_HYD_Contour_Major and P_HYD_Contour_Major for contour display are turned
on.

https://youtu.be/udwqMcn-_g0?t=756
daube
Highlight
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III. Lateral Ditches

Lateral ditches are located next to the toe of a fill slope (slope stake line) for a roadway.
Using OpenRoads, such ditches can be dynamically tied to the fill slope stake (SS) line such
that shifts of the slope stake line automatically result in a corresponding shift in the ditch
location.  To accomplish this, a template with an origin point on the left or right side will be
needed.  Such templates are available in the NCDOT WorkSpace.  Ditches should be created
in a new DGN file created from a 2D seed, and DGN files containing the existing terrain
model, proposed geometry, and roadway corridor model should be referenced.

Although the overall concept is straightforward, in practice the processes for modeling
lateral ditches are complicated by numerous factors:

 Can the SS line from the Roadway corridor model be used, or will changes to the
roadway corridor model be needed to address needs identified by the Hydraulics
Unit?  For example, changing the fill slope from 3:1 to 2:1 will shift the SS line.  If
Shoulder Berm Gutter is requested, that will typically change the location of the SS
line as well.  This will require steps to create a new SS line for ditch modeling.

 Is the SS line fairly straight, or does it contain angular deflections?  Due to the nature
of corridor modeling using template drops perpendicular to the corridor baseline,
such deflections can cause crossing template problems which may need to be
addressed by adding small horizontal curves.

 If it is desired to use the roadway baseline as the reference baseline for a lateral
ditch instead of the SS line, then additional steps are required in the modeling
process to shift the ditch from its initial position at the roadway baseline to its actual
position at the SS line.  In addition, the SS line needs to be added to the ditch model
as a “Secondary Alignment” in order for the template drops to be perpendicular to
the ditch (not the roadway baseline) in order to ensure correct ditch dimensions and
quantities.

 How will the ditch profile be established?  Using the “Elevation and Grade” method,
or by creating horizontal and vertical geometry for the ditch profile?

The next page provides a Flow Chart to help visualize these decision points.  In the following
pages, the steps for modeling lateral ditches under four different ditch control scenarios will
be outlined:

1. Use the existing SS line from the Roadway corridor model as the control.

2. Use a new SS line created on top of the existing SS line from Roadway, but with curves
added to address crossing templates.

3. Use the Roadway baseline as the ditch control line.

4. Use a new SS line that takes into account needed changes to the Roadway fill slope.
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                                                     FLOW CHART FOR LATERAL DITCHES

Do you need to make a change to the
Roadway corridor model fill slope

stake (SS) line?  For example, adding
shoulder berm gutter or changing side

slope from 3:1 to 2:1, etc.

Create a corridor model for
the revised fill slope to create

a new fill SS line.

Create a corridor model
for the ditch using the

new fill SS line.

Create a corridor model for the ditch.
Three options for ditch control
baseline:

a) Use Roadway SS line.
b) Create new baseline on top of

Roadway SS line.
c) Use Roadway baseline.

Apply template(s) to
ditch corridor model.

Apply Parametric Constraints to ditch
corridor model to change bottom

width, side slopes, lining height, etc.

Apply template(s) to
ditch corridor model.

If using option “c” above, then
apply Point Control to shift ditch

control line to the fill SS line.
Otherwise, skip this step.

Apply Point Control to set the ditch profile:
a) Elevation and Grade method.
b) Linear Geometry method.

Add flow arrow lines
where appropriate.

Yes No
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A. Create ditch corridor model using the existing Roadway SS line.  (Video)

1. Select a feature from the referenced existing terrain model and set it as the Active
Terrain as discussed in the previous section.

2. Turn on display of the referenced CMD corridor model and ALG geometry files.

3. As discussed in the previous section, in the OpenRoads Modeling workflow, go to
Corridors > Create > Template and select Create Template.  When the dialog opens,
go to File > Open and browse to C:\NCDOT_CONNECT_WORKSPACE\Configuration
10_10\Organization-Civil\Disciplines\NCDOT_Hydraulics\Standards\Template
Library and select NCDOT-Hydraulics-Ditches.ITL, and then click Open.  Then close
the Create Template dialog.

4. Go to Corridors > Create and select New Corridor.

5. In the dialog box, go to Feature Definition and select HYD w/Contours from the
drop-down list.

6. At the prompt Locate Corridor Baseline,
select the toe of slope line feature from the
roadway corridor model.  Be sure to hover
over the feature first and use the ORD
attribute feedback to verify you are
selecting the correct feature.  <R> if
needed to cycle through other features
that may be located in the same place.

7. At the prompt Locate Profile, <R> to select the active profile for the toe of slope line
feature.

8. At the prompt Corridor Name, provide the name such as L_16+46, LT in the dialog
and <D> to accept and then move your mouse a little to bring up the Create
Template Drop dialog shown below.

https://youtu.be/NS_ufqetBeQ
daube
Highlight
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To select a template, you can either click on the ellipsis button in the dialog or use
the ALT + Down Arrow key combination on your keyboard to open the Pick
Template window.

Note that the Lateral Ditches folder contains two subfolders:

 DDE.  Use these templates to model ditches where the ditch foreslope is different
than the fill slope (Drainage Ditch Excavation quantity).  Typically, such ditches will
also have a berm between the slope stake line and the top of the ditch foreslope,
but you can choose to change the berm width value to zero if desired by using a
Parametric Constraint, as explained in Chapter IV.

 UCE.  Use these templates to model ditches where the ditch foreslope is a
continuation of the roadway fill slope, with no berm (Unclassified Excavation
quantity).

Note also that the above two folders are further divided for ditches that are located on
the Left and Right side of the roadway.  In accordance with the standard convention,
“left” and “right” are defined as looking up-station in reference to the roadway baseline.
It is important that you select a template for the correct side.

9. In the current example, browse to Drainage Ditches > Lateral Ditches > DDE > Left
Side and select Lat_LT_Trap_Riprap_CL-B for a base ditch with Class B riprap.

10. Specify the Start and Stop station by using your mouse or entering values.
Remember that for lateral ditches the corridor model needs to be stationed in the
same direction as the roadway baseline, which may be the opposite direction of the
ditch flow.
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11. Enter a value for Drop Interval such as 5.0.

12. <D> in the design file to accept all dialog settings.  The corridor model will be
created and displayed in the plan view window.

Note that in this example the ditch has a low point in it because it is following the profile
of the slope stake line.  This will be addressed in the following steps.

13. As discussed in the previous chapter, go to Primary > References and turn on display
for the 3D model to see the contour lines for the new ditch corridor.

14. As discussed in the previous chapter, create a dynamic cross section view window to
review the corridor.

At this point the ditch has a uniform depth such that the ditch bottom is a fixed distance
below the toe of the fill slope.  We now need to add Point Controls to establish an
independent profile for the ditch.  (Video)

https://youtu.be/NS_ufqetBeQ?t=179
daube
Highlight
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15.  As explained in the previous chapter, select the ditch centerline feature in the new
ditch corridor and from the fly-out menu select Open Profile Model, select an
unused view window and <D> in the window to view the profile.  The existing
ground profile and the initial ditch invert profile will be displayed.

16. To create the Point Controls for the ditch profile adjustments, you will need a table
of start and stop stations, start elevations, and slopes.  To develop this data, it is
helpful at this point to create a temporary profile in the profile model window to
layout your proposed profile points.  As explained in the previous section, use the
Feature Definition Toolbar to set the default Feature Definition to
HYD_Ditch_Baseline.

17. Go to Geometry > Vertical > Complex
Geometry > Profile Complex by PI and use
the procedure detailed in the previous
chapter to create a profile from PI points.
Do not worry about being precise for the
first try.  You can always make adjustments
later.  Ensure that the box for Curve Length
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is checked and the value is set to zero.  Enter the name Working Profile.  Don’t
forget about Civil Accudraw.

We used the slope stake line from the roadway corridor model as the horizontal control for
our ditch corridor.  Therefore, the stationing for the ditch corridor is taken from the slope
stake line, which is different than the roadway baseline stationing.  Unless you started your
ditch corridor at the very beginning of the slope stake line, the stationing for the ditch
centerline (from which you created the profile) is not the same as the ditch corridor
stationing or the roadway baseline stationing.  The station data for the Point Controls must
match the corridor stationing, not the ditch centerline stationing.

18. Go to Home > Model Analysis and Reporting > Civil Analysis > Analyze Point, select
the slope stake line in the plan view, and then in the profile view you can obtain the
corridor stationing for each of the profile PI points you created.

19. The data shown below is an example; your data will be different.

Ditch
Station

Start
Elevation Slope

Start 415.94 875.27 -3.3457%
PI 582.95 869.67 -1.0832%

End 734.34



NCDOT Hydraulics Unit Standard Workflows
Ditch Design Using OpenRoads Designer

22

20. Select one of the ditch corridor handles and
from the flyout menu go to Corridor Creation
Tools and select Create Point Control.

21. In the dialog for Create Point Control (see
image below), check the boxes for Start and
Stop and enter the first set of stations from
the data table: 415.94 and 582.95.

22. For Control Description, enter DitchInvert.

23. From the drop down list for Point, select
~DITCH_BOT_IN.  This is the bottom of the
ditch foreslope – and the point in the
template that is to be controlled by the Point
Control.

24. Select Vertical for the Mode, and Elevation
and Grade for the Control Type.

25. Enter 875.27 for the elevation and -3.3457%
from the data table.

26.  <D> in the design file to accept all prompts.
The corridor will reprocess, and you will see
the ditch profile update.  Note that the new
profile will not exactly match your temporary
profile, and there may also be some
“bumpiness”.  This can happen because the
stationing of the corridor is based on the alignment of the toe of the roadway fill
slope, not the alignment of the ditch centerline, and it’s the ditch centerline that
was used for the profile.  As the depth of the ditch becomes variable, the ditch
centerline feature will no longer be exactly parallel to the the toe of fill slope and the
stationing and length of the ditch centerline will be different than the toe of fill line.
Changes in ditch alignment can also cause this to happen.  For this reason, you will
find that this process is often iterative: your initial values for elevation and grade
may need to be repeatedly adjusted as you refine the profile to match your intended
profile.

27. Redo this process to add a second point control using Start = 582.95, Stop = 734.34,
Elevation = 869.67, and Slope = -1.0832%.  Continue adding point controls to the
corridor until all data has been entered.
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28. In the profile window, delete the temporary profile.

29. Turn on the display of the referenced 3D model and review the contour grading for
the ditch.  Notice that the low point in the ditch has been eliminated.

30. Go to the 3D model view window and review the ditch, using the Rotate View tool.
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B. Create ditch corridor model using new SS line on top of the existing Roadway SS line
with added curves.

The previous approach works best when the fill slope toe is linear and does not have
abrupt angular changes in horizontal alignment.  Deflection angles in horizontal
alignment may create template drops that cross each other and cause model glitches.
Usually, moderate changes in alignment are tolerated fairly well when contours are
displayed.  As you can see in the example below, there is an area where templates are
crossing.  Yet, the contour display was acceptable.

If crossing templates become a problem, there are two approaches you can take to
address the issue:   (Video)

1. The easiest approach is to simply reduce the frequency of template drops by
increasing the template drop interval.  Select the graphic for the template drop (light
blue dashed line) and from the flyout menu select Properties.  In the Quick
Properties dialog that pops up, type in a new (larger) value for the Interval.  This is
typically an iterative process – try various values until you obtain the desired results.
Usually, continuing to increase the Interval beyond a certain value will not be
helpful, so increase the Interval in small steps.  If you cannot obtain acceptable
results using this approach, then try the second approach below.

https://youtu.be/NS_ufqetBeQ?t=606
daube
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2. Instead of using the roadway corridor slope stake line as the ditch corridor
horizontal control, place a separate alignment along the path of the slope stake line.
This can be done by using the Complex by PI tool and placing a series of points,
snapping to the roadway corridor slope stake line.  Be sure that the Persist Snaps
toggle in the Feature Definition Toolbar is ON so that your new slope stake line will
be ruled to the roadway corridor slope stake line.  It is not necessary to snap to
every vertex in the slope stake line feature – just add enough points to follow the
line.

3. Once this line has been created, you can now use the Table Editor at Geometry >
Common Tools to add small horizontal curves at any interior angles to eliminate the
crossing templates.  Remember, you can come back later and easily use Table Editor
to edit the curve radii.  See Chapter IV for further discussion of adding horizontal
curves.  Some things to remember when using this approach:
 Once the horizontal alignment has been set,

you will need to establish a profile for the
control line which is based on draping the
alignment on the existing terrain.  To do this,
go to Geometry > Vertical > Profile Creation >
Profile From Surface.  Follow the prompts or
complete the dialog to create a profile and
don’t forget to set it as the “active” profile
when finished.

 Try using smaller radius values.  You can
usually eliminate the crossing template drops with small curves in the alignment.

 Remember that when creating the horizontal alignment, you can snap to the
slope stake line wherever you wish to create a “ruled” alignment that will update
if the roadway slope stake line shifts.
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C. Create ditch corridor model using the Roadway baseline as the ditch control line.

One may use the roadway baseline as the reference baseline for a lateral ditch instead
of the SS line.  The principal benefit of this is that for corridor edits the stationing is the
same as the roadway baseline.  However, the disadvantage is that several additional
modeling edits must be made.  First, a point control must be added to shift the ditch
from its initial position at the roadway baseline to its actual position at the SS line.
Second, the SS line needs to be added to the ditch model as a “Secondary Alignment” in
order for the template drops to be perpendicular to the ditch (not the roadway
baseline) in order to ensure correct ditch dimensions and quantities.

1. Go to Corridors > New Corridor.  Set Feature Definition to HYD w/Contours as
before. (Video)

2. At the prompt Locate Corridor Baseline, select the roadway baseline.

3. At the prompt Locate Profile, select profile “Y2” from the list.

4. Enter a ditch name such as Y2_16+46, LT.

5. In the dialog, click on the ellipsis button to launch the Pick Template dialog, and
select a template such as Lat_LT_Trap_Riprap_CL-B as in the previous example.  <D>
to accept the selection.

6. Enter the Start and End stations, based on the roadway baseline stationing.  In this
example, the start station is 16+46 and the end station is 19+40.

7. Enter a drop interval and <D> to confirm.  The initial ditch is then placed at the
roadway baseline.

The ditch now needs to be shifted to the slope stake line.  This is done using a Point
Control.

https://www.youtube.com/watch?v=M7__-oPuP1M
daube
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8. Go to Corridors > Edit > Edits > Create Point
Control.  Or, you can just select one of the ditch
corridor handles and select this tool from the
flyout menu.

9. Complete the dialog box as shown on the right.
It’s important that you complete the dialog from
the top down.  However, you must also pay
attention to the head’s up prompt and <D> to
accept the selected Corridor.  If you do not do this,
the drop down list for Reference Feature will not
show any features to select.

The ditch will then move to the fill slope stake line as
shown below.

As a consequence of using the roadway baseline as the baseline for the ditch, the
template drops for the ditch are perpendicular to the roadway baseline rather than to
the slope stake line.  This
results in a 3D model which is
not consistent with the
hydraulic calculations.  The
inaccurate ditch dimensions
will also result in inaccurate
ditch quantities for earthwork,
riprap, and geotextile.  To
correct this, a Secondary
Alignment needs to be added
to the ditch corridor model.
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10. Go to Corridors > Edit > Edits > Create Secondary Alignment.  Or, you can just select
one of the ditch corridor handles and select this tool from the flyout menu.

11. At the prompt Select Corridor, select one of the corridor handles, and at the prompt
Locate Secondary Alignment, select the fill slope stake line from the roadway
corridor model.

12. Enter and accept the Start and Stop stations, and enter zero for the Start and Stop
Offsets.  <D> to accept inputs, and the corridor will update.

As shown above, the ditch template drops are now perpendicular to the ditch flow line,
as they should be.  If crossing template drops become an issue, then you will need to
address this as discussed earlier in this chapter by creating a new slope stake line along
the original so that you can add vertices or small horizontal curves to eliminate the
crossing template drops if needed.  After this is done, use the new slope stake line as
the source for the Point Control to shift the ditch corridor from the roadway baseline to
the slope stake line.  You do not need to delete and redo the Point Control done
previously, just edit the one you already created by using the Corridor Objects tool.

 In the Point Control settings, change the settings so that the Control Type is
Linear Geometry, and you can then select the new slope stake line you created.
Also, check the box for Secondary Alignment.

 In the Corridor Objects tool, delete the first Secondary Alignment that was
added since you no longer need it.

As explained earlier in this chapter, you can then add a point control to set the ditch
profile.
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D. Creating a ditch corridor model when changes are required to the Roadway corridor
model.

It will often be the case that changes are needed to the roadway corridor model to
address Hydro requirements.  For example, shoulder berm gutter is to be added, or the
fill slope changed from 3:1 to 2:1, etc.  These changes are to be shown on the Redline
Drainage Plans for approval prior to submitting to Roadway Design Unit.  The following
workflow in this chapter is intended to provide a coordinated approach that:

 allows Roadway and Hydro staff to work in their own separate files, and

 avoids duplication of effort between the two Units.

The following is an overview of the recommended workflow:

 Hydro creates a corridor model of the revised roadway fill slope, which
establishes a new fill slope stake line.  Both the fill slope component and the new
slope stake line will be placed on levels that can be turned off for plan
production.  They are only to be used for Redline Drainage Plans.

 Hydro creates a corridor model for the ditch that uses the new slope stake line
as the ditch control point.  This corridor model will be used for both Redline
Drainage Plans as well as the final construction plans.

 After Redline Drainage Plan are approved, Roadway will edit the roadway
corridor end conditions so that they match the changes requested by Hydro.
Roadway’s corridor model will stop at the slope stake line and will not include
the ditch, avoiding duplication of modeling effort.

 In cases where the roadway has gone from a “fill” section to a “cut” section (as
with UCE ditches that have a foreslope which is a continuation of the roadway fill
slope), then Roadway will use End Condition Overrides so that the slope stake
line is a construction class element that will not appear on the plans, and that
change the slope component from a “fill” component to a “cut” component.

1. Go to Corridors > Create > New Corridor. (Video)

2. At the prompt Locate Corridor Baseline, select the roadway baseline geometry.

3. At  the prompt Locate Profile, select the desired profile from the dropdown list in
the dialog.

4. Give the new corridor a name, such as NewFillSlope.

https://www.youtube.com/watch?v=-PlbSrdnjOs
daube
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5. At the prompt Select Template, select the template Fill Slope LT since the ditch is on
the left side of the road.

6. Enter the Start and End stations for the new corridor.

7. Enter the template drop interval.  The new corridor will then be created.  At this
point, it will be located at the roadway baseline.

The next step is to apply a Point Control to shift the corridor to the shoulder break point,
using the same procedure as described earlier in this chapter.
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8. Go to Corridors > Edit > Edits > Create Point
Control.  Complete the dialog as discussed earlier
in this chapter.  The target point name for the
shoulder point is “~GB_N”.  This then shifts the fill
slope corridor to the correct location.  In this
example, the original 4:1 fill slope is being replaced
with a 2:1 fill slope.

The selected template has a default fill slope of
2:1.  What if you want a different fill slope?  You
can apply a Parametric Constraint to change the fill
slope.  However, an easier approach is to simply
edit the template drop so that it uses your desired
fill slope.

9. Go to Corridors > Edit > Edit Template Drop and select the corridor for the new fill
slope in the plan view window.  This will launch the template editor.  In the editor,
select the Active Template tab, and then open the folder for Parametric
Constraints.  Double click on the entry for Fill_Slope, and you can then enter the
desired value for fill slope.  See the screenshot on the next page.
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Now that the new fill slope has been established, the corridor model for the proposed
ditch can be created.  In this example, a grass trapezoid ditch will be provided that has a
foreslope that is a continuation of the roadway fill slope.

10. Go to Corridors > Create > New Corridor. (Video)

11. At the prompt Locate Corridor Baseline, select the new fill slope stake line in the plan
view window, and at the prompt Locate Profile, <R> to accept the active profile.

12. Give the ditch corridor a name such as Y2_16+46, LT, and at the prompt Select
Template, select the grass lateral ditch template under the UCE folder.

https://youtu.be/-PlbSrdnjOs?t=317
daube
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13. At the prompts for Start and End stations, you can press the ALT key to lock to the
beginning and end of the corridor baseline since you are now using the new fill slope
stake line, not the roadway baseline, as the corridor baseline.

14. Enter and accept the template drop interval, and the ditch corridor model will be
created.

What is shown above can now be used to prepare the Redline Drainage Plans.

The red line above is the original roadway corridor model fill slope.  Once the Hydro
design has been approved, Roadway will revise the roadway corridor to match the new
fill slope shown above in orange.  Roadway must use an End Condition Exception
Override that will change their fill slope from a “fill” component to a “cut” component.
They must also change the Feature Definition of the fill slope stake line feature so that it
creates a 3D linear feature as a construction class element.  When changing side slope,
remember that it is NCDOT practice to provide at least 50 feet between each 1’ shift of
side slope (i.e., 3:1 to 4:1).  This can be accomplished using parametric constraints as
discussed in the next chapter.

Roadway can then turn off the level P_HYD_TC_Fill_Slope containing the orange fill
slope line.  The 3D linear features for the ditch control line at the shoulder break point
as well as the new fill slope stake line are construction class elements that will not
appear on the final plans.

The next steps in the process are to make corridor model edits to change ditch
dimensions, add transitions, and add or modify channel linings.  This is explained in the
next chapter.
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E. Special Cases

1. Sometimes a lateral ditch may start out as a UCE ditch (no berm, with ditch
foreslope the same as the roadway fill slope) and then transition to a DDE ditch with
a slope break and/or a berm between the fill slope stake line and the ditch
foreslope.  When this occurs, there is no need to create two separate ditch corridor
models.  You simply change the template being used where the change occurs.  This
is done by going to Corridors > Create > New Template Drop and provide the Start
and End station range, the new template, and the template drop interval.  That new
template will then replace the existing template in that specified range.  You will
then likely need to add a parametric constraint (discussed in the next Chapter) to
transition from one template to another.  In this case, the berm width at the start of
the DDE ditch was transitioned from 0’ to 5’ wide.

2. Earlier in this chapter it was shown how you can create a new fill slope stake line on
top of the original line created by the roadway corridor model so that you can add
horizontal curves to address crossing templates.  Keep in mind that just as you can
add a Point Control to shift your ditch model from the roadway baseline down to the
slope stake line as shown earlier in this chapter, you can also use a Point Control to
shift a portion of your ditch corridor from the original slope stake line to a new slope
stake line.  That means that you can create a new slope stake line for just that
location where the crossing templates occur, and not necessarily for the entire ditch
length.

3. If you ever need to change the baseline of a ditch corridor model from one
alignment to another, or if the name of the baseline has changed, use the Reattach
Corridor tool to do this.  You do not need to recreate the corridor.  Follow the
prompts to select the ditch corridor and then select the new alignment.
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IV. Adjusting the Ditch Design
A. Adding Parametric Constraints   (Video)

Initially, the ditch corridor model has been created utilizing default values for the bench
offset from the slope toe, ditch bottom width, left and right-side slope, height of
channel lining, and thickness of channel lining and bedding layers, etc.  These default
values were taken from the specific template that was selected during the corridor
creation process.  The next step in the process is to adjust the corridor model based on
the hydraulic assessment that was completed.

The NCDOT standard templates for ditches contain “parametric constraints”.
Parametric constraints allow for template variables, such as bottom width or side slope,
to be defined in reference to a parameter that can be varied in the corridor model.  In
this way, the ditch dimensions can be adjusted at various locations along the corridor
without having to re-create the corridor or create new templates.  Refer to the
Appendix for a list of the available parametric constraints.

Before revising the ditch dimensions, you should first finalize the previously created
ditch invert vertical alignment if needed by revising the Point Controls.  The corridor will
automatically re-process.  If the vertical alignment is revised, then review the previous
hydraulic analysis and determine if ditch dimensions or linings need to be revised as a
result.

In this example, parametric constraints will be used to widen the ditch below station
6+40.  A transition section will be added between 6+20 and 6+40.  Therefore, two
parametric constraints will be needed: one for the widened ditch and one for the
widening transition.  Remember, however, that the stationing used for the parametric
constraints will use the ditch corridor stationing, not the ditch centerline stationing, nor
the roadway baseline stationing.

1. Select one of the corridor handles and
from the flyout menu go to Corridor
Creation Tools and from the drop-down
menu select Create Parametric
Constraint.

2. In the Create Parametric Constraint
dialog (see next page), enter 640.00 for
the Start location and 734.34 for the
Stop location (the station of the end of
the ditch corridor).

3. For the Constraint Label, select Bottom_Width.

https://youtu.be/pvvQK-SG9QI
daube
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4. Change the Start Value and Stop Value for
the parametric constraint to 8.

5. <D> in the view window to accept all dialog
inputs.  The ditch corridor will reprocess,
and all views will update.

6. The next step is to add a section to
transition the 4’ wide bottom width to an 8’
wide bottom width.  Repeat the above
process to add a new parametric
constraint.

7. Enter 620.0 for the Start location and 640.0
for the Stop location.

8. Enter 4 for the Start Value and 8 for the Stop Value.

9. <D> in the view window to accept all dialog inputs to update the corridor.

10. This same process can be used to change any other dimension of the ditch.



NCDOT Hydraulics Unit Standard Workflows
Ditch Design Using OpenRoads Designer

37

Determining Length of Transitions:

For creating parametric constraints for channel transitions, the NCDOT recommended
practice is to apply a 25:1 transition ratio.  In the above example, the bottom width was
increased from 4 to 8 feet.  Since the expansion occurs on one side of the channel, the
4’ expansion is multiplied by 25 to obtain a transition length of 100 feet.

Note that parametric constraints allow you to model linear transitions only.  If you want
a corridor feature to follow a curved path, then you must use a Point Control as
discussed earlier, except that instead of adjusting the profile, you would set the Model
to Horizontal and provide a horizontal control element.  Also, note that the default
templates all assume base (trapezoidal) ditches.  Therefore, if you are modeling a V-
ditch, then apply a parametric constraint to change the bottom width to zero.  You can
also use a parametric constraint to transition a ditch from a V-ditch to a base ditch.

Another place where parametric constraints are needed is where a ditch daylights to
existing ground.  In these cases, the lining on the backslope will automatically transition
as the ditch depth reduces to zero.  However, the lining on the foreslope will not.
Therefore, you will need to add a parametric constraint to gradually reduce the value of
“Lining_Height_IN” from its design height to zero over a specified station range.

B. Adding Template Drops   (Video)

In order to add, remove, or change the ditch lining it is necessary to revise the template
being used for the corridor model for the station range where the change is needed.  In
the current example, Class B riprap has been used for the entire length of the ditch.  It
will be revised so that Class II riprap is used for the 8’ wide portion of the ditch
beginning at 6+40.

1. Select one of the corridor handles and from the flyout menu go to Corridor Creation
Tools and from the drop-
down menu select Create
Template Drop.

2. In the dialog, check the
boxes for Start and End and
enter 640.0 and 734.34 for
the End.

https://youtu.be/pvvQK-SG9QI?t=223
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3. Enter 5.0 for the Drop Interval.

4. From the drop-down list, select Lat_LT_Trap_Riprap_CL-II.

5. <D> in the view window to accept all dialog inputs to update the corridor.

OpenRoads creates graphics in the plan view for the template drops.  If edits to a
template drop are needed, then select the template drop graphic and from the flyout
menu select Edit Template Drop.  It is important to remember that once a template has
been dropped into a corridor, it is completely separate from the template library from
which it came.  Edits to the template drop do not change the templates in the library.
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If you want the changes to be included in the library, then first make the changes to the
library, then select the template drop graphic and from the flyout menu select
Synchronize with Library.  The changes in the library will then be applied to the
template in the corridor.

C. Adding Horizontal Curves to Ditches   (Video)

It is often necessary to add
small horizontal curves to
ditch alignments to avoid
modeling problems caused by
corridor templates crossing
each other where there is a
deflection in the alignment, as
discussed earlier in Chapter
III.  This is more likely to occur for ditches with relatively large deflection angles and top
widths.  Fortunately, it is easy to add such curves.

1. Go to Geometry > Common Tools and select Table Editor.

2. At the prompt Locate Alignment, select the baseline of the ditch.  This brings up the
dialog for Alignment Table Editor.

https://youtu.be/pvvQK-SG9QI?t=388
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3. Select the middle row and in the plan view the tangents on either side of the
selected PI point will highlight in yellow.

4. In the Alignment Table Editor, change the value of Radius to 20, and then click
Apply to reprocess the corridor to see the change.  Experiment with different values
for radius.  Use the smallest value that provides good results.  When finished, close
the dialog.



NCDOT Hydraulics Unit Standard Workflows
Ditch Design Using OpenRoads Designer

41

V. Special Cut Ditches

Special cut ditches are located within the limits of the roadway corridor.  They modify the
“standard” cut ditches that result from the templates used in the roadway corridor model.
Some examples include:

 Increasing the ditch grade at crest vertical curves to eliminate flat spots.

 Creating a ditch that slopes in the opposite direction of the roadway grade (i.e.,
“bucking grade”).

 Lowering the ditch grade to match the invert of a cross pipe, or increase conveyance
capacity.

Since special cut ditches are incorporated into the project design through modification of
the roadway corridor model, it may not be necessary to create separate corridor models for
them.  It is only necessary to create the horizontal and vertical alignments for the special cut
ditches.  With this information, the Roadway staff can then use those alignments as point
controls for the roadway corridor model to make the needed modifications.  However,
Hydraulics Unit staff may wish to develop corridor models for the cut ditches as part of the
design process to evaluate the impacts of special cut ditch alternatives.  This could be a
more efficient alternative to the traditional approach of marking up roadway cross sections,
especially if the changes affect many cross sections.  This
chapter provides workflows for developing the horizontal and
vertical alignments that are needed by the Roadway staff, as
well as workflows for creating corridor models for evaluation
purposes.

Special cut ditches can be needed in grassed medians as well as
the shoulder areas.  The NCDOT ditch template library contains
different templates for cut ditches to support corridor
modeling.  One for medians, which has an origin at the center
of the template, and others for the shoulders, for left or right
side with origin points at the inside edge.

In the example discussed below, the
shoulder on the right side of the
roadway in a cut section will be
modified to create a cut ditch where
none currently exists.  First, the
horizontal and vertical alignments
are created.  Then, a corridor model
is developed so that the impacts can
be evaluated.
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A. Create a horizontal alignment for the special cut ditch.   (Video)

The cut ditch will be created by lowering the point at the outside of the shoulder where
the bottom of the backslope begins.  This point is represented in plan view by a feature
created by the roadway corridor model.

1. As shown in Chapter II, set the default Feature Definition to HYD_Ditch_Baseline
and make sure the Use Active Feature Definition toggle is ON.

2. Go to Geometry > Horizontal > Offsets and Tapers and
select Single Offset Partial.

3. In the dialog check the box for Offset and enter 0.0.
Leave all the other boxes unchecked.

4. Enter the ditch name.  In this example, the special cut
ditch will start approximately at 24+24 on the right side.

5. At the prompt Locate Element, select the feature for the
outside edge of shoulder.

6. At the prompt Start Distance and Offset, identify the start
point of the alignment by clicking with your mouse near
the beginning of the cut section.

7. At the prompt End Distance and End Offset, identify the end point of the alignment
by clicking with your mouse near the end of the cut section.  The new alignment will
then appear over top of the outside edge of shoulder line.

https://youtu.be/Jt8xNSpjq94?t=22
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B. Create a profile for the special cut ditch.   (Video)

1. As shown in Chapter II, select the horizontal alignment and from the flyout menu
select Open Profile Model, and place it into an available view window.

2. In the profile window, go to Create 3D Cut and create a 3D cut
window which will display the profile of the outside edge of
shoulder line from the corridor model.  Go to the References
dialog and make sure that Snaps are enabled for the nested
corridor model in the referenced 3D model.

3. As shown in Chapter II, go to Geometry > Vertical > Profile Complex by PI, and
create a lowered profile as shown below, snapping to the existing profile of the
outside edge of shoulder line.  Remember that you can use Civil Accudraw to set
station and/or elevation of the PI points in reference to the roadway baseline,
and/or set the slope of the ditch.

4. Remember to select the profile and make it the active profile.

At this point, you now have a horizontal and vertical alignment for the special cut ditch.
This information can now be used by Roadway as a Point Control to modify the roadway
corridor to lower the outside edge of shoulder to match your proposed profile.

The following workflow will demonstrate how to create a working corridor model for
the special cut ditch so that you can evaluate the modifications to the roadway corridor
that will result from the proposed ditch profile.

https://youtu.be/Jt8xNSpjq94?t=103
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C. Create a corridor model for the special cut ditch.   (Video)

1. Go to Corridors > Create > Template and select Create Template.  When the dialog
opens, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and select NCDOT-
Hydraulics-Ditches.ITL, and then click Open.  Then close the Create Template dialog.

2. Select New Corridor.

3. In the dialog, set the Feature Definition to
HYD w/Contours.

4. At the prompt Locate Corridor Baseline, select the corridor model feature
representing the back of the curb line.

5. At the prompt Locate Profile, <R> to select the active profile.

6. Enter the name Y2_24+24, RT.  This will create a yellow temporary box around the
roadway alignment.  Move your mouse to bring up the next prompt.

7. In either the heads up prompt or the dialog, select a template to use for the special
cut ditch.  If using the heads up prompt, press ALT and the down arrow key to bring
up the Pick Template dialog.  For this example, go to Drainage Ditches > Special Cut
Ditches and select Shoulder_RT_Grass since the special cut ditch is located on the
right side of the road.  Click OK to close the dialog, then <D> to accept the selection.

https://youtu.be/Jt8xNSpjq94?t=287
daube
Highlight



NCDOT Hydraulics Unit Standard Workflows
Ditch Design Using OpenRoads Designer

45

8. Go to the profile model window and using your mouse, snap to the beginning of the
special cut ditch profile to establish the start of the ditch corridor model and repeat
for the end.

9. At the prompt Interval, enter a value of 1.0’.  <D> to accept, and the corridor model
will be created.

10. Select one of the yellow corridor handles and
from the flyout menu select Open Cross
Section Model, and select an available view
window.

At this point, the selected template has simply been placed along the back of the curb line.
We now need to use parametric constraints to adjust the ditch dimensions, and point
controls to make the ditch invert follow the proposed special ditch profile.
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D. Use parametric constraints to change ditch dimensions.   (Video)

1. Select one of the yellow corridor handles and from the flyout menu select Create
Parametric Constraint.

2. The first corridor edit will change the
bottom width to zero to create a V-shaped section.  Complete the dialog as shown.
The <D> to accept all inputs.  The changes will be reflected in the cross section view.

3.  The next edit will change the backslope to 4:1 to match the roadway corridor.  This
time, we’ll use the heads up prompts instead of the dialog.  As before, select a
corridor handle and go to Create Parametric Constraint.

4. At the prompt Start Station, press ALT to lock to the
beginning and press <D> to accept.

5. At the prompt End Station, press ALT to lock to the
end and press <D> to accept.

https://youtu.be/Jt8xNSpjq94?t=445
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6. At the prompt Constraint Label, press the down
arrow on your keyboard until BackSlope
appears, then press <D> to accept.

7. At the prompts for Start Value and Stop Value,
enter 25% and <D> to accept.

E. Add Point Controls to establish ditch
profile.   (Video)

1. Select one of the corridor handles
and from the flyout menu select
Create Point Control.

2. Complete the dialog as shown:

 Check the boxes for Lock to Start
and Lock to End.

 Enter Invert as the description.

 Always select the point
+DITCH_BOT_IN as the point to
be controlled.

 Set the Mode to Both and Control
Type to Linear Geometry.

 Select the special ditch geometry
for plan and profile control.

https://youtu.be/Jt8xNSpjq94?t=519
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3. <D> to accept all inputs.  The cross section view will then be updated.

At this point, you now have a working corridor model which you can use to evaluate various
ditch design scenarios:

 Revising the ditch foreslope or backslope.

 Revising the width of the shoulder.

 Revising the ditch profile in the previously-created profile model window.

When you make any of these changes, the plan view, 3D model view, and cross section view are
all automatically updated, allowing you to view the changes along the entirety of the special cut
ditch corridor.

Note: in the above workflow, the template point which was controlled was the point named
+DITCH_BOT_IN, not the point named +DITCH_MID.  The reason for this is that the default
template is for a trapezoidal channel, and the points +DITCH_MID and +DITCH_BOT_OUT are
constrained to the vertical location of +DITCH_BOT_IN.  The purpose of Point Controls is to
override the “point constraints” defined in the ditch template – in this case the location of the
point +DITCH_BOT_IN.  Therefore, when using Point Controls it is very important that you first
review the template so that you understand which points need to be controlled.

In addition, be aware that you can apply more than one point control to the ditch corridor.  For
example, for a median ditch you may want to use the left side inner EOP to control the left top
of ditch line, a special cut ditch profile to control the centerline invert elevation, and the right
side inner EOP to control the right top of ditch line.
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F. Using Target Alias   (Video)

In the previous example, the template which was utilized to model the special cut ditch
in the right shoulder area had a backslope that intersected with the existing terrain to
establish the location of the top of the cut slope.  In some circumstances the special cut
ditch will intersect with the roadway corridor surface rather than the existing terrain.
For example, a special cut ditch in the median may be designed intersect with the
surface of the median modeled by the Roadway staff.  To do this, you can use a tool
called Target Alias.

1. Go to Corridors > Miscellaneous > Define Target Aliasing.

2. At the prompt Locate Corridor, select any feature of the special cut ditch corridor
model in the plan view.  The dialog will then display.

3. All available “surfaces” will be shown on the left.  Select the corridor model to be
modified by the special cut ditch and then click on Apply.

4. Make sure the box for Use Closest is not checked if you want to be sure that the
ditch cut slopes will not seek the existing terrain if it is closer than the corridor
model surface.  In this case, OpenRoads will check for intersection based on the
order in the dialog.  In the above example, the corridor model for Y2 will be checked
first.  Otherwise, check the box if you want the slope to intersect the closest surface.

https://youtu.be/Jt8xNSpjq94?t=736
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G. Reviewing Cross Sections with Temporary Dimensions   (Video)

1. In the cross section view window, right-press
to bring up a pop-up menu.

2. Select Place Vertical Temporary Dimesion.

3. At the prompt Start Point, snap to the point at
the back of curb.

4. At the prompt End Point, snap to the invert of
the adjusted cut ditch.

5.  At the prompt Dimension Location, <D> where
you would like the dimension to be shown.

You can now use the left and right arrow buttons in the cross section view window to
review the selected dimension along the ditch.

In order to use temporary dimensions, you must create the cross section view from the
corridor, not the alignment.  Also, you can only use temporary dimensions for features
in a corridor that is located within the active DGN, not corridor features from a
referenced corridor.

https://youtu.be/Jt8xNSpjq94?t=873
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H. Special Cut Ditches with Linings

As with lateral ditches, the templates for special cut ditches in the shoulder areas
include options for channel lining including Coir-Fiber, PSRM, concrete, and the four
different classes of riprap, as well as options for each side.

As with lateral ditches, if a special cut ditch with a lining daylights to existing ground,
then parametric constraints must be added to gradually reduce the foreslope lining
height to zero.

Remember that corridor models for special cut ditches will generally not be used for
plan production, but are only intended to be used to provide design parameters to
Roadway so that they can edit the Roadway corridor models for the special cut ditches.
Specifically, they will use the ditch centerline feature as a point control.  However, if
special cut ditches have linings, then the ditch corridor models will be used by Roadway
to show the linings on the Roadway cross sections.  Roadway will only use the levels for
the linings, and all other levels will be turned off.  For this reason, special cut ditches
must be put into a separate DGN file from the other Hydro ditches.

Another purpose of the Hydro special cut ditches is to provide profiles that can be
projected onto the Roadway profiles.  Refer to Chapter X for detailed discussion of
projecting ditch profiles.
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VI. Berm Ditches
Berm ditches are placed just above the top of cut slopes to intercept overland runoff
flowing toward the roadway in order to prevent erosion down the relatively steep face of
the cut slope.  For modeling purposes, a berm ditch can be treated as either a lateral ditch
or a tail ditch, and you can use the same templates in the ditch template library for this
purpose.  For the lateral ditches along a roadway fill slope that were discussed in Chapter III,
we used the roadway fill slope stake line as the control for the ditch.  For berm ditches, you
can use the top of cut slope feature as the control.  Alternatively, you can create a separate
control line, drape that line onto the existing terrain, and then use that feature to control
the berm ditch.  For the following example, we will use the tail ditch approach.

A. Create Berm Ditch Baseline   (Video)

1. In the Feature Definition Toolbar, set the active feature definition to Linear >
HYD_Modeling > HYD_Ditch_Baseline and turn on the Use Active Feature
Definition toggle.

2. In the OpenRoads Modeling workflow, go to Geometry > Complex Geometry >
Complex by PI and layout the proposed horizontal alignment representing the
centerline of the berm ditch.  Give the ditch a name (for example, Y2_25+48, RT)
based on the location of the start of the ditch.  Don’t worry about being exact – you
will tweak the location later.  See example below.  The end point for the berm ditch
has been extended to discharge to an existing ditch.

https://youtu.be/vYzSXX7NzjI
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3. Change the active Feature Definition to HYD_Construction.

4. Select one of the contours and verify that the existing
terrain has been set as the Active Terrain Model.
Then go to Vertical > Profile Creation > Profile From
Surface.  This will create an initial profile for the ditch
based on draping the horizontal alignment on the
active terrain.

5. Complete the dialog as shown using an offset of -2.0
to set the initial profile 2’ below existing ground.

6. At the prompt Locate Plan Element, select the
horizontal alignment created for the ditch, then <R>
to complete.

7. <R> to accept the active terrain model as the
reference surface.  <D> to accept all remaining inputs.

8. Create a profile model to review the profile:
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The next step is to create the design profile for the ditch using the offset profile as a
guide.

9. Change the active Feature Definition back to HYD_Ditch_Baseline.

10. Go to Geometry > Vertical > Complex Geometry > Complex by PI and create a
design profile by placing PI points in the profile model window.  End the profile by
snapping to the invert of the existing ditch.

B. Create Berm Ditch Corridor Model   (Video)

1. Go to Corridors > Create > Template and select Create Template.  When the dialog
opens, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and select NCDOT-
Hydraulics-Ditches.ITL, and then click Open.  Then close the Create Template dialog.

2. Go to New Corridor.

3. At the prompt Locate Corridor Baseline, select the horizontal alignment for the ditch.

4. <R> to accept the active profile.

5. <D> to accept the name, which is based on the name of the selected alignment.

6. Move your mouse to bring up the next prompt: Select Template.  Press ALT and
down arrow key to bring up the Pick Template dialog.

7. In the dialog, select the template at Head/Tail Ditches called Trap_Riprap_CL-B.
Click OK to close the dialog, and then <D> to accept the selection.

https://youtu.be/vYzSXX7NzjI?t=273
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8. At the prompt Start Station, press ALT and then <D> to lock to start and repeat for
the End Station.

9. Enter 1.0 for the interval, and <D> to accept.  The corridor will then be created.  See
below.

C.   Apply Parametric Constraints   (Video)

The corridor as initially created uses the default dimensions in the selected template.
The next task is to apply parametric constraints to revise the ditch dimensions.  Review the
procedures detailed in Chapter V to apply parametric constraints and then make the
following changes:

 Change value for Bottom_Width to 0 to change ditch to V-shape.

 Change value for Lining_Slope to 50% (enter 50 or 100/2) for 2:1 slope.

https://youtu.be/vYzSXX7NzjI?t=383
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D. Finalize the horizontal and vertical alignment.   (Video)

As a result of the changes in ditch dimensions, the limits for grading for the ditch may be
very different than when the initial corridor was created.  Use the graphic manipulators in
both the plan and profile view windows to adjust the ditch horizontal alignment and profile
so that the inside top of berm ditch is approximately 5’ away from the top of the roadway
cut slope in accordance with NCDOT design guidelines.

https://youtu.be/vYzSXX7NzjI?t=469
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In the plan view, turn off the level Draft_Corridor_Graphics_Final and review the ditch
grading after adjustment:

Also review the 3D model view of the berm ditch.  Note that the ditch transitions to zero
height and depth as the profile approaches existing grade at the end of the ditch:

This is the 3D model view with some levels turned off and the contours turned on:
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VII. Channel Changes   (Video)

Channel changes occur when an existing channel, either under or outside the limits of the
roadway, needs to be relocated.  When the channel is located on the outside of the
roadway limits, this sometimes results in cross sections where an existing channel needs to
be filled adjacent to the location of the new channel location.  The NCDOT standard ditch
templates are provided to assist in modeling this situation.  The template consists of a ditch
with fixed dimensions (which are editable through parametric constraints) that also
provides an end condition component that will seek the existing terrain to complete the fill
of the existing channel to be abandoned.  The slope of the end condition component can
also be adjusted using a parametric constraint.

Below is an example of a cross section where a channel change might be needed:

A channel change corridor model is created in the same way as a lateral ditch (see Chapter
III).  In the above example, the outside edge of the shoulder will be used as the control line
along which the template will run.

After creating the corridor model, parametric constraints are then used to revise ditch
dimensions.  In the example below, the bottom width was reduced from 4’ to 2’, the
channel depth was reduced from 3’ to 2’, and the slope of the fill was changed from positive
2% to negative 2% as required by the site conditions.  Review the procedures in Chapter V
for how to apply parametric constraints to a corridor model.

https://youtu.be/VMcoLreO3BQ
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VIII. Ditch Intersections
Modeling the intersections of ditches presents some unique challenges, particularly if we
want models that can dynamically update in response to design changes.  The intersection
shown below illustrates a “side” ditch with PSRM lining entering a “main” ditch with riprap
lining.

The workflows detailed in this chapter are divided into two separate sections: a workflow
for V-shaped side ditches and a workflow for trapezoidal shaped side ditches.  Both
workflows can accommodate a main ditch which is either V-shaped or trapezoidal shaped.
In this manual it is assumed that the main ditch has a trapezoidal shape.  If the main ditch is
V-shaped, then substitute the phrase “centerline” for “bottom of bank” in reference to the
main ditch in the instructions below.

Procedure for V-shaped side ditches

A. Create horizontal and vertical alignments for the side ditch.   (Video)

1. Set the ribbon workflow to OpenRoads Modeling and set the default Feature
Definition to Drainage Baseline in the Feature Definition Toolbar.

2. Using Line Between Points or Complex by PI, create a horizontal alignment for the
ditch.  The side ditch alignment must extend past the bottom of bank feature of the
main ditch.  For trapezoidal main ditch, you can end the side ditch alignment by
snapping to the main ditch centerline.  If main ditch is V-shaped, then end the side
ditch alignment beyond the main ditch centerline feature by a distance at least
equal to the side ditch bottom width.  Provide a ditch name that meets NCDOT
naming convention such as L_32+89, LT.

https://youtu.be/YcNWt019gAw
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3. Select the side ditch alignment and from the flyout menu select Open Profile Model.

4. Go to Geometry > Vertical > Profile Creation and select Profile Intersection Point.

5. At the prompt Locate Element to Show Intersection, select the side ditch alignment.

6. At the prompt Locate Element Which Intersects, select the main ditch bottom of
bank feature.  A dot representing the profile intersection point will appear in the
profile model window for the side ditch.  This intersection point is ruled to the
bottom of bank feature of the main ditch so that if the main ditch is revised, this
point will move with it.  By snapping to this point, you create a dynamic relationship
between the profile of the side ditch and the profile of the main ditch.

7. Go to Geometry > Vertical > Lines and select Profile Line Between Points.

8. In the profile model window, identify the start of the first vertical tangent line by
snapping to the start of the profile (not necessarily the existing ground line, but the
vertical line representing the beginning of the horizontal alignment).  End the line by
snapping to the profile intersection point.

As shown above, if you have successfully snapped to the beginning of the profile and
the profile intersection point, when you select the line you should see snap
indicators at both ends.  It is very important this is done correctly so that the ditch
intersection model will dynamically update when design revisions are made.

9. In the profile model window, zoom in toward the profile intersection point, select
Profile Line Between Points again, and identify the start of the second vertical
tangent line by snapping to the point.
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10. In the heads up prompt Enter End Point, you will initially be asked to specify the
Length.  Press the right-arrow key on your keyboard to change the prompt to Slope.

11. Key in a value of -10%, press Enter to lock in the value, and be sure to snap to the
end of the profile (the vertical line between back and gray).  Make sure you see the
yellow “x” and the snap indicator before snapping to end the line.

The portion of the profile past the intersection point with the main ditch bottom of
bank line is to force the side ditch corridor model below the main ditch corridor
model.  Eventually, that portion of the side ditch corridor will be trimmed out.

12. The next step is to “complex” both vertical tangents together into a single profile for
the side ditch.  Go to Vertical > Complex Geometry and select Profile Complex By
Elements.  Name the profile L_32+89, LT.

13. At the prompt Locate First Element, hover your mouse over the first tangent line in
the profile model window, near its left end.  Note that an arrow will appear
indicating the direction the complexing will run.  The arrow should be pointed to the
right, in the direction of the second tangent line to be added.  See image below.
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14. <D> to confirm the direction, and then <D> again to accept the complexed profile.
Select the profile and confirm that both tangents highlight, indicating that they are
now part of a single complex geometry.

15. While the profile is highlighted, hover your mouse over the profile to bring up the
flyout menu and select Set As Active Profile.  This is an easy step to forget, but you
must always do this so that the profile is associated with the horizontal alignment.

B. Create corridor model for the side ditch.   (Video)

1. Go to Corridors > Create > Template and select Create Template.  When the dialog
opens, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and select NCDOT-
Hydraulics-Ditches.ITL, and then click Open.  Then close the Create Template dialog.

2. Select New Corridor and set the FD to HYD w/Contours.

3. At the prompt Locate Corridor Baseline, select the side ditch alignment.

4. At the prompt Locate Profile, <R> to accept the active profile.

5. <D> to confirm the corridor name and move your mouse to bring up the next
prompt to Select Template.

6. Press the ALT and down arrow keys to bring up the Pick Template dialog.

7. Go to Drainage Ditches > Head/Tail Ditches and select Trap_PSRM.  Click OK to
close the dialog and then <D> to accept.

8. Press the ALT key to lock the start of the corridor to the beginning of the alignment
and then <D> to confirm.  Repeat for the end station.

https://youtu.be/YcNWt019gAw?t=248
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9. Enter 1.0’ for the template drop interval, and <D> to accept.  The corridor will then
be created.  It should look something like the image below.

10. Review the procedures detailed in Chapter V to apply parametric constraints and
then make the following changes:

 Change value for Bottom_Width to 0 to change ditch to V-shape.

 Change value for Lining_Slope to 50% for 2:1 slope
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C. Use Corridor Clipping to Clean up the Intersection Model (Side Ditch with Constant
Slope)   (Video)

At this stage, the intersection model may be good enough for conceptual plan
development.  The horizontal alignments and profiles for both ditches have been
established, as well as the grading limits.  Once the layout of ditches has been finalized,
you can then proceed to the next step of cleaning up the model to trim off the
overlapping portions of the corridor models.

1. In the plan view window, turn off the level Draft_Corridor_Graphics_Final.

2.  Change the default feature definition in the Feature Definition Toolbar to
HYD_Construction.

First, we will create a corridor clipping shape for the side ditch:

3. Go to Geometry > Complex Geometry and select Complex By PI.

4. Snap to the intersection of where the centerline of the side ditch intersects with the
main ditch bottom of bank line, and the intersections of the top of bank lines for
both ditches, using “intersection” snap mode.

5. Extend shape around remainder of side ditch, capturing top of bank lines all the way
to the end, extending at 45 degree angles to allow for possible future revisions in the
skew angle.  See below for how the final clipping shape should appear. It’s very
important that snap rules are established for the three locations indicated, so select
the shape and verify that you see the snap indicators.

https://youtu.be/YcNWt019gAw?t=472
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Next, we will create a corridor clipping shape for the main ditch:

6. Using Complex By PI, snap to the same three intersection points as before, using
“intersection” snap mode.  Then, add a point offset from the main ditch top of bank
line to be sure that the entire line within the overlap area is clipped.  See example
below for how it should appear with both clipping shapes created.

Now that the clipping shapes have been created, we can use them to clip the corridor
models.

7. In the plan view window, turn the level Draft_Corridor_Graphics_Final back on.

8. Go to Corridors > Corridor Clipping and select Add Clipping Reference.

9. At the prompt Select Corridor To Be Clipped, select the template graphic for the main
ditch.  See image below.
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10. At the prompt Locate First Clipping Reference, select the clipping shape for the main
ditch.  Then <R> to complete.

11. Once again, go to Corridors > Corridor Clipping and select Add Clipping Reference.

12. At the prompt Select Corridor To Be Clipped, select the template graphic for the side
ditch.

13. At the prompt Locate First Clipping Reference, select the clipping shape for the side
ditch.  Then <R> to complete.  The intersection model should now be complete.

Procedure for Trapezoidal-shaped side ditches

A. Create horizontal and vertical alignments for the side ditch.  Use exactly the same
procedure as described above for V-shaped side ditch.

B. Since the geometry and corridor models for trapezoidal ditches are much more
complicated than for v-shaped ditches, civil cells are used to simplify the process.

1. If you have not done so already, go to Corridors > Create > Template and select
Create Template.  When the dialog opens, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and select NCDOT-
Hydraulics-Ditches.ITL, and then click Open.  Then
close the Create Template dialog.

2. Go to Model Detailing > Civil Cells and select Place
Civil Cell.   (Video)

https://youtu.be/ltQAzquq6Ns
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3. In the dialog that pops up, click on the ellipsis
button to bring up the Pick Civil Cell dialog shown
below.

4. In the dialog, select the civil cell named Ditch
Intersection.

5. At the prompt Locate Reference Element: Side Ditch CL, select the alignment for the
side ditch.

6. At the prompt Locate Reference Element: Main Ditch Bottom of Bank, select the
main ditch corridor feature for the bottom of bank.  If the main ditch is V-shaped,
then select the ditch centerline feature.

7. At the prompt Select Elements to View Alternatives, review the preview of the side
ditch corridor that is presented in the plan view window.  It should appear as shown
below, with the orange arrow pointing in the correct direction for the side ditch.
Move your mouse around if needed to get the arrow to show on the side ditch
rather than the main ditch.  You should also see a dashed white transverse line near
the intersection.  If arrow is pointing in wrong direction and you don’t see the line,
then try using a <D> to switch the direction.  If the preview looks correct, then <R>
to skip to the next prompt.
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8. At the prompt Accept Civil Cell Placement, <D> to accept.  The corridor model will
then be created and displayed.

9. Go to Model Detailing > Civil Cells and select Drop Civil Cell.

10. At the prompt Locate Civil Cell, select the corridor model for the side ditch.

11. In the plan view window, select the template
drop graphic for the side ditch corridor and
from the flyout menu select Properties.

12. In the Properties dialog, select the field for Template Name.  This brings up the Pick
Template dialog.

13. Go to Drainage Ditches > Head/Tail Ditches, select Trap_PSRM, and click OK.

14. Review the procedures detailed in Chapter V to apply parametric constraints and
then change value for Bottom_Width to 2’.

Important Note:

For trapezoidal side ditches, horizontal and vertical geometry and Point Controls for the
bottom of bank lines are included in the corridor model that was created through the
civil cell.  This is needed to “warp” the cross slope of the side ditch bottom so that it
matches the longitudinal slope of the main ditch where they meet.  This complication is
why civil cells are used for trapezoidal side ditches – to save the user the effort of
creating the geometry and Point Controls.  When the bottom width is changed through
a parametric constraint or template drop edit, you must update the side ditch geometry
so that the bottom width of these control lines match the new bottom width, as
detailed below.
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15. Turn off the levels Draft_Corridor_Graphics_Final and
Draft_Corridor_Point_Control.  The intersection should then appear as shown in the
image below.

16. Select the white dashed line on the right side of the side ditch.  Orange graphic and
text manipulators will then appear.  Zoom to the text manipulators shown near the
middle of the ditch, not either end.

17. Move your mouse over the orange text for the offset until you see it highlight
slightly.  Then click on the text and this will cause an editing box to pop up.  Change
the value from 2’ offset to 1’ offset.  Do this for both sides of the ditch.  The green
corridor model bottom of bank lines and the dashed white lines should now
coincide.  Be sure to use -1 for the left side.
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18. Turn the levels Draft_Corridor_Graphics_Final and Draft_Corridor_Point_Control
back on.

The ditch intersection should now look like this:

C. Use Corridor Clipping and Target Alias to Clean up the Intersection Model (Side Ditch
with Variable Slope).   (Video)

In the previous example, the side slopes in the side ditch were constant: the slope of the
grass and the PSRM lining were the same.  In this example, they are different.  When
variable slopes occur in either the main ditch or the side ditch, a more complex
approach is needed.

A greater density of template drops is needed in the vicinity of the intersection.
Therefore, a new template drop range will be created for that purpose.

5. Select a corridor handle for the
side ditch and from the flyout
menu select Create Template
Drop.

6. In the dialog, select the same
template as before:
Trap_PSRM.  <D> to accept the
selection.

https://youtu.be/ltQAzquq6Ns?t=242
daube
Highlight
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7. At the prompt Start Station, with your mouse, graphically identify the start of the
new template drop, which should be just before the intersection of the top of bank
lines for the two ditches.

8. At the prompt End Station, press ALT to lock to the end of the corridor and <D> to
accept.

9. At the prompt for Interval, enter a value of 0.1 feet and <D> to accept.  The corridor
will update.

10. In the plan view window, turn off the level Draft_Corridor_Graphics_Final.

11.  Change the default feature definition in the Feature Definition Toolbar to
HYD_Construction.

Next, we will create a corridor clipping shape for the portion of the side ditch bottom
which projects past the main ditch  bottom of bank line:

12. Go to Geometry > Complex Geometry and select Complex By PI.

13. Snap to the intersections of where the bottom of bank lines for the side ditch
intersect either the main ditch bottom of bank line (if main ditch is trapezoidal) or
the main ditch centerline (if main ditch is V-shaped).  Be sure to use “intersection”
snap mode.

14. Extend shape around remainder of side ditch, capturing top of bank lines all the way
to the end, extending at 45 degree angles to allow for possible future revisions in the
skew angle.  See below for how the final clipping shape should appear. As in the
previous example, select the shape and verify that you see the snap indicators.
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Next, we will create a corridor clipping shape for the main ditch:

15. Using Complex By PI, with snap mode set to “intersection”, snap to the intersections
of where the bottom of bank lines for the side ditch intersect either the main ditch
bottom of bank line (if main ditch is trapezoidal) or the main ditch centerline (if main
ditch is V-shaped).  Also snap to the intersection of the top of bank lines for both
ditches.  Then, add a point offset from the main ditch top of bank line to be sure that
the entire line within the overlap area is clipped.  See example below for how it
should appear with both clipping shapes created.

The next step is to use Target Aliasing to identify the break point where the slope
changes in the side ditch.

16. In the plan view window, turn the level Draft_Corridor_Graphics_Final back on.

17. Go to Corridors > Miscellaneous and select Define Target Aliasing.

18. At the prompt Locate Corridor, select the side ditch corridor model.  This brings up
the Define Target Aliasing dialog (shown on the next page).

19. Initially, nothing will be listed under the heading “Aliases”.  Find the existing terrain
and the main ditch corridor model in the list under the heading “Surface or
Corridor”.  For each one, select it and then click on Add to move it to the list of
Aliases as shown above.

20. Check the box for Use Closest, then click Apply.  In the 3D model view window, you
will see that the side ditch corridor model has now been trimmed by the main ditch
corridor model.  Click Close to close the dialog.
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Completed Target Aliasing dialog:

 Below shows the side ditch trimmed by the main ditch corridor model:

The clipping shape for the main ditch can now be finalized to clean up the intersection.
(Video)

https://youtu.be/ltQAzquq6Ns?t=523
daube
Highlight
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21. In the Feature Definition Toolbar, turn off the toggle for Persist Snaps.

22. Use Insert Vertex to modify clipping shape for main ditch by adding vertices by
snapping to angle point where the top of side ditch lining intersects with the main
ditch.  Do this on both sides of the side ditch.

23. Turn Persist Snaps back on.

24. Go to Corridors > Miscellaneous > Corridor Clipping and select Add Clipping
Reference.

25. At the prompt Select Corridor To Be Clipped, select the template graphic for the main
ditch.

26. At the prompt Locate First Clipping Reference, select the clipping shape for the main
ditch.  Then <R> to complete.

27. Once again, go to Corridors > Corridor Clipping and select Add Clipping Reference.

28. At the prompt Select Corridor To Be Clipped, select the template graphic for the side
ditch.
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29. At the prompt Locate First Clipping Reference, select the clipping shape for the side
ditch.  Then <R> to complete.  The intersection model should now be complete.
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Procedure for revising ditch intersections

The ditch intersection model is dynamic – it will update automatically to changes in ditch
dimensions, alignment, and profile of either ditch.  It will also update if the connection point
of the side ditch to the main ditch is relocated.  However, you should follow a particular
sequence when making revisions, and note the following for some particular circumstances:

1. If Target Aliasing is being used for a variable slope side ditch (V-shaped or
trapezoidal), turn it off before making revisions.  Simply open the Target Aliasing
dialog as before and remove the main ditch from the list of Aliases.

2. Make ditch revisions.

a. It is often helpful to turn off certain levels since many lines may be on top of
each other.  For example, if editing the horizontal alignment then turn off the
levels Draft_Corridor_Graphics_Final and P_HYD_Construction so that the
baseline is easily accessible.

b. If changing the bottom width of a trapezoidal side ditch, remember to adjust the
ditch bottom control lines as previously explained.

c. Depending on the scale of the revisions, you may need to adjust some of the
points in the clipping shapes that were placed free hand (not snapped).  This is
especially the case if the connection point between the two ditches has been
relocated.  Therefore, after making revisions always check the clipping shapes.

3. If Target Aliasing is being used, turn it back on after making revisions and re-adjust
the main ditch clipping shape.

4. If a civil cell has been used to create the side ditch corridor for a trapezoidal side
ditch, there is one type of revision that cannot be made: revision of the main ditch
profile.  The main ditch horizontal alignment can be revised, but not its profile.  If
this change is needed, then the intersection model will need to be deleted and re-
created.
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IX. Energy Dissipators.
This section outlines the procedure for creating a dynamic model for a standard NCDOT
energy dissipator, as well as the downstream grading transition.

Develop Design Parameters for Energy Dissipator

Complete the design the energy dissipator before attempting to model it.  The following
parameters must be identified:

1. “Wo” = span of conduit discharging to energy dissipator.

2. “A” and “B” = thickness of riprap lining.  For modeling purposes, it is assumed that A
equals B, but they can be shown differently on the plan details.

3. “C” = depth of the riprap toe wall at the downstream edge of the apron.  This is not
used in the 3D model, but will be shown on the plan details.

4. “D” = depth of energy dissipator.

5. “E” = width of the riprap apron at the downstream edge of the energy dissipator.

6. “F” = transverse length of the riprap apron.

7. “G” = length of the dissipator pool.

Create Horizontal and Vertical Alignment

1. Create a horizontal alignment that runs through the energy dissipator.  It must be a
straight line (no angle points or curves) until reaching downstream edge of berm,
and then end at that point.  The total length of the alignment must be equal to the
total length of the designed energy dissipator, which is “G” + “E”.

2. Create a vertical alignment, or profile, for the horizontal alignment and make it
active.  As shown in the NCDOT standard detail, the elevation should be the same
for the pipe invert, top of dissipator pool, and downstream apron.  Also, this
elevation should set to match the stream invert elevation at the downstream edge
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of the apron so that there is no drop off of flow to the existing stream bed.  See
example below.  Profile must include all the break points: 2:1 slope down to bottom,
flat bottom, 2:1 slope back up, and flat apron to the end.  Refer to the pictures
below.

3. Go to Corridors > Create > Template and select Create Template.  If not already
open, go to File > Open and browse to
C:\NCDOT_CONNECT_WORKSPACE\Configuration 10_10\Organization-
Civil\Disciplines\NCDOT_Hydraulics\Standards\Template Library and open the file
NCDOT_Hydraulics_Ditches.itl to access the template library for the next step.

Create Energy Dissipator by Placing a Civil Cell    (video)

1. In the OpenRoads Modeling workflow, go to
Model Detailing > Civil Cells and select Place
Civil Cell.

2. Click on the button with the three dots.

3. In the Pick Civil Cell dialog, select Energy Dissipator and then click OK.

https://www.youtube.com/watch?v=DyppJ2QylCw
daube
Highlight
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4. At the prompt Locate Reference
Element: Centerline Alignment, select
the horizontal alignment created
earlier.

5. At this point, you will likely see a jumbled mess of lines, and the prompt Select
Elements to View Alternatives.  <R> to skip this step.

6. At the prompt Accept Civil Cell Placement, <D> to accept.

7.  With the plan view window activated, go to Level Display and turn off all levels
except P_HYD_Construction.  It should look similar to the picture below.

The geometry of the civil cell uses a
tangent snap.  It is the nature of
tangent snaps that there are two
possible alternative solutions.  One
will be correct, and the other
incorrect.  Any incorrect tangent
snaps will have to be manually fixed.
In the above example, one line is
incorrect.  Sometimes both lines may
need to be fixed.
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8. Select the line representing the top of the dissipator pool side slope.  Move your
mouse pointer to the point where the line is tangent to the wrong side of the circle
and click on the Move Point graphic manipulator.

9. Set snap mode to Tangent Snap, and move the line and snap to the correct point of
tangency (see below).  Confirm the tangent snap indicator before you <D> to accept.
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10. The geometric layout should now look as shown below.

11. Go to Level Display for the plan view and turn on all levels.  See below for how the
plan and 3D model views should appear.
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Make adjustments to the Energy Dissipator     (video)

When the civil cell was placed, it was longitudinally “stretched” to fit the total length of the
horizontal alignment.  In addition, the elevations of the top and bottom of the dissipator
pool and apron were adjusted to fit the active profile of the alignment.  However, the civil
cell contains default values for many dimensions and these values may need to be edited to
match your specific design.

1. Select the Drop Civil Cell tool from the ribbon menu, and select the energy
dissipator in the plan view to drop the civil cell and leave behind the geometry,
proposed terrain model, surface template, and linear templates so they can be
edited more easily.

2. For the plan view window, turn off levels for Draft_Corridor_Graphics_Final,
P_HYD_TL_Ditch_Base, and P_HYD_TL_Ditch_Boundary.

3. For each of the two offset lines to
which the circles are attached,
select the line and adjust the
offset value (be sure to select the
text manipulator in the middle!).

4. Select the line for the bottom of the
slope at the end of the dissipator pool.
The offset values will at first appear gray
and cannot be edited.  <R> on the text
manipulators and they will turn orange
and become editable.  Again, be sure to
edit the middle value.

https://youtu.be/DyppJ2QylCw?t=127
daube
Highlight
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5. Select the line for the top of the slope at the
end of the dissipator pool.  The offset values
will at first appear gray and cannot be edited.
<R> on the text manipulators and they will turn
orange and become editable.  Again, be sure to
edit the middle value.

6. Select the line for the bottom of the slope at
one of the sides of the dissipator pool.  Edit the
offset value as needed.  Repeat for the other
side.  Pay attention to positive and negative
signs.
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7. Adjust the width of the dissipator pool by selecting the outside line on each side and
adjusting the offset values for each.

8. Adjust the location of the top of side slope by revising the value of the radius on
each side.
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9. To adjust the bottom width of the pool to match the span of the conduit, select the
back construction line, and then <R> on it to expose the text manipulators and then
change both the offset values as needed.  This is the first step.

10. Next, select one of the lines to the radius point, and change offset value.  Repeat for other
side.
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11. In the plan view, turn on all levels and turn off the level P_HYD_Construction.  Using
the baseline feature for the dissipator, create a profile model and then add a 3D Cut
to verify that the riprap matches the proposed profile.

12. Review the 3D model view.
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Create Downstream Grading Transition      (video)

The final step in the process is to model the grading downstream of the energy dissipator to
transition from the riprap apron (which was set at the elevation of the stream invert) to the
existing channel.

1. For the plan view window, turn on levels for P_HYD_TL_Ditch_Base, and
P_HYD_TL_Ditch_Boundary

2. Determine downstream point where transition will end.  The transition should be
approximately at a 3:1 ratio.

3. If the top and bottom of bank lines are available for the existing stream in the plan
view, then create lines connecting the top of banks at the downstream edge of the
riprap apron with the top of banks at the downstream transition tie-in point.  You
can skip the next step.

4. If existing top and bottom of bank lines are not
available in the plan view:

a. Place a temporary transverse line across the
stream at the transition end point and create a
profile model for it.

b. Select the linear feature for the downstream edge
of the apron and create a profile model for it in a
separate view window.

c. Set the default feature definition to
HYD_TL_Ditch_Top.

d. Place lines for each proposed top of bank line
through the transition.  Click on the top of bank
points in each profile model to set the start and
end locations for each line correctly.

e. Delete the temporary
transverse line at the end of the
transition.

https://www.youtube.com/watch?v=SDcr2r97Y-4
daube
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5. Select one of the top of bank lines and from the flyout menu open a profile model.

6. Go to Geometry > Vertical > Profile Creation and select Profile Intersection Point.

7. At the prompt Locate Element to Show Intersection select the top of bank line being
profiled.

8. At the prompt Locate Element Which Intersects, select the downstream edge of the
apron.  A pink dot will appear in the profile model window, which will be
dynamically tied to the elevation of the apron.

9. Set the default feature definition to HYD_Ditch_Baseline and go to Profile Line
Between Points and draw a profile line in the profile model by snapping to the
profile intersection point, and then snapping to the existing ground at the end of the
profile.  Select the profile and from the flyout menu make the profile active.  See
below.

10. Repeat the process to create an active profile for the other top of bank line.

11. Set the default feature definition to P_HYD_Construction.

12. Using the tool Single Offset Entire Element, create a construction line 1’ offset from
the downstream toe of the apron.

13. Set the default feature definition
to HYD_TL_Ditch_Bottom and
draw new complex horizontal
elements (using Complex by PI)
by placing three PI points: snap to
the end of the linear template;
snap to the end of the
construction line; and snap to the
end of the top of bank line
created previously.  Repeat this
process for the other side of the
grading transition.  See image on
next page.
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14. Turn off display of the levels Draft_Corridor_Graphics_Final and
P_HYD_Construction.

15. Select one of the edge of transition complex elements just created, and from the
flyout menu open a profile model.  Set the default feature definition to
HYD_Ditch_Baseline.

16. Create profile intersection points using the downstream edge of the apron and the
downstream end of the top of bank line.  See below.

17. Use Profile Line Between Points to place a vertical alignment between the two
profile intersection points.  Select the profile and from the flyout menu make the
profile active.  See below.
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18. Repeat this process for
the other top of bank line.

The 3D model view should
now show 3D features for
the two triangular grading
areas as shown.

19. Go to Modeling Detailing
> Apply Linear Template.

20. At the prompt Locate
Element to Apply
Template, select the edge
of transition complex element on the right side.   (video)

21. Press ALT and the right-arrow key to bring up the Pick Template dialog.  Expand the
Linear Templates folder and select the template named “Grass”.  Then click OK.
Then <D> to accept the template.

22. In the Apply Linear Template dialog, make sure that the boxes for Mirror and
Reflect are unchecked, and that the Feature Definition is set to HYD w/Contours.

23. At the prompt Start Station, snap to the beginning of the grading transition complex
element.  At the prompt Stop Station, snap to the end of the grading transition.

24. <D> to confirm the correct side for the linear template, and then <D> again to
confirm the exterior corner sweep angle.  <D> once more to skip entering a
description.  The exterior grading slope to existing ground should then appear in the
3D model view.

25. Repeat steps 21 to 26 for the
other side of the transition.
However, for Step 21 for the
left make sure to check the
box for Reflect, since the
grading slope goes the
opposite direction.

https://youtu.be/SDcr2r97Y-4?t=560
daube
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The final task to complete the grading transition is to create a terrain model for each
triangular grading area, and then apply a riprap surface template to each one.   (video)

26. Set the default feature definition to HYD_TL_Ditch_Bottom.

27. Go to the Geometry tab and create a
line for each of the two grading areas
along the downstream edge of the
apron as shown.

28. Go to Element Profiles and select
Profile By Slope From Element.  At
the prompt Locate First Element to
Profile, select one of the two lines
just created in Step 29.

29. At the prompt Locate Next Element
to Profile,  select the other line.  Then
<R>.

30. At the prompt Locate Reference Element, select the line for the downstream edge of
the apron (select it at a location between the two lines).  <D> to accept the
remaining inputs.

31. Repeat the process for the other side.

32. Go to Terrain > Create and select From
Elements.  Set the Feature Type to Boundary
and the feature definition in the dialog to
PT_Boundary.

https://youtu.be/SDcr2r97Y-4?t=661
daube
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33. At the prompt Locate Element to Add,
in the plan view, select the three sides
for one of the triangular grading areas.
<R> to accept selections, then <D> to
confirm remaining inputs.  The terrain
model will then be created.  Repeat for
the other side.

34. Go to Model Detailing >
3D Tools Surface
Templates and select
Apply Surface Templates.

35. In the dialog, select the
template Riprap_Class -
II_Surface.

36. At the prompt Locate a
Terrain Model, select one of the terrain models just created in the 3D model view
window.  <D> to confirm dialog inputs.

37. Repeat for the other terrain model.

The energy dissipator is now complete.
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X. Showing Ditches on the Plans.
As mentioned in Chapter I, this manual is intended to work together with the NCDOT
document “Ditch Drafting Guidelines”.  Display of ditches on the plans should conform to
that document.  This chapter provides procedures for how to support those guidelines using
the tools in OpenRoads.

The Hydraulics Unit staff will also need to provide the necessary information to the
Roadway Unit in order to support display of ditches on the roadway plans, profiles, and
cross sections.  The detailed procedures for this coordination are still under development
and will be included in this Manual at a later date.

A. Creating flow arrow lines   (Video)

As detailed in the Ditch Drafting Guidelines, flow arrows are to be shown for some types
of ditches.  For lateral ditches that use roadway slope stake lines as the corridor
baseline, the ditch corridor stationing must match the direction of the roadway corridor.
This means that sometimes the stationing for the ditch corridor will run upstream rather
than downstream.  Another issue is that for ditch intersections the alignment of the side
ditch must extend past the true end of the ditch to accommodate modeling
requirements.  For these reasons, the centerline feature generated by the ditch corridor
cannot itself be used to create the flow arrows by simply using a flow arrow linestyle.
However, the procedure below can be used to create the flow arrows from the ditch
centerline feature.

The Single Offset Partial tool is useful for many purposes.  If you set the offset value to
zero, then you can use the tool to “trace” an element to make a copy of it.  That copy is
then ruled to the original element so that if the original is changed, the copy will
automatically update.  The copy can have a different feature definition, level, etc.  As
the name suggests, you can copy only a portion of the original element if desired.  In
addition, the tool gives you the opportunity to make the direction of the copy the
opposite of the original, and we will make use of that feature here.

1. Go to the Feature Definition Toolbar and
set the active feature definition to
HYD_Ditch_Flow_Arrow.

2. Go to Geometry > Horizontal > Offsets
and Tapers and select Single Offset
Partial.

https://youtu.be/RxOWPe2eb5U
daube
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3. In the dialog, set the Offset to zero.

4. At the prompt Locate Element, select the ditch
center line feature (if a V-ditch) or one of the
ditch bottom lines (if a base ditch).  Note: for
base ditches you will need to complete this
process twice since a flow arrow is needed for
each ditch bottom line.

5. At the prompt Start Distance and Offset, snap
to the upstream end of the ditch centerline or
bottom of bank line.

6. At the prompt End Distance and End Offset,
snap to the downstream end of the ditch
centerline or bottom of bank line.

B. Obtaining Station, Offset, and Elevation Data   (Video)

Station, offset, and elevation of ditch control points are often needed for construction
layout, and the stationing is typically referenced to the roadway baseline.  The ditch
corridor model provides a ditch centerline in the plan view and a profile of this
centerline can be shown in a separate profile window.  Use the following workflow to
obtain roadway baseline station and offset, as well as ditch invert elevation.  For this
workflow, you will need to have two view windows open: one for the plan view, and one
for the profile model for the ditch centerline.

1. Select the ditch center feature and from the flyout menu select Open Profile Model
and select a view window if you don’t already have the profile model for
“+DITCH_MIDDLE” set up.  See image on the next page.

https://youtu.be/VWmLKmbZkAk
daube
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2. Go to Home > Model Analysis and Reporting >
Civil Analysis and select Analyze Point.  This is a
very useful tool, and it is recommended that
you include it on your Quick Access Toolbar.

3. Select the roadway baseline feature.  The
Analyze Point tool will now provide feedback relative to the roadway baseline in
both the plan and profile windows.

4. In the ditch profile window, snap to the start of the ditch centerline profile.  Zoom in
closely and be careful to snap to the very beginning of the profile.

5.  In the dialog for the tool, the station, offset, and elevation (“Z on Snap”) is shown
for the selected point.  The elevation reported by Analyze Point should match the
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elevation specified for the point control that was applied to the ditch corridor to set
the ditch profile.

Continue this process for each vertical PI point to the end of the ditch to obtain all the
station, offset, and invert elevation controls for the ditch.  This information can now be
used for plan and profile sheet annotation.

C. Showing Ditches on Roadway Profiles.    (video)

In accordance with longstanding practice, lateral drainage ditches (those along the toe
of fill slopes) as well as special cut ditches, are to be shown on the roadway profiles.
This is done by “projecting” the profile of the ditch centerline onto the profile of the
roadway baseline, as shown in the figure below which shows the plan view of a ditch
adjacent to a roadway:

When the ditch profile is projected to the roadway profile, the length of the ditch
measured along the roadway baseline will usually be shorter than the actual ditch
length.  However, it is possible that the actual ditch length will be shorter than the
projected length on the roadway profile if the ditch is located on the inside of a curved
roadway alignment.  For this reason, annotation of ditch lengths and slopes should use
data from the ditch itself, not the projected alignment on the roadway profile.

Geometry (horizontal and vertical alignments) for ditch designs should be located in
separate files from the Roadway ALG profiles.  In order to project the ditch profiles onto
roadway profiles, it is necessary to open and edit the Roadway ALG file where the
roadway geometry is located.  The file containing the ditch geometry is then referenced
to the Roadway ALG file, and the ditch profile projected to it using the procedure
detailed below.  After the ditch profile has been projected, the reference file for the
ditch could be detached.  However, if this is done the profile will lose its dynamic
connection to the source ditch design file.  Therefore, it is recommended that the ditch
reference file remain attached to the Roadway ALG file to allow for automatic updating
of the ditches shown on the roadway profiles and avoidance of unnecessary rework.
The following steps detail the process.

Length along roadway baseline

https://www.youtube.com/watch?v=cZg1wnrfNto
daube
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1. Open the Roadway ALG file and zoom to the location where the proposed ditch is
located on both the plan and profile views.

2. Go to Home > References and attach the DGN file containing the ditch geometry.
The ditch will then appear in the plan view.

3. Activate the plan view window and go to Home > Level Display and turn off all levels
for the referenced ditch design file except the level named P_HYD_Ditch_Baseline.

4. Hover your mouse pointer over the ditch alignment in the plan view, and from the
attribute feedback obtain the name of the ditch alignment.  In this example, the
name is “Y2_24+24, RT”.

5. Go to Geometry > Vertical > Profile Creation > Project Profile To Element.
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6. In the dialog, set the Feature Definition to Linear > HYD_Modeling >
HYD_Ditch_Baseline.

7. Change the Name to the name of the ditch alignment.

8. At the prompt Select Element to Project, select the ditch alignment in the plan view.

9. At the prompt Select Plan Element To Project Onto, select the road alignment in the
plan view.  The ditch profile will then appear in the profile view window, as shown
on the next page.
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The profile can now be incorporated into the drawing and sheet models for the roadway
profiles and annotated using the NCDOT annotation standards.

Please note that this same process can be used to project ditch corridor features such as
the ditch centerline feature, rather than geometry.  It will often be the case that ditch
profiles have been developed using point controls with “Elevation and Grade” method
rather than using vertical geometry.  In these cases, there will be no vertical geometry
to project and the corridor centerline feature will be the only feature representing the
ditch profile.
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XI. Ditch Quantities

Component Quantities   (Video)

This tool reports the quantities of components based
on a corridor model.  Go to Home > Model Analysis
and Reporting > Corridor Reports > Component
Quantities.  When prompted, simply select the
corridor and a report is provided as shown below.  In
addition to the cut and fill volume quantities, surface
area and volume quantities are provided for each of
the template “components” that were used to create the corridor.  Note that the
surface area values for grass do not include the surface area covered by riprap.  Also,
surface area values are not provided for components that have thickness such as riprap.
Unit costs can be entered into the report to generate an approximate cost estimate if
desired.

Volumes are calculated using the Average End Area method, and accuracy is determined
by the frequency of the template drop interval.  For this reason, the results generated
by the Component Quantities report are generally considered approximate, and
appropriate for preliminary analysis.

https://youtu.be/wNn6K71erCg
daube
Highlight
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Element Component Quantities   (Video)

This tool reports the quantities of components
directly from the 3D elements generated by
the corridor model.  Go to Home > Model
Analysis and Reporting > Civil Analysis >
Element Component Quantities.  When
prompted, simply select the corridor and a
report is provided.

Element Component Quantities are more accurate than Component Quantities since
they are not affected by template drops or the approximations inherent in the Average
End Area method.  This method also provides surface area quantities for riprap, unlike
Component Quantities.  However, the Element Component Quantities report only
calculates the volumes of closed shapes (components) in the templates used for the
corridor.  For this reason, earthwork cut and fill volumes are not provided.  Also,
quantities reported by station are not available, as they are with the Component
Quantities tool.  Therefore, it is recommended to use Component Quantities to obtain
the cut and fill volumes, and Element Component Quantities for the other quantities.

Quantities from 3D Mesh Elements

OpenRoads has a powerful set of tools that can create and utilize 3D mesh elements
generated from corridor models using the Create Cut Fill Volumes tool located at Home
> Model Analysis and Reporting > Civil Analysis.  This tool creates 3D solids, or meshes,
in the 3D model of the DGN file.  These are then used to compute accurate volume
quantities for cut and fill, as well as excavation of unsuitable materials, substrata, and
subgrade surfaces.  This is a complex topic beyond the scope of this Manual.  More
information is available through the Bentley Learn Server at
https://learn.bentley.com/app/Public/ViewLearningPathWithMasterCourseExpanded?lp
Id=113539&mcId=103116

https://youtu.be/wNn6K71erCg?t=47
daube
Highlight
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APPENDIX

List of Available Parametric Constraints



LIST OF AVAILABLE PARAMETRIC CONSTRAINTS FOR DITCH TYPES

Special Cut Ditches
Bottom_Width
Side_Slope_LT, Side_Slope_RT Only for median ditches
Ditch Depth Only for shoulder ditches
Grass_Slope_IN, Grass_Slope_OUT Only for shoulder ditches without lining
Lining_Height_IN, Lining_Height_OUT Only for shoulder ditches with lining
Slope_IN, Lining_Slope_OUT, Grass_Slope_OUT Only for shoulder ditches with lining
Lining_Thickness Only for shoulder ditches with lining

Head/Tail Ditches
Bedding_Thickness Only for ditches with a concrete lining
Bottom_Width
Grass_Slope
Lining_Height Only for ditches with a lining
Lining_Slope Only for ditches with a lining
Lining_Thickness Only for ditches with a ripirap or concrete lining

Lateral Ditches
Bedding_Thickness Only for ditches with a concrete lining
Bench_Slope Only for ditches with a bench at bottom of roadway fill slope
Bench_Width Only for ditches with a bench at bottom of roadway fill slope
Bottom_Width
Ditch_Depth
Grass_Slope_IN Only for grass ditches
Grass_Slope_OUT Only for ditches with a lining
Lining_Height_IN, Lining_Height_OUT Only for ditches with a lining
Lining_Slope_OUT Only for ditches with a lining
Lining_Thickness Only for ditches with a ripirap or concrete lining
Slope_IN Only for ditches with a lining, applies to both grass and lining

Channel Change
Bedding_Thickness Only for ditches with a concrete lining
Bench_Slope
Bench_Width
Bottom_Width
Ditch_Depth_IN
Ditch_Depth_OUT
Grading_Slope_OUT For fill area beyond the outside top of bank
Grass_Slope_IN Only for grass ditches
Grass_Slope_OUT
Lining_Height_IN, Lining_Height_OUT Only for ditches with a lining
Lining_Slope_OUT Only for ditches with a lining
Lining_Thickness Only for ditches with a ripirap or concrete lining
Slope_IN Only for ditches with a lining, applies to both grass and lining
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